H390 and H590 now Roon ready!


Question - i upgrade my Hegel H590 with the latest firmware what went very well.
However i am getting the following error when enabeling this device in the Roon Audio tab.

Any idea what is going wrong?

Kind regards,


Hi André,
A restart of your core probably will do the trick.
Good luck!

Hi Arlen,

Thanks for the suggestion which i already tried without any positive results.

Pull the network cable and wait for 30 seconds. That should fix it. The network card doesn’t reboot when you reboot the amplifier the normal way.


If this is indeed the case, it might make sense to include this recommendation in the Hegel upgrade guide.

Hi Andres thanks for the suggestion but that didn’t do the trick.

This morning i tried a difffertent roon core which didn’t have the problem and i was able to enable the roon functionality.

Next step I switcht back to my orginal roon core (grimm mu1) and the problem was back.
I d did on the grimm mu1 a reset of the roon database which resolved the issue.
Thanks for the advice

Kind regards,


Excellent point, and I will get that done.

I am glad it worked out in the end. Sorry for the troubles.

No problem - thanks for the quick advice

Now that Hegel is Roon Ready I have a question about how it works with my Innous server. This is probably a question for Innous but I thought I would try here.
Prior to Roon ready I simply used usb:
Innous as Roon Core => Hegel => Usb in => internal DAC
After the update, this option is still obviously available.

Hegel is connected to the network through the Innous:
network switch => Innous LAN => Innous Streamer out => Hegel

Question is, other than volume control what is the benefit of using the “roon ready” feature on the Hagel?

Also, is the Innous sending the file through my router?
Innous as Roon Core => router => Hegel Roon ready => internal DAC

or straight to the Hegel?
Innous as Roon Core => innous streamer out => Hegel Roon ready => internal DAC

The upgrade on my H590 went flawless. Lets see how my H590 Roon compares to my Auralic Aries 2.1 streamer. Exiting.


With a networked connection, you may put your server further from your amp. This might be more convenient and it might be better for the sound because there is less interference between computer and amp electronics.
Also, a Roon Ready connection might make it easier for your server. In my previous situation, I had a networked connection to the H390 using the Squeezebox protocol. With this, it was not quite possible to upsample to dsd and use a convolution filter simultaneously, because the processing speed was slightly more than 1.
Now it is about 11 or 12. So there are no problems anymore.
But all of this depends on your own situation, your gear, your ears and your tastes.

1 Like

It is very interesting. looking forward to the review.

Patience rewarded!

H590 updated Network functionality, now with full Roon integration.
Very happy Hegel remained determined to provide promised support. Just this once a pity have a lifetime Roon memebership already :wink:

Thanks Hegel/ Roon team!

1 Like

Well, upgraded my H390 now and what to say - I´m really overwhelmed how good the H390 is as a Roon endpoint!
Whatever you have as your Roon endpoint device - pull off the network cable and plug it in into your Hegel and give it a try…

My story: I’ve bought the H390 back in February this year and was only interested in its analog sound. So far so happy with its sound after my personal history of buying Amplifiers.
For Roon I used to have a dedicated Audio-PC with Windows Server and Audiophile Optimizer as the Roon Core.
Roon Endpoint until now was an Oppo UDP-203 with Oppomod upgraded parts.
The Oppo was connected via IIS to an Gustard X26 Pro DAC, and then via XLR to the Hegel H390.

After some serious listening sessions I can say that I don’t need the external DAC and the Oppo as Roon endpoint any longer…

I don’t know what’s going on, that the Hegel now is suddenly capable of outperforming such a good combo of DAC+Oppo via I2S, but my theory is, that always has been true that the shorter the signal path is the more clean the sound will be.
The soundstage is bigger in depth and width again now, the instruments do have way more space to breathe and you have sound information everywhere. I`m somehow “bathing” now in acoustic informations.
Now the Hegel H390 is really showing up…

Thanks for the sudden surprise of new adventures in listening with the Hegel!


After implementing Roon Ready, I can’t stop listening to my favorite records through my Hegel H590 for several days now. The sound is great and it seems to me that there is no need for further experiments to improve my audio system. Which makes it even a little sad. My system has never sounded so good. And the last two updates played a key role here. This is the appearance of Roon Ready, as well as the improvement of network stream due to the introduction of Adot MC01, Melco S100 and Plixir BDC Elite devices into the system. Now my Revel 228Be monitors sing in a way that even their creator probably did not expect. The appearance of Roon Ready was very positive and stopped me from spending unnecessary money on introducing new devices (specialized streamers, external DACs, etc.). Or maybe I’m wrong and it’s not worth stopping. It’s very interesting to hear from Hegel 390/590 owners who can now compare the sound of their systems with and without external streamers (Aurender, Auralic, Melco, etc).


Wonderful experience the Roon ready sound on my Hegel 390!
No need to connect an external streamer or Dac
I just sold it……(sorry NAIM)
Worth waiting.


The long wait was worth it :slight_smile: I just installed the update with no issues. Roon is perfectly integrated into the Hegel system and the sound is amazing on my H390. I wasn’t disappointed about the late update because it also worked great with audirvana. But now with roon it’s even better. Thank you @Anders_Ertzeid that you kept your promise and made the amp even better. Cheers Gerald


I have just updated my Hegel H590 to the latest firmware version to make it ROON ready. Unfortunately, the H590 appears under “Other Networkwork Devices” in the Roon application on my Mac Studio (as the Core). The Hegel shows that it is still playing 'via Airplay…"
Any ideas on how to enable it for ROON?