Having a Login Loop problem

Affected Product

Roon (login)

Roon Issue Category

Installation or Setup

Description of Issue

Hi. Long term user here without any big problems.
I had to stop en restart my NUC with ROCK. Then I needed to login again from my Macbook m1 (but it also did not work from my iPhone and second computer, Mac mini m2Pro.
I am getting into a ‘loop’ from Roon app login to the website login getting back to Roon app login. In Between the Roon waiting logo is shown. But nothing happens.
I have read some other login loop questions here. So I shut down my firewall, stopped my Sophos antivirus. I don’t have any add blockers. And changed my DNS server to cloudfare. I also tried a different browser. But nothing seems to help. Also not from the iPhone or other computer. What can I do?

Roon Core Platform

macOS

Roon Core Specifications

NUC ROCK i7

Connected Audio Devices

Auralic Aries G1

Home Network Details

LAN and WifFi

Screenshot

I just setup a server on my MacBook and when login in I get no problems at all.
(so at least I can listen to some music while figuring out what is going on ;))

Is my understanding of your problem description summarized below correct?

  • With Roon Server on NUC ROCK, login from MacBook M1, MacMini M2 Pro, iPhone results in login loop

  • With Roon Server on MacBook M1, login direct from GUI is ok

Yes, correct.
I installed a new server on my MacBook m1 (never have done that)
And I am able to login and have been listening for a couple of hours.

I was thinking: maybe I need to change some things on the NUC itself? Like DNS server or something? Never looked on the NUC itself since I bought it pre installed with ROCK.

I suggest you make a backup, then reinstall the NUC from scratch.

Also disable IPv6 on the router (although this failed to solve the same problem in two other cases).

I have IPv6 already disabled on my router. For the fun of it I put it on. But that made no difference :wink:

I have never installed a ROCK before so. I will check out how to do that.
I had an automatic Roon Backup yesterday. Is that enough backup to not loose anything of my Roon information?

Thank you for your help!

It’s working again!
But to be honest I don’t know what solved it.
I did several things:
Going to the IP address on my browser of ROCK I double checked everything. There was everywhere a green OK. I did a restart through there (had done that before) Then I saw under the network tab: wireless. I remembered I shut the wireless route of on my router. So just to try things I made it possible to connect also wireless. I can’t remember if I restarted my router or not. But when I try to login again I was transferred back into Roon but this time on a total black screen except for the Roon waiting logo.
Since I was cooking I let it do it’s thing and after more than 5 minutes Roon started working again.

So no clue what did it but I am happy again!

Thnx again for your help. And maybe this might help other people just for trying some things.

Hi @Ronnie_Zeemering,

Thank you for the report and we’re sorry to hear you experienced a login issue.

For our investigation, do you mind clarifying the following?

  1. Do you have Private WiFi enabled on any of your iOS devices in the Wifi Settings?

  2. What is your network topology here, and what was the make/model of the router involved? Do you have any additional switches or network hardware?

Hi Connor,

no problem. Luckily I had some time on my hands to ‘solve’ it. It is actually the first bad encounter in 4 years. So that is not a bad thing.

  1. I don’t think I have a private wifi connection. Never set that up. Or Apple might do that native for me?
  2. I have a Ziggo router that not functions as a router but only as a signal pass through for my router (forgot the name of the setup like that) It feeds a Netgear Orbi router.
    I have a Netgear switch between the orbi and the NUC ROCK

hope that helps you a bit.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.