HDMI Distortion from Rock / NUC to AVR

Yep, I made sure of it before I purchased this model -

And support has no help for you?

Roon did start not liking Nuc Rock since the last couple of months
No issue until then
I stand my idea: no reason to blame hardware perfectly working when only updates is Roon itself
The silence from support is, anyway, quite loud


No good sign. Did you already try the ROCK 256 update?

I remember Rock should automatically update when choosing Operating System Reinstall in the web interface…mine not doing it…am I mistaken?

Yes, obviously not that automatically :wink:. I placed a message here No automatic ROCK update from 254 to 256, though running with UEFI on NUC8.
roon says it’s only UEFI/HDMI related because before 256, HDMI ports won’t be recognized on some UEFI machines. This manual update can be done easily. And I had no issues at all with 256.
I think it’s worth a try.

Issue still exists.

OMG! Today, I got a new DSD64 5.0 file… and it began to stutter :rofl:
Here you see the signal path.

After fiddling with some parameters in the device setup, I saw it seems to be the buffer size. It was “default”, before I set it to the max (500ms).

I tested this several times playing the same DSD over and over again. 100% reproducible, in my case when switching between default and 500ms.


… if starting with a regular stereo AIFF and continuing with this DSD file, stuttering again. I then set the resync time to 6000ms. And after that, everything seems to be fine again.

What says your processing speed in the signal path…?

BTW, I have all roon DSP filters off. With your Denon AVR, do you have video selected or disabled for the roon HDMI port?


My first thoughts on the issues experienced is that I would recommend connecting the Core (NUC) as a source via HDMI or USB. I have and still occasionally do for tinkering purposes and prefer SQ when going to a dedicated Endpoint.

Do you have means to connect another HDMI Endpoint to your amp? I’d try this if you can. When I have it sounded better via the endpoint option.

In my case the NUC is already bridge only. So, roon server and library incl. music files are on a separate NAS.
If I’m correct, @JD_Cincy has all running on a single NUC.

My post was meant for them. Edited post.

The reason for the NUC was to allow me to do multichannel to the AVR, I thought it would be the simplest option.

Is there an endpoint that supports multichannel? My office Windows PC will do it. I could run Roon server from my office and put windows on the NUC, but that’s a very much overbuilt NUC to just be a windows endpoint.

Thank you for the response!

exaSound Rood Ready S88is one such device.

Alternatively, as @Matthias_Dauelsberg has a second NUC as an endpoint.

Also, will confirm later. I side loaded the latest gen Fire TV cube with Roon Remote and got it working. Didn’t try multichannel at the time as didn’t have anything connected. I now do and can advise later.

I also have everything running on the NUC (libraries on 3 USB HDD) connected via HDMI to the AVR…no intention to go into anything more complicated or costly than this
Considering it worked for two years without any problem or setting updare, issue is surely connected to some Roon updates

I also tried different buffers and delays, no change
And HDMI setup do not know…but never changed, think it’s as standard Denon settings

My NUC on Legacy, not UEFI (not supported at the time, if I remember correctly)

News on the issue?

I have not had the stuttering issue in ~3 weeks.

  • Changed nothing on my end config from my PC, NUC, AVR.
  • Not done any software updates to the NUC, PC, or AVR.

Roon has done 2 updates in that same timeframe… so either one of the updates addressed the issue or rebooting / restarting the software twice in that window has prevented it from recurring. I’ll update again in a week or so.

No improvement over here, even with the updates
Every mch above 24/96 or DSD mch has stuttering/distorsion

Mine still seems to work consistently. I did have an issue where the left surround speaker wasn’t playing in 5.1, but a restart resolved that… Not sure what changed aside from the recent Roon updates, but it seems to be pretty stable at this point.

I made some new experience with my NUC8 regarding (heavy) distortion.
Since I run my NUC with two drives, one for ROCK and one for Windows 10, I played a bit with new Windows application areas. One is video calls. That’s why I plugged a Camlink 4k into the left front USB port. I leave it there all the time.
Now, I turned on ROCK with the plugged Camlink for the very first time, listening to a 5.0 DSD… a desaster :roll_eyes:.
Stuttering, distortion, short repeats… whatever you like. Again, only with DSD (multi channel). I tried different things to no avail.
Then, I plugged out the Camlink, after pausing DSD playback. And all the distortion disappeared at once and for ever…
I had the Camlink plugged in, before booting ROCK. So, I don’t know if the ROCK Linux grabs the Camlink somehow though, ROCK cannot make use of it.
The Camlink is known to draw quite a lot of power from the USB port, even if not connected to a camera. So, it may also be some issue with my NUC or some if its BIOS settings.
So, take a look at your connected (USB) peripherals, too :point_up:t3:
This reminds me of your configuration, Riccardo_Sibilia. Three external USB drives :thinking:
Maybe one small step further :thinking: