HDMI Multichannel issues on Windows [Fixed in B196]

I have the same problem, ‘Channel Layout’ is greyed out and I cannot change it from 2.0 to anything else. I uninstalled and reinstalled RoonBridge on my NUC and its showing max 8 channels into the Oppo I have it passing into :

@support can you help please ?


This is an HDMI port on a NUC running Windows, correct?

WASAPI is one of the least well tested output mechanisms for Multichannel on our end. We don’t have many hardware configurations where it works compared to the others–but we can try to set up a NUC like this and see what happens.

One thought: since we know Roon works well with ASIO, maybe try using ASIO4ALL as a workaround for now. It might sidestep the problem until we can fix it properly.

Yes correct.

Do I install ASIO4ALL on both Core and Bridge ?


Just the bridge.

Done and enabled but Channel Layout is still greyed out :

Hm. That means that ASIO4ALL is seeing the same capabilities we are I think.

When you use this with other software, do you do something like Dolby or DTS encoding to get 8ch playback?

Sorry but not entirely sure what you are asking me ? On the NUC the only software installed is Roon Bridge, its not used for anything else

I was assuming that you’d used this NUC/HDMI for multichannel before with something else, since Roon’s multichannel support is new. If that’s not the case, then you won’t have an answer for me :slight_smile:

What I’m concerned about is: maybe this HDMI port actually only does 2ch playback of PCM, but it can support 8ch when used with Dolby or DTS or something.

Hopefully I can reproduce on one of the NUCs here and see what’s going on.

You mean the HDMI out of the NUC is possibly limited or the input HDMI into the Oppo ?

The HDMI on the NUC.

OK… well that’s a major bummer… MC playback was the thing I have been looking forward to most in Roon 1.3 :frowning:

Let me know if there is any further info I can provide you with… I have another ticket open relating to DSD to PCM conversion in 1.2… 1.3 didn’t fix that unfortunately


EDIT : I just intalled VLC on the NUC and tried to play a 5.1 FLAC and all I got was stereo output… Played a video that has DTS soundtrack and only got stereo as well… might be my ignorance of how to use VLC though rather than the NUC ?


My NUC (nuc skull canyon nuc6i7kyk) produces 5.1 sound through HDMI on my Pioneer SC-LX76.
It uses Intel® Display Audio Wasapi as the driver.

Roon 1.3 configured the same way shows Channel Layout greyed out… ;-(

I run Roon on windows partition of a Mac Mini and I’ve had the nearly the exact problems with the HDMI output to a Denon AV amp. However when I used my Macbook Pro as the output and selected apple HDMI core as the output 5.1 and 7.1 channel options were available.

Unfortunately the sound was output in multichannel but it was kind of digitized sound and heavily distorted. I have tried all possible combinations with DSP engine and all other options (DoP over PCM, vol levelling sample rate conv… etc.) on and off but the result was the same. In my case the multichannel files were 5.0 DSF files ripped from a multichannel SACD. Using the HDMI output stereo DSD files resulted the same way. On the other hand all FLAC files (HD or not) played fine.

By the way I have no multichannel FLAC files to try only DSD. Maybe if I had multichannel FLAC it would sound fine too. But I am not concerned so much about multichannel right now. I rather try to adapt the new features other than that. I’m sure bugs will be fixed soon if any.

Another interesting point to be mentioned for me is that, even select 5.1 stereo sources are changed to multichannel too. I guess Roon should have the option to play stereo as stereo even if the output is set to 5.1. Also I would like to see the option for 5.0 not only 5.1.

Exact same issue on a Pioneer SC 99 fed by a Windows 10 laptop.

Dear support and/or other visitors,

I’m still a trial user, but: WOW, what a stunning update today !
Just like many others, I’ve been eagerly awaiting v1.3. My reason for this was multichannel support.
With working multichannel, this would be an immediate purchase for me.

However, I can’t get this to work. I hope you can support or advise me on the following.

Setup is simple : I have an Intel NUC6i5SYH running Win10, and full Roon 1.3 build 193 64bit.
I use the Intel’s HDMI as sound output, and connect that directly to an AV receiver (Marantz NR1504). All the latest drivers for this NUC are installed.

When I try to setup Roon to output Multichannel, I get the following :

As you can see, only 2.0 is selectable. The rest is greyed out, as if it were not available on that device. (Yes, the receiver was turned ON before booting the PC).

But in reality the Intel DOES pass multichannel : I can play it perfectly fine in JRiver, and also the test procedure inside Windows device manager can correctly identify and play over each of my seperate speakers.

  1. Is this ‘expected behaviour’, or should Roon be able to output multichannel over the Intel Display Audio HDMI ?
  2. What can I do, or provide to you, to further troubleshoot this ?
  3. Could anyone with the same NUC try to reproduce this, and share your result ?

I’m quite an advanced computer user, so, feel free to get technical if needed.

Thanks very much in advance ! Best regards,
Marco de Jonge

Maybe I should add, that I found some sort of solution. A temporary, and not fully satisfactory one (because of stability, added latency and added cost of JRiver license) :

  1. Enabled the virtual ASIO sound card driver in JRiver
  2. Use this driver, as output in Roon
  3. Set this up in Roon, as Multichannel

Haven’t played much with it yet, but it does (often) work and output Multichannel correctly.
Not 100% stable and a bit of a ‘hack’, so I still highly prefer an option directly inside Roon… if possible ?

This does in fact prove, that it should be possible for Roon, to output multichannel over HDMI ?

On my Mac, I had to deactivate HDMI ouput in Roon, go into Audio Midi on the Mac, change the output from 2-channel to 8-channel, set the speaker setup to 5.1, then reactivate HDMI in Roon.


I use my Mac mini as a Core right now. My W10 PC is one of the remotes as well as currently the computer outputting HDMI audio to my receiver. I also tried connecting my Mac using HDMI but both only offer 2.0 output.

As a reference I’m using foobar2000 WASAPI and played some 5.1 and 6.1 music without problems. I’m guessing it was downmixing to 5.1 for the back channel.

Wonder if it is the chain of devices that confuses roon.
My monitor is only capable of outputting 2.0 stereo while my receiver is 5.1

My main curiosity is how you can develop surround sound support while ignoring HDMI which is used very frequently with most surround sound setups. Makes me wonder what kind of setups you actually tested.

Anything I can do to help?
Can you reproduce the problem in-house?
This still needs @support as it seems widespread enough when looking at fraction of actual users.

1 Like

The channel layout is grayed out and locked at two speakers.

I’ve tried both Mac and PC.

You can configure surround sound on PC but I found no such option on my Mac.

Regardless roon takes exlusive rights to the output device and has already decided it is stereo only.

My FLAC files playback fine in foobar2000 with wasapi plugin.
I don’t have a 5.1 system just to downmix to 2.0.
I’ve read that you only had limited testing with HDMI for surround.

I need some @support and is happy to facilitate the troubleshooting.

Thank you for the detailed instructions my Mac now plays surround through roon.

Still no solution for windows.