HDMI multichannel setup issues [Solved - Driver Issue]

Hi crew. Trying to get Roon to run multichannel in my living room on an Integra DTR-40.3 receiver. I am connected to it via HDMI from a Windows 10 PC with Roon Bridge installed. Roon audio settings sees the new endpoint — so that’s good! — but instead of identifying it as High Definition Audio Device (WASAPI), as with my Marantz prepro elsewhere in my home, it identifies only as System Output and even that, when enabled, says the device is not found.

Help appreciated. Thanks. JCR

1 Like

Hello @Jeffrey_Robbins,

Thanks for contacting support, I’d be happy to take a look over the issue you are facing here. Can you please provide a screenshot of your Audio Setup? This can be accessed in Settings -> Audio Devices and should look something like this:

Do you have the option to enable any audio outputs there that could be related to your Roon Bridge HDMI output there? Please let me know when possible.


Hello, @noris. I’d like to upload a screenshot for you, but I’m constantly getting the error message: uninitialized constant EXIFR::JPEG and can’t attach a photo. But, to reiterate, the only option is System Output and when enabling it, it says that it is not found. I do have 12 other Roon endpoints so I do know what to look for and it’s not there. What next? Thanks. JCR

Hello @Jeffrey_Robbins,

Thanks for confirming that for me. We can try a RAATServer refresh in your case to see if that triggers a change in behavior. To perform this action please do the following steps:

  1. Before anything, please make a backup of your Roon Database.

  2. Next, please close out of your Roon application

  3. Once the Roon application has been stopped please navigate to your RAATServer path by opening a Windows Explorer window and typing %localappdata%

  4. It should automatically take you to the location of where Roon and RAATServer reside (ex. C:\Users\USER_NAME\AppData\Local). There please locate and rename the current “RAATServer” folder that’s in place to “RAATServer_old”.

  5. Now that the RAATServer folder has been renamed, start the Roon application again to generate a new RAATServer folder. Please let me know if this help resolves your issue.


Hello, @noris. Creating a new RAATServer folder did not solve the issue, unfortunately. Roon still sees the HDMI-connected endpoint by IP address but still only shows System Output which, if enabled, continues to say Device Not Found. Next? Thanks. JCR

Hello @Jeffrey_Robbins,

Sorry to hear that a RAATServer refresh has not solved the issue at hand. I have gone ahead and created a case for further review with our QA team to see if they can provide some insight as to what could be going wrong here. I require some more information from you to pass on to them to understand the setup:

  • Can you please provide the Manufacturer and Model of your Roon Bridge Machine?
  • Can you please provide a screenshot of your Audio Page, listed under Setttings -> Audio (Note: We are having difficulties on our site uploading .JPEG images, please save the image as a .PNG in the meantime while we resolve .JPEG issues)
  • A detailed overview of your Network Setup - As in how is the Roon Core connected here? Is it hardwired directly into your Router or is it using WiFi? How is the Roon Bridge connected, wired or WiFi? Are you using any LAN switches or is it a direct connection from the Router? Are you using any Power-line adapters in the setup? Are the devices using an assigned IP address or are on DHCP addressing?

Please let me know your answers to the above when possible.


Hello, @noris.

I use a Small Green Computer CAPS Zuma i7 server.

Multiple pages make up my audio settings, but even in png, I can’t upload. If you provide a private email, I can forward the screenshots.

For the endpoint that is causing the problems here, the path is as follows:

Roonserver on i7 server - Ethernet to unmanaged switch - Ethernet to Orbi router - Orbi Wi-Fi backchannel to Orbi remote satellite (located on next level up in our home) - Ethernet to i5 PC endpoint running Roon Bridge - HDMI to Integra DTC-40.3 receiver. All DHCP.


Hello @Jeffrey_Robbins,

Thank you for providing the requested information, I have forwarded to the QA team handling your case. They have asked if you can provide some additional information regarding the hardware specifications on the Windows 10 machine running Roonbridge , specifically, what’s the Manufacturer/Model, CPU and what audio drivers do you have installed? Please provide a screenshot of your Device Manager on that machine and also a screenshot of the driver that HDMI WASAPI/ASIO driver information, screenshots should look something like this:

Please post it here or if image uploads are not working, you can also send them to contact@roonlabs.com.

Thank You,

Hi @noris. The PC running Roon Bridge is a Lenovo H320 — i3 processor 520GHz, 8 Gb RAM, with Windows 10 pro.

Here are screenshots as requested.

A little color on the screenshots above. As you can see, the only audio drivers showing are the Microsoft High Definition Audio Devices. And one of them is broken. As you can see, I tried to update that driver but Windows reports it as current. So, I disabled the “bad” one. It did. It have any effect on solving the issue at hand.

Since uploading screenshots is again working today, here’s a screen shot of my Roon audio settings just so you can indeed see that only System Output appears for the PC in question.

Um, doesn’t the Lenovo H320 have a Nvidia Graphics card, and won’t that be the HDMI connection? I see a Nvidia device listed in the Roon settings - what happens if you enable that?

I hear you. Where in the device manager list did you see that? I can check then to see if it is already enabled. JCR

Well, it’s listed in the Roon settings, but oddly enough in the Windows Device Manager, I see only an Intel HD Graphics adaptor listed… That may be the issue.

Here, for example, is what I see on my Desktop PC, which has an AMD Radeon graphics card. There’s both a graphics adaptor and a sound device listed…

For this PC, I don’t see the NVidia listed in Roon. Maybe that is another of my PCs acting as a Roon endpoint for multichannel.

And I see your point. Not sure what I’m supposed to do. Graphics properties are indeed controlled by Intel.

You should be seeing an entry for Intel ® Display Audio in the Windows Device Manager in the Sound, video and game controllers section…

Doesn’t that Intel Graphics control panel give you the way to update your Intel drivers? (it’s been an age since I had an HTPC that used that Control Panel…)

Hello @Jeffrey_Robbins,
Thanks for the screenshots, they will be very helpful in narrowing down what could be going wrong here. What happens if you enable the system output of the High Definition Audio Device for the Roon Bridge? Does sound work then? Highlighted the option here from your screenshot:

Also, can you please verify that you have the newest drivers installed from Lenovo? Link to download drivers is here:

I would update both the Audio Drivers and the Display and Video drivers you have. Seems like you have the Intel built-in graphics so I would choose this one from the list:
Intel Onboard Graphics Driver - Windows 7 (32-bit) Ver. 27 May 2010

And for the audio driver, this one should work for your setup:
Realtek High Definition Audio Driver - Windows 7 (32-bit, 64-bit) 27 May 2010

Please let me know your findings after doing so.


Hi @noris. OK, I uninstalled the High Definition Audio Device drivers and installed the Realtek instead. I also removed and installed the Intel HD Graphics driver you pointed to. That actually was an older version of what I already had. I did the driver update and it went back to the version that I started with.

When installing the new drivers, a reboot of the PC is required. Each time, the High Definition Audio Device driver reappears, but in broken form. Since I can’t seem to uninstall it and make the uninstall stick, I merely disabled it.

I’ve attached screenshots of the updated Device Manager and the driver details for both the video and audio.

Unfortunately, this made no difference to solving our problem. The endpoint still only shows System Output and when attempting to enable even that, it still shows Device Not Found.

Next idea? Thanks. JCR

Hello @Jeffrey_Robbins,

Sorry to hear that installing the drivers did not resolve the issue here. Hmm, I’m curious,when you connect the Roon Bridge computer to a monitor of some sorts (TV or Desktop Monitor) does the picture and sound show up? If you try to play a song off of Youtube on that without Roon anywhere in the mix, does it work?

If it works can you please note the name of the audio device in volume taskbar (lower right hand corner volume icon of the taskbar usually). I did a bit of digging and there was a user who reported the same issue as you were having on the Lenovo forums: https://forums.lenovo.com/t5/Lenovo-Desktop-Towers/h320-40411GU-driver-to-get-hdmi-ausio-out-to-work/td-p/1118069, seems like this may be an issue that affects the specific model you have and is not directly related to Roon. You should also check that HDMI has been enabled as per their specifications: https://support.lenovo.com/fi/en/solutions/ht034390.

Regardless, I will ask one of our senior developers what he believes this issue to be on Monday since they are gone for the weekend and let you know his thoughts. I would also give Lenovo a call or post on that forum topic to see if any progress has been made in that specific thread if my suggestions end up not helping here.


Hello, @noris. Well, this has been quite the learning experience. Here’s where I am at:

  1. As noted previously, only High Definition Audio Device was available and it showed a working and non-working version. I can’t make the deletion of that device stick, unfortunately, so I’ve merely disabled it.
  2. I installed the Reatek HD audio manager and the device driver relating thereto. It shows up as properly working as well.
  3. In both cases, I cannot get out any audio. Sounds merely reports that speakers aren’t plugged in. There’s no sign of an HDMI device.
  4. I’ve tried a different HDMI cable and that doesn’t solve the issue. In fact, I know the cable is fine – video is produced over HDMI just fine. But no audio.
  5. I thought maybe there’d be something to adjust in the BIOS. Unfortunately, this PC will not let me into the BIOS, only into the setup, and the setup has no audio settings of useful nature there.
  6. This PC was working fine as my multichannel USB Roon endpoint – USB out to a miniDSP U-DAC8. The hard drive failed and just before I opened this troubleshooting ticket, I had reinstalled W10 on the PC. I don’t actually know if HDMI audio worked previously, as I never used HDMI audio.
  7. Thinking my W10 reinstall didn’t work right, I pulled the drive, reformatted back to blank and again reinstalled W10 – this time directly from Microsoft and not off of a boot disc I’d previously made off of another W10 PC. Same issues going.

All of this tells me that there must be some hardware issue or motherboard issue or the like as to the HDMI on this PC. I saw the articles you linked and although I see some had the same issues, no one seemed to have a fix.

Since I ended up buying a replacement used PC to work as my USB multichannel Roon endpoint in my den, I’m going to hook that PC up to my living room setup with the Integra receiver and see if I can get that PC to work. Perhaps I can use the sick PC just as I had before – in my den as a USB endpoint and not an HDMI endpoint. I will report back on what happens next. JCR