Hegel H90 Airplay - Audio Issues

Core Machine (Operating system/System info/Roon build number)

Intel NUC8I5BEH / ROON ROCK v 1.0 (build 174) Server 1.6 (build 401)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router: Technicolor MediaAccess TG799vac
Switch x2 Netgear GS105

Intel NUC and Hegel H90 connected to Routher via Switch (Ethernet)

Audio Devices (Specify connection type - USB/HDMI/ect.)

Endpoint Hegel H90 (Ethernet) - via AirPlay

Description Of Issue

When streaming to my Hegel H90 I loose the Audio after around two hours continues playback. The track is still running in Roon-app (IPhone controller).

If I “Pause” and then press Play again, audio is back again.

I have had this problem since I installed the ROCK-server a week ago. Everyday…

Today I tried to use my Ipad as an Endpoint, and same thing occur. Around two hours…

What to do?

Do you need more info about my setup? Check log-files?

I wrote down time and tracks, at the time audio was lost. Today everything was fine 9:08 - 11:14 (around two hours again).

Try connecting using USB instead of network AirPlay.

You mean that streaming via Ethernet/AirPlay is a common problem?

I’ve been using Spotify (iPhone) via WiFi, streaming to my H90 without any problem. (for a long time)

Now I invested in a dedicated server (ROCK), connected to LAN, and can’t even play more than two hours :frowning:

Hi @lindstorm75,

Thanks for contacting us regarding this issue, and thanks for posting those details, I appreciate the timestamp. Ethernet/Airplay is no commonly an issue but before we take a deeper dive here can I pleas ask you to try two things?

  1. Try playback to the Hegel via USB as a temporary test. If things are stable via USB, then we know that we should take a closer look at the internet connectivity for any possible issues.

  2. We have previously seen the IPv6 implementation of Technicolor routers to cause issues with Roon. As noted in our Networking Best Practices, we suggest adding Roon and RAATServer as exceptions to Technicolor’s IPv6 firewall for proper communication.

Also, how is your Hegel connected in this network setup, is it connected to the same switch as the NUC or are they connected to different switches?


@noris Update:

  1. Yesterday I connected Intel NUC to Hegel via USB and played +5h straight without any loss of audio. Nice!

Today I connected both Intel Nuc and Hegel to same D-Link Switch (Ethernet/Airplay), playback for 3.5 hours … then no audio again.

Original setup:
Intel NUC connected to Router via Netgear GS105.
Hegel connected to Router via D-Link DGS-1005A

Note: More decvices like Apple TV, Computer are connected to switch aswell.

  1. Should I try to change settings in Technicolor router now? (Please describe how to)

Hello @lindstrom75,

Thanks for confirming that the Hegel works as expected via USB, this does further indicate a network configuration issue, especially since the iPad also displays this behavior.

As for the settings change in Technicolor, I have not previously used this router before so you may want to check in with your ISP on instructions. I have found this screenshot as a way to access the IPv6 settings but can’t see a field on how to add exceptions to the IPv6 firewall:

Typically to access the router configuration page you open up an internet browser and then type in the default IP address, usually and login is typically admin and password is password or admin but as I mentioned, this might be configured a bit differently so I would check with the ISP.

Before going through this process you might want to confirm two other things through. Is the behavior the same when both Core and Hegel are on the Netgear GS105 switch, and is the behavior the same when they are both connected directly to the router, bypassing any switches?


Hi @noris!

Today I connected both Hegel and Intel Nuc directly to my router.

Four hours playback, and then no audio again…

Should I try to connect both to Netgear switch aswell? Seems like the setup above should be more optimal, or?



It seems like IPv6 is disabled in my Router settings, se image (Local Network) below:

In Firewall:

Should I enable IPv6 and add something?

Hi @lindstrom75,

Thanks for confirming that IPv6 is disabled.

I would like to take a closer look at the diagnostics from your Core to see if there are any errors outputted when this behavior occurs. To make sure I gather the correct info to analyze here, can I please ask you to reproduce this issue and let me know the exact local time in your country (e.g. 9:34PM) when it occurs?

After receiving this info I can then go ahead and enable this feature.


See if you can use an Apple device (not ROCK) to AirPlay something (other than Roon app) to your system for hours without disconnection. This way we can see whether this is a problem related to Roon or not.

@noris New update:

Playback today (friday) using old setup: Intel nuc via Netgear switch and Hegel via D-link Switch (as described earlier)

Airplay via Ethernet.

+6 hours before audio loss (!)

Start: ~3:48pm - 10:07pm CET (last song: Too Deep - dvsn / Noll - Kent)

(Time stamp in server logs seems to be one hour behind though)


Start: ~7.43am - 9.48am (audio loss during song “Allt som är ditt - Säkert!”)

Setup as above.

@wklie Streaming Spotify from iPad (WiFi, no offline files) to Hegel via AirPlay, + 8h today. No problem!

I’m suprised that it’s more stable than my dedicated server (ROCK) on LAN/Ethernet…

Hello @lindstrom75,

Thanks for performing those tests. I have gone ahead and enabled diagnostics mode for your account and what this action does is automatically upload a set of logs to our server for analysis.

You mentioned that you ran this test on Friday, but I did not see any diagnostics report come in in the past few days. Would it be possible for you to manually send us the logs from your ROCK core using these instructions?

You can send them to us as a shared Dropbox, Google Drive or Firefox Send link and I can take a look afterwards to see if there are any errors being outputted at the timestamp you mentioned.


@noris I sent you a link to download my Log-files. (Message)

Hi @lindstrom75,

Thanks for sending those log files over, I am going to ask QA to take a look for any signs of the issue at the timestamp you specified. I appreciate your patience until my request reaches their queue and I hear back.


Hello @lindstrom75,

I appreciate your patience here. I just heard back from QA and they noted that the diagnostics were inconclusive as to narrowing the issue down. To further troubleshoot this issue, QA has just enabled some additional airplay debugging tools for your account.

Can I please ask you to reproduce the issue once more with this additional debugging turned on and let me know the exact local time and track that Roon experiences issue, as you have done so before? We are hoping that these additional debug traces will shed some light on where things are going wrong.



Playback tonight again:

6.49pm - 8.54pm - Audio loss during "A Day in the Life [2017 Remix] - Sgt. Pepper’s …
Local time CET

Hopefully you will find something… around two hours again.

Do I need to upload new log-files aswell?

Hello @lindstrom75,

Yes, please upload a new set of logs when you have a chance since I am not seeing any communication to our diagnostics servers from your Core at the present time.

You may also want to reboot your Core as that might re-establish the connection to our servers.