Help getting HQPlayer to work in NAA mode on Mac

After trying unsuccessfully to get HQPlayer in NAA mode to work with Roon, I am now trying to get it to work without Roon - upon the advice of many people in this form an in CA.

I have HQPlayer running on a Mac Mini that’s on the LAN. My DAC is an LH Labs Geek Pulse X Infinity is connected to a microRendu as the NAA.

I can access the Mac Mini via the network and I can see the microRendu in the Shared list on the Mac Mini.

In HQPlayer preferences in Backend, I have it set to NetworkAudioAdapter and under Device, my DAC is selected.

Here’s a screenshot of my preferences:

I imported a few tracks on to my Mac Mini to try, but the tracks just are not playing. The track will load and the play button is depressed, but the Time does not move. When I stop it and try again, I get the progress bar moving back and forth and there’s no way to stop it other than force quitting an application.

Does anyone have any ideas on what I could be doing wrong in my setup?



Update: I tried getting Roon to work in RoonReady mode using my microRendu as the endpoint and it worked fine. It took some playing around with but ultimately I got it to work.

Now I have two Zones, 1) RoonReady and 2) HQPlayer. RoonReady works great, but when I try to play through HQPlayer in NAA mode, I get the same dreaded error message that others have reported "Transport: Couldn’t connect to HQPlayer”. I can play HQPlayer directly in NAA mode with no problem, but once I launch Roon and change to the HQPlayer Zone, it will not play.

Below is a screenshot of my Roon Preferences. My Mac Mini running HQPlayer has the IP address of

Does anything look incorrect from what you can see?

Thanks in advance.


Hi Gary

Did you get this fixed yet?

Sounds eerily like the problem I had when I got my Sonicore SE. I recall it being something very simple. I am not at home at the moment but I will check my settings in a few hours and get back to you.



Have you enabled network access in HQP (far right button on the button bar)?

Hi Jonny, I had not fixed yet but I just read the message from Rene below and found the button Allow Network Control and it works! Yay!


1 Like

Hi Rene, thank you for pointing this out! I totally missed that in the manual. It works!



This seems like something the software should do for you. If you have settings that require network control, it should be turned on. Am I missing something?

If you have HQPlayer on your laptop and you are traveling around with it, you may not want to allow control from network in all places. For example in an airport’s or cafe’s WiFi…

Control connections within the same computer (from “localhost”) are always allowed. In many cases Roon and HQPlayer are running on the same computer, so the button is not needed in such cases.

HQPlayer has no way of knowing what kind of network you are in, so a toolbar button is provided for easily controlling access from external networks. Of course you can use firewall software as a primary layer of control anyway.

Thanks Jussi!

I have a similar problem-Also with MacMini
MicroRendu works fine with Roon. This is using RoonReady “Active” in MicroRendu
Would like to use HQP. Tried above suggestions clicking Network logo on-off in HQP.
HQPlayer NAA is “Active” when I click. BUT in HQP Preferences: Backend: NetworkAudioAdaptor. Device: Selection box is blank. Is the only way to run Roon > HQP> MicroRendu with HQP NAA?
What should I do?

Note that in first screen shot, HQPlayer shows localhost. Should I change this?
Thanks for any help.

Jeff, it seemed I had sort of the same problem as you. My problem was that the app switcher on the microRendu was still set to RoonReady and not to HQPlayer NAA (as I thought previously). When I changed this setting everything was working fine.

When I switch to HQPlayer NAA the green “active” button lights.
When I go to Apps> HQPlayer> HQPlayer EULA> there is no agree button in order to download MicroRendu software. I am already have a license for HQPlayer.

Am I to assume I automatically have this HQPlayer App as I never actually downloaded the HQPlayer EULA?

Also in HQPlayer Device Settings when I select NetworkAudioAdaptor the Device box goes blank, giving me no choice. This must be the root cause of my difficulty.

You only should have the HQPlayer on your MacMini - no need to download any additional software. By selecting the following:

NAA is activated on the microRendu and you should be able to see and select your DAC in from the HQPlayer on your Mac under NAA devices. Try this before you involve the Roon software.

For trouble shooting purposes you can download the Network Audio Daemon from Signalyst website and run this on a different Mac on your network and then see if you can select that particular device in NAA (this made me understand where the problem was).

Guys, I have a similar problem with microRendu and HQP. As my Hi-Fi is a long way away from the wifi and Internet routers, at first I tried to get a direct connection between my MBP and the microRendu. I read somewhere (can’t remember exactly where right now) that I had a direct Ethernet connection to the mR and a WiFI one to the Internet, if the wifi Internet access was shared in “Sharing” (System Preferences) several services could actually work, but not NAA. I managed to get Roon direct to mR working well.

Then I found an old switch I had gathering dust somewhere at home, and got that “in the middle” between the MBPro and the mR. I couldn’t get this switch to connect to the wifi network at home, so I kept my MBP’s wifi Internet connection shared. Again, everything worked fine while I keep myself to Roon straight to mR (no HQP in between). Whenever I tried starting up HQP (no Roon) and changed to NetworkAudioDevice, at first I got nothing (even though NAA player was Active in mR) to choose as actual device. Then I remembered the demon at the Sygnalist site, downloaded it and turned it on. With this helping whenever I chose NetworkAudioAdaptor the Device list filled with “default: Built-In Output”, “default: Built-In Input”, and similar stuff, but not the mR. How can I get to see the mR?

Thanks for your help… I’m beginning to think there is no other choice but to get a wifi router that can hang-on to the Internet wifi network at home but still reside in the middle between de MPB and the mR. Anyone has any other experience or idea? Thanks!


Wow. At wit’s end here.

I have a Mac mini running Roon and hqplayer. I open hpq and select the upper right hand button to permit network control and then go to hqp preferences and select network audio adapter in the backend drop down, but then no devices show up in the device drop down box.

Then, In roon, I have added hqp as a networked device, but I do not get sound out of that. Sometimes it seems to activate hqp, but I never get the tracks on hqp to play from the system.

I am running all of this to a Bryston bdp-2 server (roonready endpoint) and the DAC is a usb attached Accuphase.

Thanks in advance.

Does the Bryston bdp-2 run the NAA daemon ? I’m pretty sure it doesn’t.

NAA is to HQP as Roon Bridge is to Roon. If you want to send audio from Roon over Ethernet then you need Roon Bridge (or Roon Ready) at the other end. Similarly if you want to send audio from HQP (whether or not using Roon as a front end) over Ethernet then you need NAA at the other end.

You can download the NAA software at the Signalyst site and instal it on a suitable device, or you can use a SonicOrbitor SE or microRendu, which have NAA software built in.

If you want to keep the Bryston in the system and use HQP to an NAA then you will either have to persuade Bryston to include the NAA in its firmware or use a separate NAA device into another input on your DAC.

I’m having the same trouble described by James_Harvey above. I’m using a headless Mac Mini running Roon and want to try HQP. I purchased and loaded HQP based on the recommendations in your sound quality post, but cannot get it to work. The Mac Mini is connected directly to an MSB Analog DAC via USB. I’ve connected Roon to HQP in the Zones screen, but am not hearing any sound. I can’t find any simple instructions on how to set up HDQ to play through my DAC.

@jussi_laako how do I solve this? Are there simple setup instructions somewhere that I’m missing?

I am having the same issue with HQPlayer. At one time I had all running smoothly with the occasional drop out or stuttering due to bandwidth. I am using HQPlayer on a Mac Mini with Roon Ready with the core running on an Antipodes DX music server. The DAC in the Lampizator Amber II. The network adapter’s drop down no longer recognizes the DAC. Everything I have tried has failed.

With the new Roon version I was hopeful to again upsample to DSD 64 and 128. But for some reason that does not work with out a second or two of music then a note in Roon that say the media is loading very slowing and it moves on to the next song with the same message.