Help, my music has disappeared from Roon

Roon Core Machine

Nucleus + 32GB

Networking Gear & Setup Details

Netgear Nighthawk AX12

Connected Audio Devices

Atom Unity

Number of Tracks in Library


Description of Issue

Until recently I had over 700,000 tracks as listed in Roon, 2 days ago I added 6 albums but the albums didn’t show up in my Roon library and Roon is now showing 513429 tracks.

Also Roon has been behaving strangely ‘Adding music to library’ for the past 2 days incredibly slowly. I see 5 albums that just added which I already added to my library years ago.

When I look at my Storage Folders in settings I notice that Roon reports just over 20,000 tracks in my external drive attached to my Nucleus+ The number should really really be approx 400,000 tracks.

It seems that somehow everything from my external drive after artists starting from D has been deleted, not sure if there’s something wrong with the drive.
I have a fairly good backup, what’s the best way to restore Roon and use my backup for the music files?

The new Roon OS 2.0 had a new NTFS / USB/ FAT driver as far as I know.

Applying the update caused Roon to report funny date time stamps 2 hrs out and hence re-imported my USB drive all 55k tracks

Not sure if that impacts your issue but for info.

Did you reboot ? Another quirk is that after a restart Roon scans the USB drive but not the internal SSD. Maybe reboot and see

Mine is a NUC/ROCK 10i7 with a 4Tb internal SSD 5tb USB

Thanks for the info, I’m not sure if that’s the case or not. Though it could be.

I looked at ‘Library Maintenance’ and noticed that there’s 224140 deleted files listed, which perhaps might be the missing tracks, not sure if I should Clean them up or not as that might make the problem worse.

Roon seems to be importing tracks which at. the current rate might complete by the decades end :slight_smile:

Is that in the middle section or the top one , if top then those files don’t exist

My guess is the middle in which case it may be the path has been distorted somehow

Is Roon actively importing files NOW ? I would not clear those files just yet !!


When I switch on I See the lower drive scanning the drive the 57904 files eventually arrive. This is only the external USB drive the top one is a 4Tb SSD internal


Hi Mike,

I’ve Rebooted Roon several times, and nothing changed.

When you say ‘Middle Section’ are you talking about my Nucleus Internal Storage?

Last night I looked at the files on my external drive connected to my Nucleus and found nearly all the folders starting from ‘D’ were missing!!

So I copied all my music files from a backup to another spare drive, which is halfway through.

But looking at the both my music folders this morning on the Nucleus (SSD internal and external drive) ALL the music folders from A - Z are there, am I going crazy :slight_smile: or perhaps I was tired.

In the mean time Roon is still churning through my library and has brought in another 49 albums during the past 9 hours.

Is my External library drive corrupted? Is Roon making a new library index?

Perhaps I should shut down Roon, disconnect the External library drive, plug it into my Mac and see if the drive is faulty and disk utility needs to repair it?

If It is faulty and can’t be repaired I have my music back up.

Should I utilise an older Roon database backup?

Will my log files be able to throw some light onto what’s happening?

No the middle section I referred to is of the Library Maintenance picture I posted .

The top sections shows files that have been deleted but referenced in the Roon db , these are safe tio clear

The Middle section is files where the storage location is missing but the files are still referenced in the Roon db (think a USB drive that has been removed). Roon will still keep a reference to these files even though they are “unavailable” This sounds like your case. Clearing these would remove that reference so when the Drive is active again it would have to re-import - LEAVE ALONE for now

It does sound like the drive is suspect, is it mains or USB powered and was in dismounted from PC/Mac properly

That rate of import is very slow , not normal, may be the drive but something is wrong !! Importing is not the time consuming part, the Audio Analysis takes much longer . For example a 114 CD box took 2-3 minutes to import …

Your plan on checking the drive is good, then make sure its dismounted safely. Also Roon recommends exFAT formatting , I have used both NTFS (Windows) or exFAT and found them much the same.

Post back when you have checked the drive., don’t restore an old BU yet , as per the logs I have never delved into them so no comment :heart_eyes_cat:

Roon has stopped indexing my music and now lists 720,859 tracks, previously I had 721,304.
The library in Roon seems to be in a different order than it was, but then with about 40 albums missing perhaps it reflects that.

So somehow 445 tracks have disappeared, which points to disc corruption.

I was planning to plug in one of my backup discs to see how many tracks I have using it.

One of my backup discs are Exfat and the other is Mac OS Extended.

Should I do that and not use an older Roon database backup?


I would first check to see whether Roon has skipped any files during the import process. Go to Settings > Library > View Skipped Files.

hi Geoff,

They are some corrupt skipped files listed, but only 5 in October, 2 in Sept and about 30 in Aug. None in November though.

It points to a corrupt location on the disk that hasn’t shown up in the skipped file list.

Any further isights that you could offer?


Try Settings > General > Show Hidden Tracks , it will then show duplicate albums and tracks

Toggling the setting on and off doesn’t make a difference to the track number.

Hey @Paul_Elliott,

It’s great to see you on the Roon Community! I apologize for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and are working as quickly as possible to get back to everyone.

Following up on this thread, are you still running into issues getting your library properly sorted? I do think it would be good to check the external drive in question for corruption. With that, can you access the Nucleus webUI and share a screenshot?

I’ll be monitoring this thread for your reply :+1:

Hi Benjamin,

Thanks for getting back to me.

I’m having problems with my music storage hard drives, I’ve been trying to use a backup of of my external drive which had a larger amount of songs. I’ve been running SongKong on it to remove duplicates until SongKong aborted the operation after losing contact with MusicBrainz. I just tried to add a couple of albums to the backup and was prompted to enter my password. I entered my Mac password but recieved the error message “The operation can’t be completed because you don’t have permission to access some of the items.” I looked at the sharing and permissions of the drive and everything is set to Read and Write. My next move is to disconnect it from my Nucleus, plug it into my Mac and run First Aid.

1 Like

Hi Benjamin,

One of my music storage backups is up and running and seems to have the correct amount of files though I have over 1000 duplicate albums and so I have to do some serious pruning on my files.

Can I post an ARC issue here? ARC on my iphone sees my Nucleus+ and in Roon at home Roon reports that ARC can securely access my Roon core. But there’s no musical content displayed in ARC.

@Paul_Elliott, re: ARC. Can you confirm you have the most current version of ARC on your iPhone? Under ARC’s settings page (select the gear icon on the first tab), you may need to reset ARC by selecting that option at the bottom of the settings menu.

Hi Rob,

Yes I do.

I reset ARC as received the message “Your Roon Core was automatically configured and has been confirmed to be securely accessible by Roon ARC.”

Still no content, no music displayed in the app.

Are you seeing any error from within ARC that there is a poor connection? If you use ARC over your WiFi connection at home, does ARC work, showing your entire library and are able to play from it on your phone?

It does the same at home, i can see my photo under Who’s listening today? But there’s no content.

Hey @Paul_Elliott,

With Arc, I would suggest starting with the basics - power cycle your router and core, remove arc on the mobile device, power down, and re-install Arc. If you could provide screenshots, that would be helpful as well :+1:

Strange, but it seems to be working for me now, though a little erratically and slow. Perhaps it was an issue with having such a large library (over 700, 000 songs) and it needed to index the library??

1 Like