Help! My remotes (iPad and iPhone) won’t connect with Roon (ROCK)

I am not sure what happened but both my iPad and iPhone remotes stopped connecting right away with Roon (ROCK on NUC 6i5 in Akasa fanless case).
The problem happens either from a reboot or from turning the NUC off/on.
It have not been any changes in my network settings as far as I can tell.
It eventually connects only after several steps.
Please see the sequence that I have to fallow in order to get a connection:

Thanks in advance for your help.

Hi @JoseL,

After rebooting, when you’re in this state, does RoonServer show that it is running in the Web UI? You can refresh the page after rebooting to verify if it is running.

Yep, that seems to be the problem. The server is lagging behind the OS. I tried several times and it takes 2-3 minutes to start running after which the remote connects without further intervention.
I must add that during that time the server seems to randomly alternate between “Not Running” and “OK”. Also I reinstalled the OS from the web UI to no effect. I tried too direct connection of the NUC to the router but still shows the same behavior.
Please advice.

Hi @JoseL,

Thank you for clarifying the error state here. We are aware of a few similar reports regarding this behavior and there is an active QA investigation at the present time. This investigation may take a bit of time, but I will add your report to the the ticket. If there are any other details that we need we will be sure to let you know, thanks for the additional data point!

Is there any progress solving this issue? The problem (see above) persists after updating the server and the remotes to the latest software version.

Hi @JoseL,

Thanks for pinging me regarding this issue. We performed a lengthy investigation into this behavior and have made significant progress in identifying the root cause of this issue.

A resolution for this issue will require a RoonOS update, and this RoonOS build is still in the final stages of QA verification.

Once it’s ready, we will make an announcement in our Release Notes Section of this site and your ROCK should automatically update.

I can’t specify an exact timeline of when the new build will complete verification and be published, but we’re working on it and hope to have some news soon. Thanks for your patience until the new build is released.

Hi @JoseL,

We’ve recently released RoonOS (Build 186) which includes changes that should improve this behavior. Please give it this a try and let us know how it goes!

You can read the full release notes here:

The Team at Roon Labs

Working fine now! Thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.