Help please with Pi 4b - 7” display

Am having exactly the same problem that occurred in this thread

I insured everything was as discussed in the thread but to just reconfirm
1, The display is an official 7" pi display
2. I formatted an sd card with the latest ropieee release
3. I configured and rebooted the pi.
4. the cables (both ribbon and 2 power/ground jumper cables) are properly attached.
5. I have tried 4 different ribbon cables.
6. I have measured the voltage across the display where the jumper cables are connected and see 5.4v
7. Yes, i have an official 5v, 3a power supply.
The pi is functional and ropieee works as expected except for the fact it does NOT detect the display at initial installation or if i change a configuration. Yes, i rebooted each time i was informed i needed to.

Is there any way to determine if the display is bad. Shouldnt, when power applied, a backlight be on and i could see a (slight) change in the display? such as from black to less black … but clearly visible in a dark room?

Any ideas or suggestions?
Thanks, in advance

In case you want to see the details of my pi

Try a Micro USB power connection instead of jumper cables.

If that fails, you could also try RPi-OS or DietPi to verify proper display function.

Can you send me feedback? You can find that option on the ‘advanced’ tab.

Thanks, Harry
Feeback sent 19870e5dfdad07ef.
Sorry, i did not capture the first feedback identifier and had to resubmit. Sorry, not trying to make you do more work.

I did try the micro usb connection first and that had the same result. Nothing.
I thought about the other OS’ and install them but since i have no experience ever in their use, i was thinking going down that path was a rathole that i would never get out of


Your screen is unfortunately not recognized.

Is it properly connected?
So when you start the unit you see ‘stuff’ happening? ‘Stuff’ in this case is the OS booting which should generate a lot of text…


Yes, the screen is not recognized.
Yes, i have connected and reconnected at least 5 times.
The OS is working fine. I believe the screen is what is bad but i have asked dozens of people on how to test the screen to see if it is bad or not and have never received an answer.
I would have thought, applying power should, at a minimum, allow me to see the backlighting light up which would give me an idea the screen is at least partially functional. Applying power via the connectors from the pi or directly from the usb provides nothing visually different than when there is no power supplied.

Dumb question, do you have the ribbon cable inserted the right way around (contacts are only on one side!)

Please dont get me wrong, i do not think ropieee had anything to do with the problem. I was posting here because i was hoping someone had been through the same thing or could point me in the right direction.
The software is working great and it always has for me.
Thanks for checking to remove ropieee as a potential source.
Seems like its the display.

i am confident i have them inserted correctly. even if i didnt (which i do) that shouldnt stop it from powering on, it would only disallow data to flow from the pi to the display since that is a data cable only. a backlight should still be lit if powered on.

The backlight can be turned on, varied in brightness, and turned off via commands over the ribbon, IIRC

to circle back around and let those that tried to help know what the problem was … it was the pi itself. There appears to be no output from that pi. I switched pi’s (same model etc) and i got immediate info on the display.
That was the last place i thought to look.
I feel bad for amazon as i returned 2 displays as faulty :frowning:

Edit: ah, I see you sorted it. A bad RPi.

Have a watch of these

I also think you need Ropieee XL

Have ropieee xl. no longer have bad pi