Help? Unable to use iPad endpoint to DSD USB

I have an unused iPad Mini 4, and would love to get it working with Directstream DAC over USB.
It works as a Roon endpoint, and it plays from Roon on the internal speakers, but I cannot get it to play to USB via either of the Apple “Camera” adapters, no matter what I do. If there are any iOS settings that might steer audio to the USB adapter, I can’t find them. iOS is v12.1.4, Roon is 1.6 (401)
All software and firmware on all the boxes is the most current. I’ve tried every combination of settings, Power cycling, and known-good USB cables I’ve got, but the only choice of output Roon offers from the iPad is Speakers.
The USB display on the dac shows a green dot, indicating that it sees a USB connection, but the darned iPad does not play to it.
What am I missing?

There are others that will know more but I think I’ve read that the Lightning to USB adapter gives iDevices only limited functionality: it’s intended to permit file transfer from cameras but not to provide general purpose USB connectivity. (Typical of Apple!)

Just to be clear, you are saying that when connected to your DAC, via a lightning to usb adopter, the DAC is not showing up as a device for sound output within iOS?
If your Mini 4 can see the DAC, then ROON will work with it. If it can’t see the DAC, then maybe the DAC is not compatible with iOS?
I have an iPhone 6s working very nicely with an Oppo portable dac/headphone amp. I can see the dac when I swipe up from the bottom of the iphone screen.

Correct - the iPad does not present the Camera adapter>DAC anywhere I can find as sound output, although it sees the camera adapter and updated it.
The PSA DAC is working fine with iPad for others - some have suggested it needs a powered USB hub?

Doubt it, but you could try.

Strange, I use a Dragonfly Red with a Camera kitwith no issues

I’ll try iPad USB to my DAC tomorrow, I already have a cable connected

I think this may be related to the Directstream DAC.

I connected my Audiolab m-dac to my iPad via A Camera kit and USB input to the DAC

Roon sees the iPad but not the DAC

I repeated with my Win 10 tablet, Roon now sees the M-DAC , even shows it’s name and device setup

Conclusion? An Apple issue , no doubt an Apple laptop would replicate my Win 10 behaviour

OK - here are pix of the setup. iPad endpoint to USB via camera adapter. I cannot get it to play to the PSAudio DSD DAC. In these pix it is playing to ipad internal speakers, the only apparent choice.

Audio settings page

ipad setup

Advanced setup

green light on DSD showing USB connection

camera adapter showing on ipad

signal path shown at ipad

I tried an Apple laptop, and discovered that it is limited to 192/24. Might as well use the Bridge.

I believe you are mistaken, the iOS and MacOS units should be able to do PCM384/DSD128 without drivers.

A bit difficult to read, but this is playing PCM352.8 over WLAN to my iPad.

1 Like

PCM768kHz and DSD256 fine for me too… with an iPhone.

What generation of iPad are you using? Perhaps that’s my issue - mine is an iPad 4.

Also, what is “EMS” in the signal path? I’ve never seen that before.

I really want to get this working, and I’m about to order a refurb iPod Touch. Has anyone got that working?

Just a name I gave the iOS endpoint… you can call it whatever and it will show in the signal path like mine.

This isn’t running the current version of iOS right? Maybe that is it.

Got another iOS device in the house that is running current iOS? Just to test with.


That one is an iPad 2018, so fairly new. I can try something else later this afternoon using my iPone 6 as endpoint.
I did notice in your second screen shot that you have the option “Convert to PCM” set for “DSD Playback Strategy”. That will of course disable DSD in any shape for your DAC.

I gave up on the iPad and I’m now using a Mac Mini running Roon Bridge through a Matrix X-SPDIF 2.

I’m using the latest version of the cheapest iPad model (on sale now for $249) as an endpoint and it works great. You do need to use a usb camera adaptor. I play DSD using DoP but that’s because of my DAC.