Help with keeping Mac awake

Power Saver set to off, Roon still stops when Mac goes to sleep.

Setting the slider to "put to sleep does not work.

Did something go wrong with this post? Screenshot of what I see:

Is my request accepted? Mac goes to sleep even if hard disks do not go to sleep. Why?

Im not sure that we know what your request is.

It was posted but looks weird, see above

This is a Mac issue, not a Roon issue. Macs go to sleep. Tips for macOS Ventura:

There is also a free app “Amphetamine” in the app store that helps preventing sleep:

1 Like

I set the Power Saver function to not turn off hard drives. Yet the Mac and Roon as a result go to sleep. Why?

Because hard drives being turned off are not the only things that make Macs go to sleep (at least new ones). See above

1 Like

OK fair enough. I tried to open Amphetamine but not successful. Any thoughts?

The app just sits there. No activity.

You have to start a keep-awake session and configure what should happen or not happen. Click “more” in the App Store description and it gives some instructions:

1 Like

Try …

System Preferences → Displays → Advanced, and make sure that ‘Prevent automatic sleeping when the display is off’ is activated:

Hi ged:

I am sure this is addressed elsewhere, but I cannot find it. I have an iMac with current operating system running Roon 2.0.

Where do I set or unset the autosleep time>

I have gone to Settings and Privacy but cannot find that setting.

My iMac is going to sleep after about 40 minutes.



System Settings → Energy Saver

1 Like

Hi DaveN;

PLEASE tell me where under Settings you are seeing these options. I do not see them.

Should I be looking outside of ROON/ Where??

Yep, outside Roon. System Settings on your iMac.

Screenshot 2023-10-29 at 20.47.19

I am using System Settings from Apple menu. Should I be using something else? Where is it?


Yep, that’s the one. It should, if you’re running the latest OS, look like the screen grab I posted a few posts ago.


No good.

I am running the latest OS.

I found the settings/energy saver. But the settings do not work for me.

Roon still shuts down after about 30-40 minutes.




Look for an app called Amphetamine in the App Store, it lets you configure in detail how the Mac should stay awake in different states

I have downloaded Amphetamine from App Store. How do I launch it?? Not sure how I use it. So far not much from the software.


Double click, as with any other app, and it will launch into the menu bar:

If you want to keep your Mac from going to sleep pick one of the options from the dropdown menu.