Hiccups with DSD

Thankfully I don’t have many DSDs, though… :neutral_face:

Ripped a couple of new SACDs yesterday and added (dsf files) to my Roon library
Today I would have liked listening to them but… I’m getting way too many hiccups (one every few seconds)

dedicated headless Mac mini quad-core i7, 2.3GHz, 16GB RAM, 128GB SSD, Mac OS 10.11.6, running Roon core and nothing else
Auralic Aries (femto) in Roon Ready mode
Audiophilleo SE
Chord 2Qute
files on a dedicated Qnap HS-251 (SMB is the one and only service enabled. NAS is only accessed by the Mac mini)

tried to no avail:

  • reverting Aries’ firmware from 5.0 beta 4 to stable 4.1
  • replacing a gigabit Netgear GS105v2 switch with a 10/100 PaulPangAudio (modified Zyxel) one as, last time I had this very same issue… doing the opposite apparently fixed it :open_mouth:

PCM 192 play just fine (when I had this issue a few months back they did not)

I believe this all started with Roon 1.3

a Chord Mojo directly connected via USB to the Mac mini… plays (almost) flawlessly even DSD 256 (just one little hiccup a few seconds into first track)


I have the same issue with my Mojo, it doesn’t particularly like DSD. Occasional dropouts.
Is it a Chord thing? My Audiobyte Black Dragon does DSD128 without a single glitch… (from the same source, a MacMini 2011 used headless as a Roon Bridge only)

If i drive these both from a Raspberry Pi the dropouts @DSD128 are more frequent but still only affect the Mojo…
Now, this is NOT a big issue for me as the Mojo sounds best at native resolution or uppsampled to very high rez PCM (>352.8Khz)

I think it is a chord issue. My Hugo also have random dropouts even with with DSD64 but 384 PCM is ok.
So I suspect it is crapy DSD support.
My next DAC will not be a Chord DAC also because they do not support MQA.

though… Chord Mojo directly connected via USB to the Mac mini only has very light issues with DSD 256

so, maybe, it’s an Aries + Chord DACs issue
and again… all was fine, afair, with Roon 1.2

ok: I’m now playing DSD directly from the Aries to the Chord 2Qute and having no issue at all

Aries is playing the very same files, on the very same NAS, that Roon does not play smoothly
nothing but Roon being out of the equation changed

so… @support please

been playing DSD 64 using the Aries for more than 1h and… only had one tiny hiccup right now
(with Roon I’m having one every few seconds, right from the very instant playback starts)

hiccup occurred, towards the very end of a track, while the Aries was pre-loading next track into RAM (at 11MB/s, according to NAS’ network activity graph, whilst during playback it’s just a few bytes/sec)

will try later today going back to the gigabit switch (I’m using a 10/100 one at the moment) and see if it happens with it too

still with the 10/100 switch, still from the Aries direct (no Roon) to the Chord 2Qute and… DSD 128 too are playing without hiccups (… so far, 30 minutes into an album)

Hi @pl_svn ----- Thank you for the feedback and sharing your observations with us, both are appreciated! I just want to make sure I am understanding this correctly.

You are noticing these “hiccups” with both of your Chord DACS (Mojo and 2Qute) when they are being used with the Aries (+Roon). Taking Roon out of the equation seems to resolve this behavior. However, If you mount them directly to the MacMini, they perform as expected while using Roon.

Moving forward, can you please provide/verify the following:

  1. Screenshots of your device settings in Roon as well as the signal path when you are making this observation.

  2. Out of curiosity, have you tried connecting the Aries via Ethernet to your router? If so, was the experience any different or the same?


I have simular issues with a Chord directly connected using USB to a Ubuntu server running Roon or when connected to a Raspberry PI used as a end-Point connected using WiFi (802-11ac). The “Hiccups” seem to be mostly during the first “30 sec” of an album or after a track changes 1 or 2 for DSD64, more with DSD128 many with DSD256. So not a big problem for me, but it would be very nice if it was fixed.

I have not had this problems using any other software or using 1.2 on a Windows machine.

hi @Eric

been out all day, will take and post screenshots tomorrow

not sure about question 2) :neutral_face:
I have a switch connecting: NAS, Mac mini and Aries
Router too is connected to this switch but via FMCs (switch > media converter > optical fiber > media converter > router)
Aries is set to “wired” (no wi-fi)

only used the Mojo to test if Mac mini itself was the issue: 2Qute is what I use in my sytem
(and, with the Mojo via USB, I had no hiccup at all up to DSD 128 and only a couple very light ones at DSD 256. 2Qute only goes up to 128)

ok, so… this are my Roon and Aries settings screenshots:
(as you can see… no upsampling at all, nor in Roon or on the Aries)

but today (… so far) all is working fine: not a single hiccup since playback started ~40+ minutes ago

would really like, though, to get to the root of this issue I have already experienced/reported more than once :frowning:

it usually happens the first time I play a DSD album that was recently added to my library. then… it does also happen with albums which already were there since a long while :neutral_face:

might this by due to some Roon background activity (… network? … processor? … even though an i7 quad-core should be fully up to the task)?

though… I always check, before starting playback, that background analysis has completed
or… is there something going on, during the first two/three days even after the “spinning wheel” is gone and background analysis has completed?

ok: just finished listening to two DSD-64 full albums
these are the two most recently added to my library (3-4 days ago) and the very same ones I started having issues with when I opened this thread

first Colin Davis/LSO Handel’s “Messiah” -> 2 and 1/2 hours without a single glitch
(yesterday hiccups every few seconds since the very beginning. stopped playback a couple of minutes into it as it was unbearable)

then LSO Mozart’s “Serenade No. 10 for winds” -> a couple of light hiccups on track 4 and another one at the beginning of track 6
(yesterday hiccups starting midway through track 3 and getting worse to the point I had to stop playback)

been playing a couple more, 1h+ long, DSD-64 albums and… hiccups are there

nothing serious as yesterday and the day before: just a few on each album
would really like getting to the root of this and fixing it once for all

even though I have very few DSD albums… might even seriously consider replacing hardware if something (or even all) that I am using (Mac mini, Switch, NAS, Aries, 2Qute) is proven to be the culprit: all I want is forget about it and just enjoy the music :slight_smile:

Hi Paolo,
Even though you have a pretty basic chain, my suggestion would bring it down further to the most basic chain: Mac Mini and 2Qute. Copy a couple of the problem DSD albums to the Mac Mini itself and plug the 2Qute straight into the Mac Mini. If that works without a hiccup, I’d add the switch and NAS back in and see.

1 Like

you mean, Daniel, without the Aries and going just straight USB from Mac mini to DAC?

tried something like that yesterday using a Chord Mojo instead of the 2Qute and… it was working fine up to DSD 256. with files still on the NAS

even tried, and it was fine too, converting DSD to PCM in Roon then via USB to a Metrum Hex and Teac headphone amplifier (files on the NAS)

oh… and everything is also fine without the Mac mini in the chain: just NAS > Aries (using Lightning DS instead of Roon, obviously) > 2Qute

Yes, without the Aries and without the NAS. You want to establish a base working chain using the equipment you want in the chain (2Qute not the Mojo); and then add the other parts of your chain back in one at a time to see what is causing the issue.

ok, will try that tomorrow :slight_smile:

in the while… tried again playing full DSD albums (yesterday I only tested with a few tracks here and there) from the Aries (no Mac mini/Roon) and there’s no issue at all with DSD 64. Only had a couple of hiccups with DSD 128 at the very beginning of two quite large tracks (12m and 15m), when the Aries pre-loads at full network speed

so, after playing a couple of full albums…

Mac mini’s USB > Chord 2Qute (files on Mac mini’s SSD) looks to have no issue at all
also tried DSD 128 (max resolution the 2Qute is capable of)

this should rule out at least the DAC, right?

trying, next:

  • Mac mini USB > Uptone Regen > Chord 2Qute, then
  • Mac mini USB > Uptone Regen > Audiophilleo SE > Chord 2Qute

The DAC and the Mac mini, I think.

You’re on the right track for troubleshooting now, IMO. Kudos to @Rugby.