HiFiBerry DAC2 Pro not recognised

Hi, I bought one of these today but it isn’t recognised by Roon. I have a RPi 4 running RoPieee XL (version 2.596). The problem I think is that this HAT is not available to choose in the drop down in the Ropieee config (my own fault for not checking). I’ve tried ‘HiFiBerry DAC2 HD’ and ‘HiFiBerry DAC+ / DAC+ Pro /Amp2’ but neither of those two work. Should they, or is there another option that does ?

Hi @stevet, can you give a link to your model please. It might be I’m hard of understanding but I can’t see a DAC2 Pro model. There’s a few variations available.

Hi, this is the one, cheers

There’s no Linux kernel version mentioned on the product data sheet but it does list the config is for a DAC+ dtoverlay=hifiberry-dacplus. I suspect you may be right, just checked my drop down and it’s not there. The boards pretty much brand new and patience may be the answer.

If it doesn’t have to be RoPieee then HiFiBerry’s endpoint instructions may get the job done.

Good luck.

Thanks for confirming. I just didn’t think to check this before buying it, sigh.

Same over here.
I bought the DAC2 pro last week.
With RPI3 b+ I can’t get it to work in ropieee XL.
When installed Volumio and select hifiberry DAC plus, together with Roon plugin, all works.

This should work with the Hifiberry DAC+ setting.
If not, feel free to reach out (send me feedback) so I can have a look.


1 Like

Try using HiFiBerry OS instead.


Hi, thanks. It’s definitely not appearing in the list of audio devices in Roon. What do you recommend doing first - I could try taking it out of the HiFi Berry metal case and seeing if it works then (I’ve read that case can be a bit tricky to connect the baords) but that’s fiddly and if there’s a software approach to try first I’d be keen to.

I’ve had great luck with the DAC2 HD both with HiFiBerryOS and DietPi. I’ve not tried RoPieee. Google for “HiFiBerry overlay” for tips that may apply to RoPieee.

root@dac2hd:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplushd], device
0: HiFiBerry DAC+ HD HiFi pcm179x-hifi-0 [HiFiBerry DAC+ HD Hi
Fi pcm179x-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

It runs a little warm but sounds great.

Hi - it is found as a Roon endpoint when I choose ‘HiFiBerry DAC’, but no sound is produced. I’ve reverted to ‘HiFiBerry DAC+ etc’ and sent feedback - cd1291edf3769f4b. Cheers

After testing HifiBerry OS, it works fine with this dac.
But it doesn’t have the (easy) option to turn off the LED’s (bedroom)
Hopefully Ropieee XL will soon integrate this dac


Tried HiFiBerry OS myself at the weekend and it works fine for me too. Can’t use the USB output at the same time though which is what I’d like to do, but happy to wait for Ropieee for that.

I’ve ordered one to sort this out.

1 Like

Ok, I’ve the device and it’s running fine.
You need to select ‘HifiBerry DAC+/DAC+ Pro/Amp2’.

It certainly won’t work if you select the ‘DAC2 HD’ from the pull-down.

There naming is quite confusing, but I’ll add this device in the list and try to make the Hifiberry list of devices a little bit more ‘readable’.

1 Like

Hi - thanks for looking into this. I can’t get mine to be recognised sadly. The USB output is, and the HAT is with HiFiBerry OS is, but the HAT with Ropieee XL isn’t. Wonder if there’s something in the settings that I’m overlooking. If I send you feedback could you take one more look ?

Can you try the beta channel? That’s where I tested it (and already implemented it in the web interface as well).

Hi - yes that works, thanks! Too late now to plug in the USB DAC as well but I’ll have a play with that the weekend. Cheers

1 Like

Thanks for the advice, but when I select the mentioned “ HifiBerry DAC+/DAC+ Pro/Amp2’”, the dac doesn’t show up in the Roon app.(settings, audio).
When selecting the “hifiberry dac” device it is shown in the Roon app but no way to get sound.
What am I doing wrong?

Hi - the beta channel worked for me, with that I can explicitly select ‘DAC2 Pro’ and see it in Roon (and I can also see a USB DAC from the same RPi :slight_smile: ). Cheers