High CPU Usage on Mac Mini 2018

well not very promising @support … sorry to see it happening, this is after woke up my Mac:

wifi trick helped:

Why not just capture a stack trace that will reveal application state e.g. race condition that is the likely root cause of the issue? Post an update that can be selectively installed with extra debug code (break points etc.) which would seem like common best practice to diagnose outside of the lab.

Indeed - Roon full version Auto-update. A few days after the Roon Core update which supposedly contained experimental fixes for the CPU problem. Well: didn’t work because I got the 400% CPU problem as soon as the app restarted.

Stop Roon, toggle WiFi, start Roon: problem gone. Pffew…

I missed it… yeah… that was the right thing to do… next time.

made it to repro it by putting the Mac to sleep again for 5 mins, I have the process sample and the Roon logs, this is the timestamp:

@support guys let me know how to get the files to you.

This second time the wifi trick didn’t work.

@support, just reporting another incident today. 300% CPU happened on both of my MacMini 2018 machines (I have two identical ones). Once in each machine. Both issues were resolved by the wifi on/off tricks.

I never had the issue since the Roon Build 610 upgrade, but just yesterday I upgraded Mac OSX to 10.15.6, again on both MacMinis. It could be related or just a coincidence.

Hello @hgim82,

What is your normal network configuration on the Mac minis? Are they connected to your network via Ethernet? WiFi? Both connected at the same time?


My house is wired on a local subnet and all machines are connected to Ethernet. WiFi is not used for these but only for fixing the problem.

BTW the OSX update was a “supplemental” one released a few days ago. I realized the version number 10.15.6 (which I installed in July) didn’t change with this update. Does Apple do this usually?

They do for supplemental updates.


Hello @hgim82,

Understood that the Ethernet connection is the primary for both computers.

Can you clarify if you normally have the Mac mini WiFi:

A) Totally “Off”
B) “On” but not connected to any networks
C) “On” and connected to your network


@john A) Off all the time.

And when Roon goes bad, I turn the wifi on and it picks up my router wifi, and the problem gets resolved. I then turn off wifi again.

1 Like

Same here on a 2020 MacBook Pro i9 2.3ghz 8 core.
I normally connect on ethernet, turning wifi on and off has cured it for the moment. This is only my third day of the 14 day trial. It’s all great except for this horrible bug.

Hello @David_Tanner1,

What ethernet adapter are you using with your MacBook Pro?


It’s a Anker USB C Hub Adapter, 5-in-1 USB C Adapter with 4K USB C to HDMI, Ethernet Port, 3 USB 3.0 Ports,

we may see some progress here, just saw a post Roon notifying some changes for the 21st, meaning a new version is coming :slight_smile:

Not necessarily :slight_smile: The existing builds may already have the required code for this. It could be as simple as flipping a switch on their end (server-side).

As previously reported, I’ve had the same problem repeatedly on my MacBook Pro regardless of whether I’m streaming on wifi or playing music files stored on my internal disk with no Internet connection.

Is this related? Meanwhile, my problem still persists. A couple of incidents in the past few days. Are you finding the fix?

I am seeing the same on a 2020 i7 iMac, Roon generates close to 50% (or 400% with 8 cores…) cpuload.
The system is connected to ethernet via a 10GBe connection, it does not matter whether Wifi is on (connected or not) or off.

This makes the fans go crazy and basically eliminates the iMac as Roon endpoint.

Please fix it…

@support can you please let us know an update, this has been going for incredible long and still happening, just now: