"History" always displays 15 tracks as "just now"

Hi Eric,

I have 15 tracks that are always in my history, with “just now” timestamp. I have tried to update the timestamp, by playing the track again, but then the particular track is listed twice, once with “just now” timestamp, and once with a correct timestamp, that changes with time.

It occurs on all devices: iPad, phone and windows.

Setup and network is still the same, apart from some updates (roon devices all latest builds, iOS 10.3.3 …)



Hi @Kristof_Baute ---- Thank you for touching base with me!

Moving forward, does power cycling the Sonic Transporter i5 hosting Roon have any affect on this behavior? Can you send me a screenshot of what you are seeing in app?



  • Synology NAS with 800 albums and 16000 tracks
  • Roon server on both ST i5 and laptop running windows 10
  • Gigabit LAN between ST, NAS and endpoint
  • Endpoint: RPi with PianoDAC+
  • Tidal with another 550 albums and 9000 tracks
  • Remotes: on ipad iOS 10.3.1, on nexus 5 (android 6.0.1), on windows 10

Network Configuration / Topology:

  • Router = Asus RT-N66U
  • Switch A = some gigabit switch, do not know the brand. Do not even know if it is involved in this particular communication flow. Could be that involved equipment is directly connected to the router.
  • NAS = Synology DS413
  • Switch B = Netgear GS105E
  • All wall cabling is CAT6. Some ethernet cables between devices could be CAT5e.

Hi Eric,

Power cycling does not have an effect.

The red rectangle are the sticky items. The entry in blue is accurate.



Can you check the date/time on your Core? Most likely, something is off and confusing the app about when these were played.

Hi Mike,

The problem has gone. Probably updating to the latest build did the trick.
You can close this.



I would like to reopen the ticket. The problem has returned. To answer the latest question, @mike, I have checked the time on all equipment. It is all ntp synchronized. It is al correct

Hi @Kristof_Baute ---- Thank you for the follow up and sharing this latest observation with us. My apologies for the slow response here.

Moving forward, may I very kindly ask you to please verify the following for me:

  • Do you notice this behavior on every remote device you are currently implementing?

  • Are you able to delete one of the mentioned tracks from the application successfully?

    NOTE - Deleting content from Roon will permanently remove the media from it’s storage location. If you are going to test this, please be sure to make a copy of the media first.