Horribly Distorted Output from Klipsch R15PM, Previously no issues

Roon Core Machine

Synology DS1819+
Output through Mac Studio

Networking Gear & Setup Details

Eero Pro, Ethernet

Connected Audio Devices

Klipsch R15PM connected via USB A

Number of Tracks in Library

~1000

Description of Issue

Playback from speakers is horribly distorted and clipped, but I haven’t changed any settings that I can tell from when it worked fine. The speakers work in phono via Sonos Port and BT input and hardwired via usb to an iPad and they are fine. Output from a usb hardwired Grace SDAC to a THX AAA 789 and Focal Clear is normal. I seem to have narrowed in on there being some issue with volume leveling and headroom management, as changing those from defaults immediately causes distortion.

This setting causes heavy distortion:

This path with no DSP filters will sound normal, though not adjusted to my liking.

This is with only headroom management turned on and it sounds horrible:

This is the normal path with everything turned on, sounds awful:

This is the SDAC and the Focal’s, 100% fine:

I apologize for any formatting issues, I haven’t posted before. Thank you for any assistance.

Sounds like clipping… is the clipping indicator displayed when you hear distortion?

You should then increase headroom in -0.5 or -1.0 dB increments until the clipping ceases.

No, I’ve seen clipping in the past and am familiar with the indicator turning red to show that. There’s no clipping showing either with headroom management on or off. Any increase in headroom management makes no difference at all. At zero it is fine, at -1 it suddenly becomes horrible. Maxing it out makes no difference.

Andrew, if you play a 24-bit source with no DSP, does it sound fine?

The clipping indicator only works when headroom is enabled.

If headroom is set to 0 dB it’s fine… isn’t that your solution? Or have I misunderstood you?

No it seems like only 16 bit. I pulled a 24 bit and it sounds equally horrible.

This is the path for that one, no DSP:

If I leave headroom management off but turn on any other filters, it also turns horrible. So no EQ or speaker setup available.

So it’s 24-bit that’s causing problems. Try to power-cycle the speakers and/or the Mac.

I’m not sure about the 24 bit being the issue. Its true that those are bad no matter what but why would that make a difference to the 16 bit files not working with any DSP applied?

Ive restarted all devices. I’ve removed and re-added the speakers. Nothing seems to make a difference.

I’m open to any and all ideas. I managed to stumble onto settings that worked for me, but I’m definitely an amateur with all this.

If you look at the signal path, the signal is converted to 24-bit before being sent to the output when DSP is used. That’s why I suspected it, since I don’t see any other differences that could cause the issue.

Just for fun, I power cycled the speakers again to no avail. Tried 24 bit on the Focal with the SDAC and it sounded fine with all the DSP on. So far then the problems are with the speakers playing 16 bit with DSP on or 24 bit period.

I gotcha, I did actually see that it gets converted back and forth earlier, though I didn’t know whether that had some effect. Based on that thought, any ideas on how to make 24 bit not get screwed up?

Most probably it’s an issue with the speakers. I’m not familiar with Mac audio stack but I doubt it doesn’t handle 24 bits correctly. I used to have these speakers, and if I remember correctly, 24/96 was working fine through Chromecast audio and optical. I’m not 100% sure though, as the vast majority of my music is 16/44, and you’re using USB.

Sigh. Well what you said got me thinking and I tried the one thing I hadn’t tried yet, which was plugging the USB A cable into an Apple USB A to USB C adapter and plugging it into the back, which is a lightning port. Now everything works fine. It doesn’t explain why the SDAC is fine on USB A in either port. Oh well…

SDAC is using 32-bit though, so it may not be a fair comparison.

Ah. What a strange combination that causes a problem. Well thanks for the assist. I’m glad to have fixed it. It was pretty obnoxious.

1 Like

You’re not the only one. See this, for instance:
https://discussions.apple.com/thread/253826026

1 Like

Interesting find. Perhaps the USB A ports in general just have issues depending on the implementation. There was a power aspect to that thread that was interesting to me, since the Klipsch don’t require power yet the Grace SDAC does.

What do you mean the Klipsch don’t require power?

Think he meant USB 5v power…but not even sure that is correct.