How can i integrate Roon Into squeezebox touch

How can i integrate Roon Into squeezebox touch. I’ve tried everything . Roon is still playing from my Mac mini . How can i play from squeezebox with Roon . I spent hours still nothing

Low-hanging fruit first:

  • Is an instance of LMS still running on your network? (If so – close LMS, reboot your Squeezebox and close/restart Roon(server)
  • Is your Squeezebox running the latest firmware?
  • Is Squeezebox support enabled in Roon (Settings > Setup) – perhaps stating the obvious here, but it can’t hurt to check

If the above is taken care of and your Squeezebox still is not seen by Roon, it may help to enter your Roon(server) IP into the appropriate location on your Squeezebox.

When you say you have tried “everything”, have you tried a factory reset of the Touch and run setup from there?

That seems to have cured every instance of Roon being unable to see the Touch from a device previously connected to LMS.

1 Like

Roon and Squeezebox Touch synched perfectly early on, but SBT has since disappeared from my Manage Devices menu on Roon. I’ve tried power cycling the SBT, restarting Roon and the computer, making sure LMS is off, making sure the SBT software is up to date, etc.

Early problems (and there were many) always cleared themselves up–“no devices found” would, over the course of a few minutes or up to an hour, change to indicate that Roon had found the SBT on its own. Now, the SBT is not visible on my Networked menu, which allows me to think it may be a larger network issue, a variation of which has happened in the past.

In any event, I spend as much time troubleshooting as I do listening to music, and therefore imagining getting rid of Tidal/Roon has become easier than ever. What a wonderful synergy when operational, but for me the ‘moodiness’ of streamed music has become an annoyance.

Airport utility reports that the Squeezebox Touch is on my network, with ‘excellent’ strength, so I can only assume that the issues I’m having remain in Roon’s court…Anyone?

On the SBT screen navigate to change library.

Are you presented here with the machine the Roon core is running on (and only that)?

If so choose it and let us know what happens.


I did a factory reset to get it working. I lost my 192kHz playback (it was a add on) but it works great with Roon. Doesn’t display anything on the screen, but I prefer having the clock!

Now … to get a way to get Roon into my sonos system - thinking line-in from an airplay device might be the best bet here.