How come you don't allow for AFP...?

Hi Mike,

How come you don’t allow for AFP…?
Since most servers (I believe) is SMB, it would be kinda user friendly to allow for the most common server mounting… :wink:

Do you BTW have any ideas of how to make a WD My Cloud remember it’s SMB mount?
I have to remount it every time I close my connection to the server, which kinda sucks.
It would be nice to just start it up and it would work…


Searching the forum is your friend, there is often quite a lot of discussion to catch up on :wink: I hope these links below help … if not then get back to us.

Configuring a WD My Cloud for SMB instead of AFP [Solved]

Watching AFP-Folders is Not Supported

AFP is deprecated … It lacks many features of SMB … You will experience a very poor experience if you use AFP

I had this problem with a My Book Live.

I ended up using ftp which as been solid and loads on every restart.


Hi @Carl,

It is, and I was looking into the WD My Cloud link, but still I have problems with that the server “disconnects” and needs manual reconnecting…
Which is very annoying.

I posted a question in said thread, no answer yet.

I’m very helpful for any help in the matter! :smile:

How do one set this up?

Sorry for being such a novice, all help very much appreciated. :slight_smile:


Hi @Bjorn_Bengtsson

Are you on a mac or windows?

Hi @Wayne_Bull1

I’m on Mac.

Hi @Bjorn_Bengtsson

1, Go to…Finder-Go-Connect To Server
2, Type in the path ftp://192.168.0.XX/XXXX (The 192.168.0.XX will be your nas ip address, XXXX will be the folder where your music is)
3, Click the plus sign next to the address bar.
4, Press Connect. You will have to enter your nas username and password.
5, This should now connect and produce a finder window showing your Nas folder.
6, Go to Settings-Users&Groups
7, Click on your profile and then the unlock button.
8, Click On Login Items
9, Now click the plus icon and navigate to your nas volume which you will see in the finder sidebar.
10, Click Add.
11, Re-lock your profile and then reboot to test that the nas is loading on startup.
12, Open Roon-Settings-Storage-Add Folder and navigate to your nas in finder sidebar.
13, Press ok and your library should load.

Hope that helps Bjorn.


1 Like

Thank you very much @Wayne_Bull1 ! :smiley:
I appreciate it a lot!

Am traveling at the moment. will be able to try it out next week.

Thanks again,

No problem Bjorn