How do I disable MQA HID USB on roon?

Roon Core Machine

NUC11TNKi7, Intel Core 11th gen, 32Gb RAM

Networking Gear & Setup Details

Router TP Link Archer C7, no VPN

Connected Audio Devices

Arcam D33 dac via USB port (connected to Class II high speed port)

Number of Tracks in Library

No local library, only Tidal and Qobuz services

Description of Issue

The issue related to not being able to use the dac connected directly via USB port was said to be solved by disabling MQA USB HID. I don´t see this option on any settings parameters

I don’t have this DAC but based on this post, …

… I suppose it should be here:

and then

1 Like

Thank you. I tried this path, yet, no option with such a name appears:

Well, this seemed reasonably answerable to be, but now I’m lost. I guess we need someone with the DAC after all :slight_smile:

A thought: Is MQA support enabled in the main section further up?

FWIW, I read the other thread. @mjazz wrote that this didn’t help:

But then this was the solution:

I am just guessing as you are surely aware :slight_smile:

1 Like

Good point.

Indeed it was not, as it does not support MQA. Yet, after ou comment, I tried enabling to see if I could get this field to appear, but the given “MQA HID USB” option still does not show.

I understood from other posts the support team needs to parameterize your account someway so that this option starts being visible for the user. I am hoping someone from dev team could confirm and to that for me. I am about to give up Roon. I bought a NUC only for running Rock, but it has been so difficult so far.

1 Like


Yes, I wondered about this as well due to this:

But it seems to me that this was only to enable the diagnostics. Who knows though. I guess you might have to wait for Support to show up, which may take several days though

1 Like

Yes, I got this part. Thanks for enlightening.
I tired USB 2.0 since the beginning. The only part I could not do so far was this MQA HID USB thing. At first I thought it was something like setting MQA to “not supported” as it already was set. Yet, reading again I realized it may be something else. My last drop of hope.

1 Like

I am often quite good at stabbing in the dark, but not so much this time :wink: I’m sure someone else or eventually support will be able to help. Good luck!


Having read the other thread, the solution was oddly by switching to USB class I and then back to USB class II. Worth a try.

Although the OP of that thread said their D33 was on the latest firmware and didn’t help, is yours on the latest.

1 Like


I also tried switching back and forth. Yet, with no positive results.
About the firmware, I also have the latest version.

Having read a wee bit online. The D33 via USB seemed to be more for a PC or MAC. If you are running ROCK on the NUC you won’t be able to install the special drivers needed.
Are you running ROCK or the Windows Roon software?
You could get something like a Topping D10s to convert to Coax.

1 Like

I am trying Rock.
With Windows it works fine, even without any special driver.

1 Like

Unfortunately I feel that’s your solution in this case unless you utilise something such as the Topping D10s. USB powered via source (NUC with ROCK) and converts to either Coax or Optical.

Topping D10s Mini USB DAC ES9038Q2M XMOS XU208 PCM384kHz DSD256 Native Audio Amplifier Decoder Black

1 Like

Can anyone from #support give some help?

Hey @Mercio_Moreira,

It’s great to see you on the Roon Community! You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

For next steps, we’ll need you to refresh your RAATServer database. Please make sure Roon is not running on ROCK or your Windows remote during this process:

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

After you’ve completed this, you’ll need to delete the endpoint_* files from your core database. You can find these files in your file path: Roon\Database\Registry\Core

Once done, you should be all set to go :+1:

I did all this before starting this post.

What I imagine is that Rock is not able to work with my DAC.
I installed Roon over Windows and moved on with life.
I would love this compatibility with Rock to exist somewhere in time.


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.