How do you set up Roon to get bit perfect playback?

Core Machine (Operating system/System info/Roon build number)

iMac / Catalina 10.15.7 / 710

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Apple Airport Extreme / Ethernet and WiFi 5ghz

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

iMac - USB AQ Dragonfly Black / Bluesound Node 2i - Ethernet connected to Peachtree Nova150 / Bluesound Mini 2i - Wifi 5ghz / Bluesound Flex 2i - WiFi 5ghz

Description Of Issue

How do I set up Roon to get “bit perfect” playback?

Show your current signal path

How? What’s my signal path? Please explain.

Have a look here, that may help:

Maybe you could post a screenshot similar to this:

If you want bit perfect playback, why do you have Volume Leveling and Sample Rate Conversion enabled?


You need to turn off volume leveling and turn off the sample conversion to 96kHz.

Honestly, I’m not sure if I know whether or not I like “bit perfect”. I assumed it was the best Roon could do possibly? I have Volume Leveling on because I usually turn on my favorites from TIDAL and put it on shuffle. Volume Leveling eliminates or evens out the changes in volume between songs that aren’t on the same album which is such an annoyance. I enabled Sample Rate Conversion because I thought it would add to sound quality. Not sure if it does or not. I set the “Max Sample Rate (PCM)” at “Up to 96kHz” because my AQ Dragonfly only does up to 24-bit / 96kHz. If I’m mistaken along my line of thinking with these settings and getting less than what Roon has to offer with sound quality - Please advise. Thanks!

Bit perfect means what goes in is what comes out, without change, damage or modification. Doing anything to the bit stream (bit errors, upsampling, volume leveling, DSP, etc), is going to break this. Typically upsampling, volume leveling, DSP would be called "enhancements’, but they will break the bit perfectness. The signal path light shows what’s happening at each stage along the way:

  • Yellow: low-quality (any lossy codec)
  • Green: high-quality (modified, so not lossless)
  • Purple: lossless (what goes in, comes out)
  • Blue: enhanced (user added processing, so not lossless)

I’m really just after the best sound quality without any annoying changes in volume between songs. So, turning off volume leveling causes the annoying changes in volume between songs to come back. I usually just select my favorites from TIDAL, select a track and put it on shuffle. I turned on volume leveling because I had a lot of volume changes between songs. I don’t know of any other way to solve that problem. Also, I’m using TIDAL HiFi but the majority of my music is live CD recordings of contemporary Christian Praise & Worship. Very few of my tracks on TIDAL are in the Masters category. The majority are just CD quality recordings. What do you think?

You’re adding a feature giving an enhanced output; not necessarily worse, but also not bit perfect.

1 Like

Is there any other way to eliminate the changes in volume between songs besides using volume leveling?

No. Its an either/or thing. Same with using upsampling.

Audio listening is all about what it sounds like to you. If you don’t think there is a difference in sound between vol. leveling or not, or, if so it is so marginal that the convenience of having vol. leveling is worth it; then you have your answer. Go with what sounds best to you with the convenience you want.

Same for upsampling.


Cool. Thanks for clearing that up for me. I appreciate it.

1 Like

Thanks to everyone who helped me out with my question. I really appreciate it!

Hello @BT_Lancaster, glad you got some help here! Please let us know if you have any further questions.