[How To] - ARC with Synology 2600 Router in UK

Roon Core Machine

Roon on Intel NUC (Intel NUC8i5BEK) via wired IP

Networking Gear & Setup Details

Netgear switch GS105 and GS 108 unmanaged
Synology 2600 router running SRM 1.3.1-9346 update 1
Vigor modem
No network VPN

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“x.x.x.x”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I have tried enabling upnp in my Synology router, and then I also tried a port forwarded rule. I have the same external and internal port, with the same port on the core with a tcp protocol but it has made no difference

In the port forwarding settings I have also set ‘restore upnp rules on startup’ and ‘generate firewalls automatically’, again, no obvious effect.

I am using EE internet provider in the UK, via PPPoE, but I don’t think I have a static external ip.

And I am still getting the error above. Any ideas?

Hi, have you read : Roon ARC with Core on Synology ?

Thanks @SEBASTIEN_MICHEL but I think that relates to a synology NAS, and I am refering to a Synology router.

I have been away for a few days, so just coming back to this now.

Any ideas on where to focus?

I expect the root cause sits with the Viper modem - it is most likely also utilising NAT (as is the Synology), thus creating rhe double NAT issue and the error you are seeing above.

This is an exact replica of the problem I had with the VirginMedia modem. In that instance I logged into the modem and changed it to ‘modem mode’ from ‘router mode’. This disabled NAT on the modem and Roon ARC connected immediately (NB: Synology just needs to have UPNP enabled, manual port forwarding rule shouldn’t be necessary)

Hopefully there is someone on the forums with experience of this modem that can help with how to change the settings

Thanks @Stampie

I have (re)enabled UPnP on the router. As an aside the NAT is also checked. I have not done anything now with port forwarding, its empty.

The model is a Vigor 130 VDSL2/ADSL Modem.

Hi @tahsu , I suggest looking at this page on the Draytek website and placing the Vigor in bridge mode

As said by others, you have to configure the Vigor in bridge mode. And after that when you want to do the portforwarding manually you have to create also a firewall rule. Without a firewall rule ARC is not going to work.

Thanks - do I need to leave upnp on or not? Or do I need to have upnp and portforwarding? I have selected that the router will add firewall rules automatically for port forwarding and upnp currently.

Thanks, will do and I will report back.

When you use upnp (and leave it on) you don’t have to use port forwarding manually. You have to leave automatically adding firewall rules on.
Explanation of the upnp process: Roon ARC is requesting a port to the router. Next the router opens a port and forward this port to Roon Core. At the same time the router creates a firewall rule so the port is open for incoming packets from internet (WAN).

If you want to do this all manually than you have to create the firewall rule manually as well as the port forwarding rule. You can disable upnp in this case.

Thanks for the help!

I have set the router to bridge mode. But I am still getting the same error as originally reported. I have try UPnP and manual port forwarding. When I have the UPnP enabled I saw my NAS but not the Roon Core.

Any more ideas?

What IP address is being shown in the Synology router for the WAN?

(may be called Internet interface)

I am not sure where I am looking, I can see the external IP in the ‘Diagnostic data for Roon Support’ is the same as the IP address recorded Status/Network Center on the router. Is that it?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“x.x.x.x.”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Did you restarted the modem, the Synology router and the NAS after the bridge mode enabling on the modem. Probably you have to disconnect the modem and the router from the powerline for a minute or so.

You state that the ‘router’ is now in bridge mode. I think it is the ‘modem’ that needs to be in bridge mode

Most of the devices supplied by ISPs is actually a combined modem/router/switch and putting it in bridged (or modem only) mode disables all functionality except the modem element.

That is implying that it’s not seeing a CGNAT and that is a public IP address so you should be ok to manually setup the port forward on the synology router and test now.

TBH there aren’t many ISPs in the UK that use CGNAT with PPPoE

Thanks again.

Yes to the modem and router, and the core, but not the NAS, but in theory it has nothing to do with Roon - Core is on seperate Intel NUC.

Sorry, you are correct. The modem is in bridge mode. The router is in router mode.

Ok, sounds like I need to look into this then, although I have tried manual port forwarding with port 55000 and also adding a fire wall rule.

test it with GRC shields up, choose the custom port option and post a screenshot of the result

This was the result.