How to change the user credentials for a network drive?

Core Machine (Operating system/System info/Roon build number)

Mac OS Catalina 10.15.1, MacBook Pro (Retina, Mid 2012), RoonServer 1.7 (Build 505)
Network Storage: Synology DS 1815+

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

I am trying to change the user that Roon uses to connect to our Synology NAS. I’ve tried the instructions located here without success. When adding the new storage, nothing happens… no errors but also no changes. I’ve confirmed that the new credentials are correct and can connect with them on the Mac running Roon server. The location of the share is not changing, just the credentials. How can this be achieved? Is this a bug?

As an aside, it would be great to be have edit capability for existing network storage connections.


I’m not support, but did you try adding user/password in this screen?

Thanks for the reply. I did try. And to add some additional detail since I just went through all my intial steps before replying…

For step 6 in the linked instructions above…

If I click “Browse” on the “Edit Storage Location” screen and then “+ Add Network Share” on the “Choose Music Storage Folder” screen, and I add a connection for the new network user, the “Add Network Share” screen will close successfully without making changes to the “Choose Music Storage Folder” screen. I can then also successfully click “Select This Folder” on the “Choose Music Storage Folder” screen as well. However, when I click save on the “Edit Storage Location” screen I get the error “This folder has already been added.”

Alternately, if for step 6, I first delete the initial network connection on the “Choose Music Storage Folder” screen by clicking the blue x in the left column, before adding the new network connection with the new user, I get the error “Could not connect to share: Unauthorized” on the “Add Network Share” screen. The only credentials that are accepted are the original credentials, even though I’ve confirmed that the new credentials are valid on the Mac I’m using.

Aha, if you want to delete an old connection from Roon, you should do it from the three dots next to connected storage you want to remove.

Don’t know if that will help, but I’ve run from NAS and changed id/password without any problem, so it’s probably a misunderstanding.

That could be it. When you delete the old connection with the three dots, do you lose playlists, favorites, etc or do they persist?

They persist, as they are in your Roon library. However, the playlists, for example, won’t work if you change the name of the storage.

Still, to be on the safe side you should do a Roon backup first.

Just remove the connection, then re-add and you should get the chance to add a new user/password.
Any storage you add, even if it’s the same, will cause a rescan.

If there’s another way to do it, I don’t know how and someone like @support should say something.

Hi @RoonCoCO,

Yes, they persist. You’ll definitely want to make a backup first (we recommend this before making any database change). When you delete the storage, Roon is still tracking this media in the database, it just becomes unassigned from a storage location. When you add the new storage back in, Roon will scan the new folder and update the path for the media rather than importing it fresh.

If you have any issues with this please let us know!

Hi @dylan ,
I’ve tried the above and just about everything I can think of to change credentials. The only network storage login Roon will accept is the original login. Any thoughts? I can’t even see failed login attempts on the NAS in its logs. It seems like something is failing in Roon itself. Is there a way to clear all network credentials in Roon or something to that effect?


Hi @RoonCoCO,

Dylan is out of the office for a few days, but I can certainly assist you while he’s out. You confirmed that you are able to connect to this share using MacOS Connect to Server feature and the login worked as expected there, correct?

Let’s try this - can you try putting in your credentials for this share in Roon and let me know the exact local time + date in your country when you do so? I can then enable diagnostics mode for your account after receiving this info. Thanks!

Thanks @noris @dylan,
Yes, I have confirmed that I can connect via Connect to Server. I attempted (and failed) adding the credentials at 11:06 mountain time today 12/9/19 in the US. Let me know if there’s anything else I can provide or do after you enable diagnostic mode.


Thanks, @RoonCoCO.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hi @dylan,
I just wanted to check and confirm that diagnostics were successful enabled and that you received the report.


Hi @RoonCoCO,

Please accept our apologies for the delay here. Yes, the diagnostics report was received and is with the technical team. I checked our internal tracker and confirmed that they’re still investigating. Due to some current testing the team’s queue is a little longer than is typical, but I’ll be sure to reach out ASAP once I receive feedback from them on this on, Bryan!


Hi @dylan,
I just did some additional testing and I think I may have found the issue. The new user that has been failing in Roon has a username with a space in it. Spaces are allowed within Synology and on macOS. As a test, I logged in to our Synology and cloned the new user that has been failing. I gave the cloned user a username that does not include a space. This user was able to log in successfully within Roon. Based on this, it seems, my guess, that Roon is not handling usernames with spaces.

Hope this may help. Thanks.

Thanks for the update, @RoonCoCO!

I’ve updated the ticket to include this information so the team can look into it.

Hi @dylan, I just wanted to check in on this issue and see if you had any progress or updates. Thanks.

Hi there. Came here looking for the answer to this and didn’t find it. However, I did fix the problem. Short answer is, I removed a file that I believe indicates the server to auto-login to.

I run a ROCK, so I navigated to the ROCK’s shared “data” folder to: /RoonServer/Database/Registry/Storage, then removed a file called “location_automounts”.

Then I rebooted the desktop client, navigated to “+ Add Folder” and voila, there was an “x” where there wasn’t one before next to the name of the server. Clicked the “x” to remove the old server path, added the folder again with the new credentials, and now my ROCK is busy reindexing all my music. A new file appeared in that folder right away called “loc_[long hex hash]”. Yay!

Had to do this because I had originally set ROCK up to access the volume as an admin (yeah I know). Created a new “Roon” user with its own password instead. Hope this helps!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.