How to connect QNAP Core to USB-DAC connected to PC

Dear everyone,

I have installed Roon (v1.5) to my QNAP TS-251+ (8GB) and it is playing perfectly with my networkbased KEF LS50W and even my old Squeezbox.

I also do have a PC (Win 10, 64bit) with a Denon CEOL Carino, with is basically an USB-DAC I use instead of the PCs onboard soundcard (German Denon Site). When I am at my PC I would like use Roon in connection with the Denon DAC.

Problem: How do I get the Roon Core (QNAP) to recognice the Denon DAC connected to my PC? Is there any way to share it in the network?

Thank you in advance!



Install Roon Bridge or Roon Remote (if you also want the GUI) on the PC.

Doing so will result in a RAAT server process running that can be discovered by the Roon Core.

I think the PC just sees the Denon as a DAC, so if you install the roon client on your PC then the NAS should see the PC as an end point and play to it, it will either see it as a named DAC or as system output, just enable it.
Have a go and see.


Thank you both.

Bridge and Roon are running on the PC. Still, all I get in Settings/Audio (all network-speaker aside) is this
This HDA seems to be some onboard-sound of the QNAP.

When I connect the Denon DAC directly to the QNAP it gets recognised

Hello @Alex,

It looks like some kind of firewall is blocking Roon or RAATServer from operating properly. I would list both as an exception in your Windows Firewall and any Antivirus applications you may have running. Please let us know if that helps.


Hi Noris,

you were right. For some reason some of the settings in Windows Defender/Advanced Settings regarding roonbridhehelper were still on blocking. I deleted/changed those to

and now the DAC is recogniced 4

Thanks a lot!

Best regards

1 Like

Happy to help @Alex! Hope you have a great listening experience :headphones:

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.