How to Get Back Access to my I7 NUC based ROCK

I’ll let you know when I can check the lights. Tuesday is my day off, so not at the shop.

I managed to get in only 20 dives since taking over the shop 5 years ago, and most of those were on my second trip to dive the nuclear fleet at Bikini Atoll a few months after taking over. Last dive was March last year. The up side is that revenue is now 15 times what it was when I took over.

1 Like

Okay, I’m back at the shop. Changed cable and router port.

The NUC is in its connected state. The two lights on the NUC ethernet port are left orange and right green. Right light on the router ethernet port is green.

It’s now in its disconnected state. Lights are the same.

I have powered off the NUC and the modem/router/switch. Powered back up the modem/router/switch. Once it was connected to the Internet I powered up the NUC which got a new IP address. Current assignments as reported by the router are:

Wired Devices

IP Address MAC Address Device Name

1 192.168.15.8 B8:27:EB:E0:7A:08
2 192.168.15.252 B8:27:EB:CF:5D:07
3 192.168.15.7 94:C6:91:17:A3:E1 ROCK
4 192.168.15.13 B8:27:EB:9A:C5:71
5 192.168.15.2 98:E7:F4:4B:D3:11 DIVESHOP-MUSIC

2.4G Wireless Devices (Wireless intruders also show up here)

IP Address MAC Address Device Name

1 192.168.15.4 30:07:4D:85:4D:43 GALAXY-S8
2 192.168.15.6 30:07:4D:7E:E3:D3 GALAXY-S8

2.4G Wireless Guest Network Devices (Wireless intruders also show up here)

IP Address MAC Address Device Name

5G Wireless Devices (Wireless intruders also show up here)

IP Address MAC Address Device Name

1 192.168.15.5 A0:C9:A0:8F:7C:02 GALAXY-NOTE8

After a few minutes the IP address 192.168.15.7 for the ROCK goes as it drops off the network.

I’ll see if I can get a USB Ethernet Adapter and give it a try. Think I’ll also take it home and try it on the network there. (I don’t want to try it on the other dive shop network.)

OK, I think orange and green port lights are bad. They should both be green? Dunno.

You say you have swapped out the Ethernet cable and replaced it with a different cable, that you know is good, and ROCK still couldn’t connect.

If orange and green lights are bad, then the only thing left, apart from a bad cable, is a bad Ethernet port on the ROCK. @AMP are you there?

If you think about it, that makes sense. Your troubles began long before the tech replaced your modem and screwed around with the IP addresses. We just got side tracked on something that didn’t matter?

A computer shop could tell you, but it would cost you $50, or so.

Looks like maybe I need to take this back. -

Hmm, just went down cellar and looked at an RPi endpoint that works. The Ethernet ports are orange and green.

Really confused, gonna shut up now.:zipper_mouth_face:

Sounds like a plan.

So I did that. The ROCK connected and got the IP address 192.168.15.5. With nothing else connected I couldn’t tell if it was actually connected or not.

I waited a while and then connected the laptop. By then the ROCK wasn’t connected.

Hello @Lloyd_Borrett & everyone following this thread,

Apologies for the delay in replying here, I have brought up this case @mike and I wanted to gather all the necessary information and get his take on it before providing next troubleshooting steps.

Since the ROCK can only be accessed temporarily using the web page, there are a few possibilities happening here:

  1. The router isn’t properly distributing IP addresses or there is an IP conflict
  2. There is something going wrong on the BIOS settings side of things
  3. There is something wrong with the network port itself

I would start off by focusing on getting the laptop and NUC stable, so possible resolutions to each above point:

  1. Attempt to use another router, possibly the one you have at home and see if you are running into the same issue. Connect only the NUC, a Laptop and the Router to start off with and see if you can reliably access the NUC.
  2. I have recently seen a report that temporarily disabling the LAN and turning it back on from the BIOS resolved another user’s issue: Can’t Update BIOS on NUC5i3RYH.
    I would connect a Keyboard and Mouse to verify this theory.
  3. If the Ethernet port is indeed damaged, then having the USB to Ethernet adapter will rule this possibility out. Yes, the drivers for the USB to Ethernet adapter should be recognized by the ROCK and having two ROCKs on the same network will not cause issues.

Also just want to confirm, is there anything notable about the network configuration on any of your devices (even the iOS devices)? Possibly a VPN or proxy that you are using? I would start simplifying the network, excluding variables that don’t need to be added and then build from there, I’m confident that we can get this stable, it’s just a matter of pinpointing where the issue lies.

Thanks,
Noris

I’m here, just in a different time zone for a couple of weeks.

Orange and green are correct. That shows linked and negotiated at 1Gbps. When I’ve had networking issues on the NUC it’s never been able to negotiate the 1Gbps link and both lights end up as green.

In those cases it’s typically been a driver issue so this not only suggests that the link is OK, but that the kernel driver is functioning as intended.

1 Like

So I tried the disable and reenable the LAN device in the BIOS.

I turned the NUC off. Disconnected the NUC ethernet cable. Did the NUC BIOS update again, which went okay. Went into the BIOS setup and made sure everything was okay. Disabled the LAN and WAN in the BIOS and saved the setting. Powered up the NUC while still not connected to the router. ROCK boots with RoonOS 1.0 (build 157) stable.

Powered the NUC off. Powered the NUC back on and turned the LAN and WAN back on in the BIOS settings. The NUC powered back up.

Powered the NUC off. Connected the ethernet cable to the NUC. Plugged in a USB drive with ROCK to do a reinstall. Reinstall finished, ROCK rebooted and was assigned IP address 192.168.15.5.

ROCK web interface was accessible on the laptop for a few minutes. Then it disconnected.

One thing that puzzles me. NUC says that it has the Samsung SSD 960 EVO 250GB as its boot drive. Also has the option of LAN : IBA CL Slot 00FE v0110 as a boot drive. Should that be there? Could this be the problem?

The BIOS has the option of doing a network boot (basically a central server hands over all of the boot parameters as well as the OS). Since you were booting ROCK this wasn’t the issue.

Sounds like the BIOS update / reset solved the problem…temporarily…

Right now it’s as simple as I can get it. The NUC and laptop are connected to the router. No VPN or proxy that I’m aware of.

Is everything else disconnected from the router? Just leave the NUC and laptop connected with no other devices. If you have devices which connect via Wi-Fi then make sure they’re powered off (or change the wireless password so they can’t connect). Make sure the laptop is getting a different IP than the NUC and make sure that the laptop only has one connection (either Ethernet or Wi-Fi).

This still sounds like an IP conflict.

Not really. The fundamental problem is that ROCK comes up, gets an IP address, is accessible for a few minutes. then disconnects. That’s where we started. It’s been worse along the way, but that’s still where we are now. However, we may have ruled out a few possibilities along the way.

I’ll defer to @noris at this point - it looks like you’re narrowing down the potential issue. Next thing I’d probably do if possible would be to follow his suggestion about trying another router. Hope you come to a resolution soon.

So I now need to do a 1.5 hour round trip to go and buy a USN Ethernet adapter. Then I’ll try that. Then I’ll probably take it home tonight and try it on my home network as well.

Okay, so a USB 3.0 Gigabit Ethernet Adapter has been purchased and deployed. ROCK booted, router assigned IP address 192.168.15.10. I could access the Roon OS WEb UI for a few minutes from the laptop and then the NUC dropped off the network. In other words, the same behaviour as the NUC’s ethernet port.

So it’s probably not a crook ethernet port on the NUC.

Took the work NUC home and connected it (without it’s external USB 3.0 drive) to the home network. I haven’t tried to simplify this network at all.

It booted up and took a while to be assigned the IP address 192.168.0.51. I could access the web interface for a short time and then it dropped off the network. So that’s now three different modem/router/switch devices this NUC has exhibited this behaviour with.

I powered it up a few times with the same result. Though one time it was 6 minutes before it dropped off the network. I tried to get to the data directory to copy the missing codec file on but couldn’t access it. Not sure if this is because it had already dropped off the network, or because there was another ROCK on the network.

It’s beginning to sound like a hardware issue - as the NUC warms up, something breaks. Have you tried re-seating the RAM and the SSD? If that doesn’t improve matters, can you try replacing each in turn?

Edit: another thought - perhaps the NUC is shutting down because it overheats? Is the fan working? No dust clogging up the vents?

1 Like

Yeah, the thing is, the NUC doesn’t shut down. It just drops off the network.

@Lloyd_Borrett - I’ve lost track, you’ve tried so much. Did you try this? -

In the case of iOS devices that use WiFi, you don’t have to change a password to prevent connection. Just disable WiFi.

Since you’ve already reinstalled ROCK once, another thought (drastic as it may be) is to install WIN10. It won’t cost you any money. You can download a USB installable WIN10 from the Microsoft site. During the install, when it asks for a license, you don’t have to enter any. WIN10 will still run. Don’t know if you need to change BIOS back or anything else, but @Geoff_Coupe can answer those questions. This way we can, temporarily, take ROCK out of the picture.

Once WIN10 is installed, try getting on the Internet. If you can, that will eliminate any port, cable or network problems. I don’t know ROCK, but I’m assuming one can’t get on the Internet with it. If one can, then you don’t need WIN10 for the test.

Other than that, maybe it’s time for a computer store technician to run some diagnostics?

Green/ amber is okay.

Left LED: Amber or green speed indicator. Amber usually the higher speed, e.g. 1000 Mbps
Right LED: Green link activity, so off means no link

The NUC stays running. It doesn’t power down. It just drops off the network regardless of which ethernet connection is used.

I have gone through the scenario of just the NUC and laptop connected with Wi-Fi turned off. Same result.

Tomorrow I’ll open up the NUC and check everything inside is okay. I wonder if there are some diagnostics for the NUC that could be run.

At least I had one success today. Setup my sixth HiFiBerry DAC Pro+. So I now have three RPi based DACs at work and five at home. Sadly everyone is missing out on music at work because of the ROCK problem.

I don’t use ROCK but I’m guessing you can’t ssh into it and run sudo ethtool -S eth0 or whatever interface you are using.

Alternatively, could you hook up a monitor and keyboard? If so, run Ubuntu from a flash drive and see what’s going on using the command line.

https://www.ubuntu.com/download/iot/intel-nuc-desktop