[How To] Nokia Fastmile 5G Modem/router

I have the same problem…Using a Nokia Fastmile 5G Modem/router, Rock connecting via unmanaged switch…UPNP activated. Tried manual port forwarding but did not seem to work.
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xx.xxx.x.xxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Hi @David_Ong ,

Thank you for reaching out for assistance with port forwarding. I’ve split your post into a separate thread so the team and other users can assist you more directly.

Typically, errors like the one you see can be caused by a misconfigured Port Forwarding setting, if you are not seeing Ready listed in Roon Settings -> Roon ARC, please look over this guide before proceeding.

If you have reviewed this guide and still have not resolved the issue, can you provide the following details about your network setup to help expedite troubleshooting?

  1. Do you have any additional network hardware, like additional routers or managed switches?

  2. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  3. Most of the time with 5G modems, port forwarding is not possible due to the ISP Carrier Grade NAT they have in place. You can give it a try, but it may not be possible, please see:


Hi Noris,
Thank you for your reply.

  1. No additional routers and managed switches, tried connecting core to the Nokia Gateway directly but no luck.
  2. No VPN etc
  3. You are correct I believe they have a CGNAT in place and they are not able to offer me a static IP.

Managed to get Arc working using Tailscale VPN , thanks to contributors on Tailscale on other threads

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.