How to Permanently disable Roon Radio

He plays Boccerini after Pink Floyd, and it does not stay turned off when I turn it off.

If there was vote for most annoying Roon feature, Roon Radio is near the top for me.

Thanks,
Goran

1 Like

Hmm If I turn it off it stays off. Will only turn back on if I reset my device and start over. Do you have more than one zone and do you group them? If so check each endpoint has it switched off before they are grouped.

Radio will stay off, once it’s turned off. If you change your endpoind or group/ungroup endpoints then radio will be back on. Probably radio should be off by default, but that’s an argument that’s been had many times.

BTW - The most annoying Roon feature for me is the persistence of Shuffle.

1 Like

I never have Radio on in Roon…

As other have pointed out, the radio on/off gets reset to the default of ON every time I switch devices, which is quite frequent. @support:
This is a DESIGN FLAW. Whether I want Radio on or off is completely unrelated to which device I am listening to.
So one of two things : either make the Radio default to OFF (probably very easy), or make Roon remember my radio setting independent of /remembered over the device selection.

Radio status is a Zone property. It is on by default in a Zone but If you turn it off in a Zone it should stay off in that Zone.

Is anyone in this thread seeing anything different ?

There is a Feature Request thread for a “default to off” or global off capability.

I’ve set this thread to close in two days so that anyone who is experiencing a bug can respond, but otherwise Feature Request is a more visible place for discussion of changes to existing design than Support.

Edit: Removed a line about group behaviour which is more accurately stated by Noris below. The intended group behaviour is that the group has the Radio status of the first Zone in the group.

Just turn it off in the queue for all your devices, then it’s off permanently. Having the ability to decide which endpoints have it is a great feature not a flaw.

2 Likes

No, it’s working as expected, and with the possible exception of defaulting to ON, it’s working as it should.

I don’t know what this means -

If it is meant that radio gets set to ON when Roon switches to a different Zone from the current Zone, that’s not my experience (as long as the switched to Zone didn’t have it set to ON before being switched to).

10 posts were split to a new topic: Transferring zones from Chromecast to HQPlayer inherits radio values

Hello All,

As @andybob mentioned, the Radio on/off settings are saved as zone specific settings. Turning it off for your desired zone should keep it saved as off for that specific zone.

Just a note, if you group the “Radio Off” zone with a “Radio On” zone, the two zones will merge to have the Radio value of the first zone and will retain this value even after they are ungrouped unless manually configured as otherwise when ungrouped.

If you are seeing different behavior and the Radio function for one of your zones turning on after you have turned it off please let me know, otherwise this is expected behavior here.

As for defaulting the Radio function to off globally, please take a look at the feature request thread @andybob linked above.

Thanks,
Noris

1 Like

No. It doesn’t matter how many times I turn it off and for how many devices, it is still coming back on. This is madness.

It should be dead easy to make the default selectable in the general settings. I don’t understand what the problem is here.

Yes, but since no one else is experiencing this problem, I suspect you are not turning radio off.

Exactly what do you mean by this? I think the problem is a mis-communication of terms. When you say ‘devices’ do you mean Zones or something else?

Can you supply some screen shots?

I don’t think snapshots are necessary. Every time I start Roon client (the Roon application on Windows 10), it resets the Radio setting.

When I say devices, it is the things that show up on the Menu > Settings > Audio tab. To me, this dialog shows devices AND zones: you can put your device in any zone you want. By device I mean things like: OPPO DAC, OPPO DAC ASIO, audio card ASIO, OPPO Network, etc.

How I turn off the Radio is: I click on the queue for the device (or Zone if you prefer), then Radio setting is on the far right.

Then I do this for each device/Zone.

But if I terminate the Roon application, every time I start the Roon application again, the moronic Radio setting is On again.

So please tell me what I am doing wrong, or how you guys do it to make the Radio setting stay off.

Thank you very much in advance,
Goran

Well, this isn’t happening for us. Once the Radio is turned off in a zone, it stays off. @noris, perhaps you’d better turn on the diagnostics on @G_Man 's system, to see what’s going on here?

Wow, you can do that? That’s great!

Yes, please, turn on the diagnostics, and I will go about doing my stuff. Hopefully diagnostics can stay on for a few days.

First I will go around to each of the two computers and my phone and tablet and turn off the radio in each zone, and then when I notice it’s back on again, I will let you know.

Thank you,
Goran

Hello @G_Man,

I have gone ahead and enabled diagnostics mode for your account, what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

To have all the necessary information for diagnostics and prepare a case, I kindly ask for you to let me know:

  • The local time in your country (ex. 10:30AM) that you disable the radio for a zone and it turns on again.
  • Which Core you notice this behavior on
  • Which Roon Remote you were using at the time (if applicable)
  • Which Zone you turned off that has turned back on
  • What action caused Radio to turn back on again (Selected another zone and then the previous zone again/Restarted Roon/ect.)
  • Any screenshots that can show this behavior

If you can format your response something similar to the following, it would be the best way to troubleshoot the issue here:

(Core Name) - (Roon Remote if Used) - Turned off Radio for (Zone Name) at (Timestamp) - Radio turned on again for (Zone Name) at (Timestamp) due to (Action Taken)

(Repeat above info for each Zone/Core with the issue)

Please let me know if you are able to provide this information and once you do so I can start a case for you and ask QA to take a look at the diagnostics and what could be going on here.

Thanks,
Noris

Okay, thanks very much. I am willing to provide this information, I just need to wait for it to happen again. I am unclear as to what sequence of actions turn the radio on, but I will watch it more closely and see if I can figure it out.

Thanks again,
Goran

1 Like

Here is the info:
Core name: Morpheus
Roon Remote: on the same computer as the core
Radio was turned off for ALL zones
Radio turned on on the Roon Network zone upon reboot of the core

Thanks,
Goran

Hello @G_Man,

I wanted to check in with you here and see if you are still experiencing the same issue after upgrading Roon to build 360, can you please let me know if so? If you are still experiencing the same issue, I kindly ask for you to provide the timestamps at which it occurs at so that we can take a look at the diagnostics. Please let me know when possible.

Thanks,
Noris