How to play native DSD with McIntosh MHA150 over PC

Just bought a MHA150 headphone amplifier but I have problems to have it played DSF DSD 256 files

Per spec the unit supports DS256. When I select the ASIO device and DSD play option is native it won’t find the audio device and nothing plays.

If I switch to the WASAPI device, Roon does some wired sample rate conversion and plays the file in DSD128 format.

Any idea what’s going on here?

this is really frustrating since everything works fine with my Mojo DAC.

– WW

Here is the sample rate conversion I was talking about. How can I tell Roon not to do it?

Try re-install the ASIO driver that comes with the DAC and try native DSD again. Also try DoP and see whether your DAC can accept it; You DAC must able to support 705.6k for DSD256 DoP transmission otherwise you are stuck using native DSD.

Thx for the reply. I tried uninstalling re-installing the driver with no success on native support. Roon just does not seem to be able to find the Device.

The Device only supports 352.8kHz that’s explaining the down sampling by Roon when playing DSD256 files in DoP. That seems to work now.

Just native does not seem to work. McIntosh is a renowned maker of audio devices. I am surprised that it has not been tested with Roon.

– WW

Here is what I am seeing after trying to play DSD256 in native


Hello @Winter_Wolf,

Are you able to play media in any format to the device using the McIntosh ASIO driver? Is the ASIO driver disappearing as a zone when you try to play back to it?


Here are my settings:

In native mode: Any other formats play fine. Including: Roon MQA tracks 96kHz, 88.2 any FLAC formats up to 384kHz. Just no DSD formats. Neither DSD 64, 128 nor 256. Roon always complains about lost Audio device

When I switch from native to DoP then I can play DSD 64 and DSD128 (the front of my Mc shows DSD64, 128 rather then the PCM equivalent transport frequency.) just no DSD 256 since Roon does the conversion to 128.

Yes the zone disappears for the duration Roon attempts to play the song. It re-appears after maybe 2 seconds

Just had a conversation with the McIntosh support rep.

Here is what he wrote: “Your MHA150 will play DSD files up to DSD256. That said, very few music programs will support this. We test with JRiver and have no problem playing DSD64, 128 and 256. You may want to reach out to Roon tech support and see what they say.”

I confirmed, JRiver plays DSD256 like a charm using bitstream and ASIO. Does this point to a Roon issue?

– WW

Initial dCS method? Isn’t that proprietary to dCS ring DACs or have I missed something?

Tried dCS method. No difference.


To be clear is should be anything but initial dCS method. I would set it to native DSD.

Native is where the problem is. DSD64, DSD128 as well as DSD 256 all suffer under “device loss” when Roon tries to play the song.

@john can you follow this up?

Hello @Winter_Wolf,

We’re in the process of reaching out to McIntosh to see if they’ll assist us in getting this issue resolved for you. Since we do not have the hardware on hand, it’s difficult to diagnose what exactly is happening here. I will be sure to update you when we have more information.


1 Like

Thx John. I messaged you the name of the McIntosh rep I was working with. Maybe he can help.

– WW

I can confirm it works now with the latest Roon updates. Happy I can use my device with roon to its full potential.

Thank you roon!
– WW

1 Like

I also bought the MHA150 yesterday and still have the same problem in 2021!
On my MacBook Pro 16" (2021, M1 Max, 64GB) I can’t use the device setting as max DSD256 but only DSD128 :frowning:

On my PC I have the same problem as described above with wasapi 32Bit/384khz and DSD128. Under ASIO then only 24Bit/384khz but then DSD256. Why not under a 32bit/384khz AND DSD256? Problem of ROON or McIntosh?

Windows is required for DSD256 output to this DAC.

Mac’s cannot do native DSD. You are limited to only using DoP, which will not reach the highest DSD rate, but, 1 lower.