How to remove "ghost" displays

I’ve looked to see if anyone is seeing this problem - but nothing I could find .

I run a Nucleus+ and multiple endpoints - no issues there.

I have a chromecast plugged into my tv that I regularly use as a display only (not as an audio output) and it works well. Over time, several versions of this display have appeared on the displays screen. Although I can enable any of them, only the last will work and I find no way to remove the others - there’s no delete option I can find.

Minor irritation but weird.

Is this the same problem; has come up before if it is?


I think it is the same. Thanks for pointing me to it . I will try some of the resolutions suggested.

Mods - perhaps you can merge these?

1 Like

So I followed the suggestions - reserved the ip address and also locked to a single access point (I run a Unifi network with several access points so this seemed a reasonable idea as I have noticed the chrome/amazon devices tend to roam across the access points if I am not careful)

Thanks again for the pointer - I really must get better at searching the community site :blush:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.