How to stop shuffle and play a list straight from beginning to end

I’m on version 1.7 and listening on a mac. Over the past month or two something changed with the software where my queue appears always on shuffle.

I want to be able to pull a playlist and play from beginning to end. How do I do this. The shuffle issue is driving me crazy. Please help

Once you have selected ‘shuffle’ in your playlist, you will notice in the queue will be highlighted in blue.

Shuffle will remain activiated untill you manually disable it in the queue by clicking on it.
It should then become just black again.

After resarting your Play Alum/Playlist, everything will be play in the expected order again.

Hope this helps


Hi Dirk. I did the above. I took the following steps:

  1. cleared play queue
  2. shuffle icon is clear (white)
  3. returned to play list
  4. clicked white play button beside the track

The upcoming queue is shuffled once again??

Can you please try again, but not clearing the queue first.

So just click stop on what you are playing.
Go to the queue and verify if the shuffle symbol is hightlighted (blue)
Click on it to disable shuffle (black again)

Go back to album/playlist view.
Select playing a another album or playlist .(your current queue is emtied automatically, and filled again with the new tracks)
Check if playing starts with the 1st track (it does with me)

Then return to the album/playlist you actually wanted to play (do not empty the queue, it is done automatically)


Hi @shrimp_creole,

Can you share some screenshots of where you’re starting playback from and what the Queue looks like?


Awesome Dirk! I’m good to go now.

My issue was that I was not hitting the Play Now button on the top left, prior to to hitting the play button within the list. Once I did that, I was fine.

Thank you!

I’m wrong. It is still doing it. I want to be able to play the play list in alphabetical order by the artist, and maybe start mid-alphabet in the playlist.

What I did was: 1) hit Play Now in the upper left of the play list; 2) clicked on artist to sort;) clicked on left play button next to the track.

It is still shuffling. See attached screen shots.

Add images

Hi @shrimp_creole,

We haven’t been able to reproduce the behavior you’ve reported here, so I think we might be missing something. Can you possible record a video of the behavior you’re seeing showing the steps?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.