[How To] - Technicolor FXA5000 Network Gateway/Switch from Telus - ROON Arc Not Connecting - Error 502

Roon Core Machine

Windows 10 Lenovo PC with 8GB Ram

Networking Gear & Setup Details

Telus Fibre Internet with Network hub and Wifi 6

Connected Audio Devices

Roon ARC on iPhone

Number of Tracks in Library

12,911 Tracks

Description of Issue

Trying to setup ARC and keep getting this message. A lot of the others in the forum are getting 504 error, not 502. Tried a number of things within the hub/switch settings and wifi router settings. The PC is connected to the switch though, so I don’t think the WiFi router is an issue.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED XXX.XXX.XXX.XXX:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“XXX.XXX.XXX.XXX”,“router_external_ip”:“XXX.XXX.XXX.XXX”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“XXX.XXX.X.XXX”,“found_upnp”:true}
}

1 Like

Same error here.

Same error here also.

Hey @Jeff_Burke,

Thanks for writing in, and I’m sorry to hear you’re running into issues getting Arc to connect! Both 504 and 502 issues point to a hiccup in the auto setup of port forwarding.

If you haven’t yet, please give the 502 error section of this help article a read:

I’ll be on standby for your reply :+1:

1 Like

Thanks Benjamin,

I’ve tried all of those with no luck. I am not sure if I need to setup port forwarding manually. This shows under my UPNP settings already, sreengrab attached.

Add images

Hey @Jeff_Burke,

Thanks for the info! It does look like we’ll need to get you set up manually. A few follow-up questions for you:

  1. Who is your internet service provider?
  2. Please list the make and model of your modem and router?
  3. Do you have any additional network hardware, like additional routers or managed switches?
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
  5. How is your Roon Core connected to the internet?

If possible, I would suggest setting your router to bridge mode if you’re able. I’ll be on standby for your reply :pray:

  1. Who is your internet service provider? - Telus - Fibre
  2. Please list the make and model of your modem and router? Technicolor FXA5000 Network Gateway/Switch from Telus
  3. Do you have any additional network hardware, like additional routers or managed switches? Yes there is a Wifi 6 Boost wifi router connected to the Telus Gateway/Switch. Also an 8 port D-link switch between the PC and the Telus Gateway/Switch. I took the 8-port switch out of the path and have the same error.
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security? No, none
  5. How is your Roon Core connected to the internet? Hardwire connection to the Dlink Switch which is connected to the Telus Gateway/Switch

Hey @Jeff_Burke,

Thanks for the info. Your switches should be fine if they’re unmanaged. For your Telus router, head into the admin settings of the router, and click on “WAN Services”.

Once there, click on “Show Advanced” in the top, and you’ll be able to port forward. (Click the links for pictures to better illustrate the steps above).

When setting up the new port forwarding rule, use the below information to fill it out:

IP address: The IP address of your roon core
LAN/Private/Internal Port: Port 55000
WAN/Public/External Port: This port must be the same as the LAN/Private/Internal port

A good thing to note, you may need to put your router (or modem router combo) into bridge mode. Here is more information on how to do this.

Let me know if this helps, and if you still run into issues after going through the above :+1:

1 Like

Thanks Benjamin.

I don’t know if I need to add a port forward for both IPv4 and IPv6. Also, the settings I have to work with do not match the settings you/the documentation mention.

I have to enter protocol yupe, WLAN and LAN but neither give me an input box, only the option to select something, see the screen grab. If I select Custom at the bottom it states that port 55000 is out of range.

As far as bridge mode, the WIFI 6 BOOST is in bridge mode already. For the Gateway/Switch I have these options:

Hey @Jeff_Burke,

Thanks for the screenshots! I would test disabling IVP6 if possible.

For the second screenshot, select ‘Full Bridge’ and restart the modem. From there, open Arc>Settings and select ‘Restart Roon Arc’. We may not have to add an additional IVP4 port based on the UPnP settings you shared earlier in the thread.

Let me know how the above goes, and thank you for your continued patience as we hash this out :pray:

2 Likes

Nope, still receiving this:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 162.156.XXX.XXX:XXXXX, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“x.x.x.x”,“router_external_ip”:“x.x.x.x”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.254”,“found_upnp”:true}
}

Hi @Jeff_Burke ,

What is this Datamodel 2 version? Can you try Datamodel 1 please?

1 Like

The bridge mode took down my WiFi network so I had to factory reset the Gateway which now shows I can connect Roon Arc. This is the second time I factory reset and Arc connected properly. Not sure what changes to cause it to go down.

It’s currently on Datamode 2. The bridge mode is off and it’s back to “routing” as the default.

Ok, so after the factory reset on the gateway, it worked for a number of days but then stopped yesterday. I tried switching to datamode 1 bit no change. This is the error I am getting now:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“XXX.XXX.XXX.XXX”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Hey @Jeff_Burke,

I’m sorry to hear you’re still running into connectivity issues. Based on the error code you’re seeing, please try the following:

  1. Try to enable UPnP/NATPMP in the router
  2. Try to manually open the port in your router configuration
  3. Make sure the IP/Port matches
  4. Check for any VPNs or Firewalls (if enabled, please make sure to have Roon setup as an exception)
  5. Check if your modem is in Bridge mode

Hi Ben,

I cannot add a new port forwarder because I don’t have settings/options needed as I mentioned in a previous comment.

When you say router do you mean my WIFI Boost Router? or on the Gateway/switch?

Hey @Jeff_Burke,

It may be best to try and strip down and simplify your network setup as much as possible and test things one step at a time.

Which of the two functions as your primary router? If possible, can you better describe your system setup? I would connect your roon core directly to your primary router, and remove all other networking gear to test.

There seems to be something with your Gateway switch that is reverting the rules you’ve set to allow arc to function properly. Are you able to temporarily remove this switch for your setup and test from there?