HQ Player not detecting streamer/DAC

#1

Hi there,

I am not 100% sure this is a HQ Player issue but thought I would start here. I should also preface that the local area has been having a series of power cuts over the last six weeks, generally only off and then back on after a few seconds later however this obviously plays havoc with NAS, NUCs, switches, modems, streamers etc. The power company don’t have much interest and they haven’t found the problem, great, so they are likely to continue for now, anyway, I digress.

I run a i7 NUC with Windows 10 with my Roon core and HQ Player. I connect across an Ethernet network and I use HQ Player in my lounge set-up where I have an Allo USBridge streamer (on the latest Diet-pi software 6.25.3) into a Mytek Liberty DAC. I use the Pipeline setup functionality in HQ Player with filters provided by Home Audio Fidelity.

I realised I was having a problem when I was pressing play on HQplayer endpoint in Roon and the music was not starting, it has been working really well up until the last few days. Anyway, I started checking back looking for the issue. When checking in the HQ Player settings i noticed in the Output device settings that the NetworkAudioAdapter is still checked but in the Device box my DAC is no longer present, its blank with no option to select anything. I had saved my settings but importing them again makes no difference. I have tried selecting different backends and then back to NetworkAudioAdapter, but again this does not work, its still blank.

The Streamer is definitely up and running as I can log into it via the Allo web interface (it has Roon bridge and NAA Daemon active), and the DAC is up and running, in fact its showing a white LED which indicates it is receiving a DSD signal which is how HQ Player is setup, again this suggests it is working. The endpoint is also recognised in Roon. I have tried restarting the Streamer, DAC, HQ Player, Core and win10 machine in various orders but to no avail. I had power cut yesterday evening and when everything came back online the DAC was present and working, I had a great few hours listening and changing filters etc. Another power cut overnight and now the DAC is not showing again in HQ Player and therefore no music and no amount of soft or hard re-starts to all the various kit seems to make a difference.

If I forget HQ Player and use my previous lounge end point, which is still the same kit so no hardware change, it will play no problem.

@jussi_laako or @support, any idea of what else I could try? I need a method which I can repeat to get it working again, considering the power will most likely keep going off and on in the near future.

#2

Its back! Not really sure why…

I hard reset the USBridge, turned the DAC off then on. No help. I re-enabled NAA Daemon on another endpoint (Allo Digione) to see if I could get that running, HQ Player didn’t recognise anything straight away. I then rebooted the Win 10 PC and waited to see effect, Roon and HQ Player start up automatically. I just checked now, and HQ Player now recognises both endpoints.

Interestingly, and this might be my naming scheme somewhere, but HQ Player recognises the two endpoints but names them quite differently, for example

Lounge:Liberty DAC:USB Audio, Lounge:atm 7059_link, Lounge:atm 7059_link, Lounge:atm 7059_link. These four options are all the USBridge and I have to select the first of these.

Dietpi:snd_allo_digione, this is my office setup.

There is no mention of Dietpi in the lounge endpoint even though both endpoints use it. Just an observation really.

I am not sure what caused the issue in the first place and I am not sure how I might fix it if it happens again. :thinking:

(Andrew Cox) #3

Streaming software generally, including HQP, doesn’t like a Network USB connection to disappear while it is running. So when turning equipment on and off, try to ensure that HQP “sees” the USBridge and DAC (with USB input selected) at all times.

So the on order should be:

DAC, USBridge, HQP

And off in reverse order.

#4

Thanks @andybob - I can try that. I assume that due to everything going off, as with a power cut, it somehow breaks something in this chain??

I have taken to leaving the whole lot on 24/7 including the amp.

(Andrew Cox) #5

HQP has improved at this. I can power off my DAC before closing the server and it’s OK. The last time I had trouble I think it was selecting the TV or computer input to the DAC before closing HQP.

#6

I have woken up to another power cut, great. I tried it on in this order and it doesn’t work unfortunately @andybob. Any other ideas?

#7

I have managed to get it running again with trial and error. So, streamer off then on, then DAC. Restart PC and hence core and HQ Player, back working now.

1 Like
(Marc Salvatori) #8

Have you considered a fanless power-conditioning UPS such as a Furman F1000?

1 Like
#9

I have had brief thoughts but I have no experience with a UPS so I have never followed up. But, I think you are right, I probably need to think about it. I would need more than one though, probably, as the NUC/NAS are separate to the end point/DAC/speakers. I will go and have a read. Thanks.

#10

I have had a bit of a read but its been a bit scatter gun as not sure what I am after. I think I probably need/want a UPS style product for my NAS/NUC that would ‘smooth’ over the short drops in power. I had a look at the Furman but couldn’t see where to buy in the UK. More thought needed here, any ideas for audiophile UPS?? I know I need something producing a sine wave (I think).

Then I probably need something different for my main listening zone, a power conditioner maybe?? Currently I have a double plug which feeds a 8 way Russ Andrews PowerBar for which I included a ‘Superclamp’ option which is supposed to help with surges and spikes. So I am not sure whether I need anything or not yet.

I then managed to look at grounding and Entreq products and got super confused. I think I need a whole power strategy!

(Ged) #11

How come so many power cuts?

#12

Not sure. I rang them up last week. They say they are investigating whilst sounding like they were not. 13 that I have recorded since 21st June.

(Ged) #13

That’s mad for the UK. I wondered if you were in a new town or a new estate. I worked in Milton Keynes in the expansion phase and that really irritating.
As for UPS you don’t need a fancy one all you need is one that will supply enough watts for your longest estimated outage. You can probably get one easily enough that will tell the PC to shut down but if they are short outages I wouldn’t bother.
There are the normal Hi-Fi discussions about the sine wave outputs of a UPS but they are pretty cheap these days to experiment with as you , hopefully, only need it until they sort themselves out.

#14

Yes, its annoying. They (Western Power Distribution) did write to us a few years ago saying they had a fault somewhere but they couldn’t find it. They were sending the helicopter up to look. We did not hear anything from them again on the subject.

(Andrew Cox) #15

Start a complaint and escalate it up to the Energy Ombudsman. Say you want a moratorium on bill payments until service standards are met by the Network Provider.

(Jussi Laako (Signalyst)) #16

This sounds like a problem with multiple USB devices. When you have multiple USB devices, nothing guarantees they come up in the same order every time… So depending on the case, they may come up in a different order.

#17

Any tips on how to ensure endpoints are seen by HQ Player in this scenario? Generally, there is nothing selectable in HQ Player, the box is blank.

#18

What are all of your HQPlayer endpoints (NAA’s) exactly?

You mentioned a DigiOne and a USBridge.

Any others?

#19

No, none, that I know of. When I first started using HQ Player, before all the power cuts, I could generally pick one of the two endpoints in the settings. I have since disabled (not enabled??) NAA for the Digione in the Allo web settings as I don’t intend to as an endpoint for HQ Player. However even when re-enabling neither is visible as an option in HQ Player quite often. I have not had a power cut for a few days so its working now but I have still not cracked the ‘magic’ switch on order to get it to work. Ideally I would like it to be repeatable in case of future cuts.

#20

I’ve had the same issue with a DigiOne after an overnight power cut, a couple times… I needed to re-boot the DigiOne completely…

That solved it all the time.

When I go into my router’s ‘network map’ I see the DigiOne has disappeared, even when power came back on and the DigiOne had power again.

So it’s not just HQP that doesn’t see the DigiOne, but also the router…

Since the router can’t see the DigiOne, the only way to reboot is via a power cycle.

Have a look at your router the next time it happens. If your router can’t see the DigiOne, pull the DigiOne’s power out then re-power. And report back.

I don’t know why my DigiOne had fallen off the router’s radar. Just sharing an observation and what worked for me.

I assume both for you are running DietPi? Maybe it’s something DietPi related. Way beyond my expertise though. Maybe @jussi_laako can have a guess?

I should have caught this similarity earlier. I only just now remembered my DigiOne issues after occasional overnight power outages.