HQPlayer NAA set-up?

Hello,
Sorry if this is a simple question but I now have a NUC with Roon and I intend to run HQPlayer along with it (my NUC is powerful enough and I don’t want to use upsampling since my DAC is an Yggdrasil anyway).
Right now, I am going out of my NUC in USB, into a Mutec MC3+ USB and then in AES into the Yggdrasil.

My question is this: given my set-up, where and how can I install a NAA for HQPlayer?
Thanks for your help!

1 Like

It has to go on a separate network connected device such as a Raspberry Pi or a commercial product with the software such as a microRendu. The USB from this would be where the Mutec and DAC are connected.

1 Like

Thank you Henry. Is there a difference in sound quality between the Raspberry vs Microrendu?

I would say there was. However this would be mitigated in part by your use of the Mutec and using a decent PSU. The biggest issue would be price and the fact the MR is the finished product and the Pi very much a hobby item that needs to be cased or hidden.

The other option is buy a cheap low powered PC. I bought an i3-5015U based PC from China for around $125. I already had an SSD and some memory laying around. More expensive than a Pi but certainly not nearly as expensive as a microrendu. That being said, i did compare my pc to a microrendu that was powered by an LPS-1 and yes, it did sound better. However, the difference in price was significant!

Why would you use HQPlayer and NAA if not upsampling?

I’d use Roonbridge instead. Maybe a PI or microrendu configured as a roonbridge plugged into the Mutec.

There are those who have claimed that just using HQPlayer in pass through mode sounds better than Roon on its own. It isn’t the conclusion I came to although it did open my eyes to the potential benefits of up-sampling into my DAC. I think you need to be a pretty committed tinkerer to go with HQPlayer.

@tboooe, I ran a PiPO X9S with Windows 10 as an endpoint for both Roon and HQPlayer. It doubled as a control console for Roon with its touch screen interface.

exactly what I want to try - pass through mode in HQP

If it’s only pass through mode with HQPlayer you are looking to do then the RPi is very cost effective and simple to implement. I would suggest a 5v linear PSU is a worthwhile upgrade for the RPi.

The MRendu with LPS-1 really comes into its own if you were going to up-sample etc with HQPlayer.

Sorry for reviving an old thread. Could someone tell me if this setup would work?

  • PC in another room as Roon Core, and running HQPlayer doing upsampling to DSD 512 and pcm.
  • ethernet to lounge (main listening area)
  • SOtM sms-200
  • usb cable to Singxer Su-6 (I need the su-6 as it has two IIS outputs for my two dacs in the lounge)

Would the hqplayer running in the pc in the other room have the output set as sms-200 or the singxer su-6?

Another variation is instead of the sms-200, could I do with another small pc in the lounge? So the chain would be:

  • PC in another room as Roon Core, and running HQPlayer doing upsampling to DSD 512 and pcm.
  • ethernet to lounge (main listening area)
  • fanless PC
  • usb cable to Singxer Su-6 (I need the su-6 as it has two IIS outputs for my two dacs in the lounge)

Does hqplayer naa work from pc to pc?

Essentially I would like the upsampling pc in another room so the fan noise won’t irritate me, and I require the su-6 in the chain to output to two IIS devices at the same time.

Ideally I would prefer setup 2 so I can hook up the fanless PC to my TV as I can use it for a htpc and do some Internet surfing on it whilst listening to music.

Either of those setups should be fine. I do this, but with a micro-Rendu and Matrix Audio X-SPDIF2 at the clean end.

The sms-200. You point HQPlayer to the NAA.

Yes. It works from HQPlayer to NAA so long as the software can run on the hardware/OS.

1 Like

Thank you, Andrew.

Assuming I use the second option I posted…

So for pc in other room running the core and hqplayer, in hqplayer settings do I put backend as Network Audio Adaptor or Network Audio Adaptor IPv6? And leave input as blank?

In the lounge pc, in hqplayer settings, for input device I use NAA/NAA IPv6 and for output I leave it as my current Singxer SU-6?

Tried looking for an up to date Hqplayer instruction manual but couldn’t find one…

Oh I found this thread.

Will just follow that then. Thanks!

1 Like

Yes, you can just boot up the provided NAA image on such PC and you are ready to go.

For this the bootable NAA image doesn’t work of course. But if you build it on full OS and NAA software module, yes that works too.

thank you, Jussi. managed to get everything working alright.

  • lounge fanless NUC with just the NAA software running.
  • other room heavy pc with Roon core and HQplayer settings as output > backend > NetworkAudioAdapter and device > NUC: Singxer USB Audio device

using the heavy PC with nvidia gfx card upsampling to DSD512 with temps hovering around 55degC. if i use my fanless NUC to do DSD512 and certain modulators, the fanless nuc temp hits 100degC on all cores…

cheers for all the help, guys!

1 Like

I’m trying to run NAA on my laptop. my laptop uses a Realtek HD Audio.
i’ve had to install asio4all on my laptop so that the primary PC running HQPlayer can see the laptop on the output setting. if i dont have asio4all, i dont see an option on the output setting to stream to the laptop.
it plays music, but there is quite a bit of lag, and on occasion the song doesnt play (and i have to either press Play again or move to another song to “jumpstart” it).
is asio4all the best option i have, or is anything else recommended?

I understand you are using a NAA (networkaudiod) on a Windows PC. You don’t need ASIO4ALL for it, but instead you need to start it with the provided .bat file, but you need to modify it to enable WASAPI backend instead of default ASIO backend.

thanks Jussi. Could you point me in the right direction for a guide that tells me how to do the modification on the .bat file? i downloaded networkaudiod-411 from you file depository.

There’s a file called networkaudiod_name.bat in the zip. This file needs to be copied to same place where the networkaudiod.exe to be used is. Then open the file in Notepad and remove "rem " prefix from the line that has “set NETWORKAUDIOD_BACKEND=WASAPI”. You can also modify name of the NAA by modifying the line “set NETWORKAUDIOD_NAME=Default” that sets the name to “Default”. (note that if you have multiple NAAs on the network, they must have unique names)

Then you just start NAA by using the networkaudiod_name.bat instead.

hmmm what am i doing wrong

Untitled3