HQPlayer no longer outputs [Solved, Restart]

I had All working until tonight I was tweaking some settings and after uninstalling and reinstalling Roon and HQPlayer I can’t get sound. In the picture attached you can see that the HQPlayer zone shows it playing but the main transport will not move.

Hi George,

Can you set out some details of your system as per this thread and provide some screenshots of your HQP front and Settings windows ?

Yes - I will do that tonight.

Another think I noticed is that I couldn’t get HQPlayer to play on its own. I even put a track on the same drive.

It wouldn’t even start playing the track.

Also when I was trying to play it through Roon - it was “blinking” is the best way to describe it


Here is the system.

Enclosure: Fanless solid aluminum case (completely silent) Processor: Intel i7 (kaby Lake) quad-core processor Memory: 32GB RAM DDR4 Storage: 240GB SSD (Samsung PRO) for Windows OS + Roon database etc OS: Windows 10 Pro OS (license included) USB: 4 USB ports for Keyboard, Mouse, and USB drives HDMI: for your monitor (not required once setup is complete) Network: 2 x Gigabit Ethernet RJ45 Power: 19VDC input

Running Ethernet into a Linksys Router and from there Ethernet to an unmanaged Ethernet switch by Netgear to an Ultra Rendu. From there USB out to the OPPO 205 as my DAC. USB NAS drive connected to the Linksys Router.

Attached is a screen shot of the settings window.

Thank you for your help.


So tonight I restarted everything. From the Oppo and ultra tendu to the windows machine Roon and hq player. It’s back to working…except that I get an annoying pop at random times while running DSP at 512Dsd.

Any suggestions?

Thanks All!

Restarting everything will clear out bad states in software and is a good first step when troubleshooting. Glad to hear you’ve got music again.

You spoke about upsampling to DSD but your HQP Output is set to “Auto”. The Auto setting uses the same output format as the input. To upsample from PCM to DSD this should be set to “(SDM) DSD”. HQP will revert to Auto by default if it has lost its settings for some reason (such as a reinstall).

In the settings as shown you haven’t got any headroom in your volume control. Jussi recommends a minimum of -3dB when upsampling to avoid excessive intersample modulation peaks. You can tell if this is happening by the “Limited” counter incrementing.

I use about -8dB headroom because I also convolve some room EQ that needs more headroom. Here are my settings atm:

I’m pretty sure allowing some headroom will fix your sporadic click. If not, try different buffer times and limiting DAC bits to the best your DAC can handle.

If you are doing DSP in Roon and upsampling in HQP then each program will want some headroom. Try 3dB in each to start with and increase if you are getting limited warnings in Roon or HQP. Sometimes a click can occur without triggering a limited alarm, a touch more headroom can solve those.

1 Like

Great reply - thank you! I will try these suggestions tonight.


Just curious - If I select HQP out put to DSD I assume it will work great for all my flac files. How would that affect the output with that setting when playing DSD files? Will I have to change the output?

Thanks again.


Depends what you want to do. If you want to:

  • Upsample the DSD file using same parameters as PCM to DSD then do nothing;

  • Disable all processing and play the DSD file then check “DirectSDM” in the File-DSDIF/DSF window;

  • Convert the DSD file to PCM then uncheck DirectSDM, set the parameters in the DSDIF/DSF window and change the Output to PCM.

Great - thank you!!!

1 Like