I can not play AAC format file, why?

i can not play AAC format file, why?

1 Like

What operating system are you using ?
Where is the file located ?
What is the file ?
What happens when you try to play it ?

There is an ongoing issue with AAC internet radio streams and having this problem with a ticket already in. I find I cannot play AAC files from my local storage either.
This may be a great insight into the issue.
To add to this, AAC via Tidal will not play and I have a few albums from tidal miss labelled AAC which are FLAC and play fine.

I’ve moved your post into the Support category, where it will be seen, and responded to, by a member of Roon’s Support team.


windows 10, nas, AAC apple music, can not play AAC format file

Hello @shing_hong_chan, are you able to play live radio or other AAC files? Is there one file in particular that won’t play?

Hi, I am also having this problem since I updated to Build 667. It affects all AAC files and radio streams as far as I can see. All played fine before I updated to the latest build.

My music files are stored on a QNAP NAS also, is there an issue with QNAP integration?

1 Like


same issue here

i have QNAP core

AAC radio streams does not work

also AAC streams from tidal does not work

i need to restart the endpoint (Naim uniti atom) to stream something else…

All acc file can not play only on QNAP nas.

It’s a bug due to latest QNAP firmware (maybe combined with latest Roon update). I’ve read that Roon is aware and will likely come with a fix some day.


The problem seems to be with the version of ffmpeg that is installed in the latest release of the QNAP Operating System (QTS).

You might want to try this, it fixed the issue for me (command line knowledge required)…

  1. Enable the QNAP Club repository in the App Center (if not already done)

Instructions here… https://www.qnapclub.eu/en/howto/1

  1. Go to the new repo in App Center and install ffmpeg - this will install version 4.3

  2. Open a SSH (putty) session

  3. Find where the current version of ffmpeg lives, mine (v3.3.6) was installed here…

cd /usr/local/medialibrary/bin

  1. Rename it to ffmpeg_OLD

mv ffmpeg ffmpeg_OLD

  1. Go to the location of the new version

cd /opt/ffmpeg

  1. copy it into /usr/local/medialibrary/bin (or wherever your original ffmpeg was located)

cp ffmpeg /usr/local/medialibrary/bin/.

  1. Restart the Roon Core

  2. Hopefully should now play AAC files. If you have any issues, rename ffmpeg_OLD back to ffmpeg again.

It looks like the QNAP installed version of ffmpeg has been compiled with most of the decoders disabled so hopefully they will fix this soon.



i was unable to play on TIDAL (they use lot AAC files) and it worked for me (before I freaked out).

1 Like

Hi Daniel,

I followed your instructions (didn’t use SSH Putty, but WinSCP on port 22). I’m more a GUI user.
And it worked!! My AAC files are rocking again with Roon :partying_face:.

Thank you for your instructions!!


I am unwilling to use Putty and line code to resolve the issue of not playing AAC files. Is there another fix to play the AAC files via QNAP or Tidal in Roon?

I feel your pain here. I didn’t even know what a putty session was but someone held my hand through the whole process whilst onlookers where holding their breath…

Thanks again https://community.roonlabs.com/u/Daniel_Murphy

1 Like

Don’t know if this is any better

Hi Scott,

You don’t have to use putty (or a command line tool) to perform the steps Daniel describes. You can use the tool WinSCP and navigate, like explorer, to the locations as described in the post of Daniel and perform the copy and past actions (no command lines required, just copy and past). However within WINSCP you must login the QNAP NAS with SFTP (port 22) instate. As admin of course.

If you need help, please let me know and I’ll create a small guide.


Hello Pascal, I really appreciate your reaching out and offering to help. Would you please send me the small guide with steps on how to accomplish this update?

Many thanks, Scott

I send you the file. Was it helpfull?

1 Like

Pascal, Thank you for your offer to help and for sending the instructions to me. I hadn’t had much time this week to look into the fix but I did have a little time tonight. I’m happy to say that I followed your steps and I can play AAC files now. Thanks very much for your help. Best, Scott