I can not play AAC format file, why?

Hi,

The problem seems to be with the version of ffmpeg that is installed in the latest release of the QNAP Operating System (QTS).

You might want to try this, it fixed the issue for me (command line knowledge required)…

  1. Enable the QNAP Club repository in the App Center (if not already done)

Instructions here… https://www.qnapclub.eu/en/howto/1

  1. Go to the new repo in App Center and install ffmpeg - this will install version 4.3

  2. Open a SSH (putty) session

  3. Find where the current version of ffmpeg lives, mine (v3.3.6) was installed here…

cd /usr/local/medialibrary/bin

  1. Rename it to ffmpeg_OLD

mv ffmpeg ffmpeg_OLD

  1. Go to the location of the new version

cd /opt/ffmpeg

  1. copy it into /usr/local/medialibrary/bin (or wherever your original ffmpeg was located)

cp ffmpeg /usr/local/medialibrary/bin/.

  1. Restart the Roon Core

  2. Hopefully should now play AAC files. If you have any issues, rename ffmpeg_OLD back to ffmpeg again.

It looks like the QNAP installed version of ffmpeg has been compiled with most of the decoders disabled so hopefully they will fix this soon.

Regards
Danny

10 Likes

i was unable to play on TIDAL (they use lot AAC files) and it worked for me (before I freaked out).
thanks!

1 Like

Hi Daniel,

I followed your instructions (didn’t use SSH Putty, but WinSCP on port 22). I’m more a GUI user.
And it worked!! My AAC files are rocking again with Roon :partying_face:.

Thank you for your instructions!!

3 Likes

I am unwilling to use Putty and line code to resolve the issue of not playing AAC files. Is there another fix to play the AAC files via QNAP or Tidal in Roon?

I feel your pain here. I didn’t even know what a putty session was but someone held my hand through the whole process whilst onlookers where holding their breath…

Thanks again https://community.roonlabs.com/u/Daniel_Murphy

1 Like

Don’t know if this is any better

Hi Scott,

You don’t have to use putty (or a command line tool) to perform the steps Daniel describes. You can use the tool WinSCP and navigate, like explorer, to the locations as described in the post of Daniel and perform the copy and past actions (no command lines required, just copy and past). However within WINSCP you must login the QNAP NAS with SFTP (port 22) instate. As admin of course.

If you need help, please let me know and I’ll create a small guide.

2 Likes

Hello Pascal, I really appreciate your reaching out and offering to help. Would you please send me the small guide with steps on how to accomplish this update?

Many thanks, Scott

I send you the file. Was it helpfull?

1 Like

Pascal, Thank you for your offer to help and for sending the instructions to me. I hadn’t had much time this week to look into the fix but I did have a little time tonight. I’m happy to say that I followed your steps and I can play AAC files now. Thanks very much for your help. Best, Scott

3 Likes

After 6 hours of trying to do this, I have done it.

I’m not IT literate, hence taking the time, but all the guidance above helped, even if it didn’t really make sense to me.

In the end I went with Pascals copy and paste. A bit challenging knowing which bit of the new folder should be copied, but it seems to work.

Thanks you guys…and gals

1 Like

Thanks for this Danny.

2 Likes

Adding my voice as another user with this problem. Roon is running on as SSD drive on QNAP TS451+, which hosts my local music. Roon shows “Nothing Playing” when AAC format files are played. Same issue playing TIDAL via Roon.

My workaround inside Roon is to disable Tidal and unselect all AAC files. For streaming, I bypass Roon entirely and use the TIDAL app. Very unsatisfactory.

@Pascal_Simons, I’d also appreciate getting a copy of your guide, if possible. Thank you!

Success! Thanks very much for this.

2 Likes

QNAP have another firmware update available, will loading this mean I have to fix the AAC bug again?

Possibly you will need to change it to point to the other version of ffmpeg again.

Thanks. Now, it`s work!!

1 Like

Hi Chris,

I updated my QNAP firmware yesterday (TS-251) and the ffmpeg file hasn’t been changed. Which means the fix is still in place (but also means that QNAP haven’t fixed the bug yet). Hopefully will be the same for you too if you decide to upgrade.

Cheers
Danny

Thanks for that Danny, I’ll take the risk later today. :sunglasses:

1 Like

Just updated my QNAP TVS 471 with no issues…
After updating the Multimedia app, I had to do the Telnet thing again to restore AAC playback.

1 Like