I cannot add network share

I would like to add network share, but I cannot add anything.

Iptime N8004ns-m is a HUB for ethernet. It can support NAS itself with extra usb or hardware. Window FileShare Service can be on, and I can login it via Finder on Macbook using SMB. However, I cannot join it on ROON CORE via Macbook. It means only I can see ‘Invalid Network Path’ when I filled out information as I did with Finder. Could you kindly give any advice?


What is the model/manufacturer of the NAS are you trying to add to Roon?

Have you followed the convention listed in our Add Folders By Path guide?

Content Stored On a NAS Drive

  • To add network storage, we recommend using your NAS drive’s hostname, such as \\DISKSTATION or smb://MyNASDrive . You can usually find this information by logging into your NAS., and examples are below.
  • You can also use your NAS drive’s IP address, but note that this can change, depending on your network’s settings.
  • Note : AFP Share are not supported, you must use SMB or hostname to connect to the NAS share. You can find more information about why AFP is not supported here.
  • If you are still having issues with setting up the NAS share, further suggestions can be found in our NAS Troubleshooting FAQ


  • If your Roon Core is running on Windows, the path to your networked folder might look like this:


  • If your Roon Core is running on Mac or Linux, the path to your networked folder might look like this:


  • After you’ve entered the network path in Roon, enter the credentials required to access your NAS. If a username, password, or workgroup isn’t required to access your NAS, just leave the relevant fields blank and click Add Folder

The manufacturer is ‘IPTIME’
The model is ‘N8004ns-m’

This is a HUB for ethernet, and even it can run NAS itself if I insert Storage(usb, hdd) into the HUB. It has a option to open Window File Share with smb1+smb2.

Dose Roon only support the traditional NAS?

On the option to open NAS, I put the host name is ‘gogigogi’, username is ‘admin’, and the password is ‘rhrlrhrl’, which is to login into the FileServer. It certainly supports it on MacBook via Finder with the information. However, I cannot do it on ROON CORE(installed in MacBook) by adding network share.
Feel free to ask me more to know about it.


If the device supports SMB v1/v2 then it should work with Roon. Can you please share a screenshot of the error message you get when typing it in Roon and also let me know the exact local time + date you try to add it?

I’ve just had screenshot which you want. Please kindly give any advice.


Thank you for the screenshot. I have a few suggestions here:

  1. If you remove the workgroup of roon from both the IPTime web config and the Roon “Add Network Share” window, is there any change in behavior?

  2. If you try to add a folder even further in, such as your Lossless Jazz folder, does that work? As in the network share location of smb://roonready/(HDD name in Korean)/Lossless Jazz?

  3. I wonder if the Korean characters in the hard drive name are causing an issue here. Could you try creating another share on a USB that contains only English characters and see if that has issues adding to Roon as well?

Thanks to you, we have solved out the issue!.

Here is the solution.

  1. I changed Korean characters to English characters.
  2. the setting was applied and the WindowShare function was stopped and restarted.

Then, It works well on RoonReady. I really appreciate it!

1 Like


Glad to hear that the suggestions helped! I will be marking this thread as [Solved] but if you have any further issues regarding Roon, feel free to reach out to us again. Until next time, take care!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.