I cant find the core using wifi mesh

Core Machine (Operating system/System info/Roon build number)

Mac Pro Mac OS Mojave Roon build no 511

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

TP link M9 wifi mesh connected to the modem/router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

mac Pro with Lynx Studio AES16e PCIE card connected via digital AES BEU cable to Genelec 8351

Description Of Issue
My Mac pro/roon core-ethernet cable connected to a network switch. The network switch is connected directly to the modem/router. My TP link is connected directly connected to the modem router. When I choose to connect my ipad to the wifi mesh I cant connect to the core unless I used the SSID of the modem router. But I dont have a stable signal since the modem/router is weak compare to the wifi mesh. How can I fix this problem. Thank you all the inputs.

Hi @Glen_Mendoza,

Is the TP link working in bridge mode? Are the devices connected via the TP link on the same subnet as the Core?

I’m sorry for my ignorance I don’t know about bridge mode. On the to link mesh advance setting it says it’s operating mode- router not access point. The Mac pro is hard wired to the network switch and the to link is hard wired to the modem router same as the network switch. On my modem/router I only have 2 inputs one for my network switch and the other for my to link.

Hi @Glen_Mendoza,

It sounds like you have two distinct subnets set up here, one subnet resides on the TP-Link and one subnet resides on the modem/router combo. For Roon to work properly, all your devices must be on the same subnet.

I would change the operating mode to access point, that way the TP Link gets the IP address info from the modem/router combo box and all the devices IP address assignment is handled by the modem/router.

Thank you Dylan and Noris for all the inputs in solving this issue. Noris what else should I change in the TP link setting aside from switching to access point?

Hi @Glen_Mendoza,

I would ensure that placing the TP-Link into access point mode disables the DHCP router on it. It should, and afterwards all your devices should be on the same subnet. You can use an app like FING to ensure that the IP address of your Roon Remote and the IP of your Core are in the same subnet (all IP values are the same except the last 3 digits).

1 Like


Everything works fine now. Except a small glitch with my Pixel phone as a roon remote. Everytime I connect to the core using the SSID of the wifi mesh I nreed to restart the core and right away I can connect. But with the ipad pro I instantly connect to the core. Thank once again.

Hi @Glen_Mendoza,

Glad to hear most of the issue is resolved!

That sounds strange. Generally speaking, Android devices are more sensitive to multicast traffic, which Roon uses to discover the Core. If you router or access point has “IGMP Snooping” or “IGMP Proxying” setting, you may want to try to turn this on.