I/O Failure importing music on windows server 2016

Using latest Roon v1.3 64bit, new here so just started my trial. On windows 10 everything is perfect, all the files on my USB drive are imported instantly, however on windows server 2016 standard (core mode) all these files are now classed as “I/O failure” in the skipped files section. Doesn’t seem to even import music from my C drive…
AudiophileOptimizer 2.20 beta 5 is installed and I made sure to install whatever is needed for Roon.

Using i5-4670k PC, 16gb ram, g1 sniper mobo. HQplayer works fine, hoping to combine both.

Been troubleshooting for the last 3 days, tried to add features, edit permission, open firewall etc to no avail. Here are some pics, as you can see 0 files found…

Hi @Manish_Maharjan ----- Thank you for the feedback and sharing your observations with us, both are very appreciated!

Moving forward, to help aide in our understanding of this behavior may I very kindly ask to please provide us with the following:

  • Can you please provide some further insight into your use of Win10 and Win Server 2016? I understand from your report that there was no issues when using Win10 but as soon as as you switched to Server 2016 you started to get the mentioned “IO error” on import.

  • Please provide a sample of media in a shared dropbox link that you are noticing this behavior with with.


Hi, @Eric thanks for your reply.
I use standard windows 10 which has hqplayer installed, I recently installed roon for the first time (64bit build 269) to test out the Audeze presets. All I did was select my USB drive in “+add folder” and it imported 1943 tracks instantly, works with all my devices/settings and has 0 skipped tracks.

On the same hard drive I have WS2016 installed as a separate boot which has audiophile optimizer installed onto it. I also use process lasso and fidelizer but have stopped these for troubleshooting purposes.

I have tried getting it to work with all audiophile optimizer settings reset (although it’s roon compatible and there are options which allow roon to install/run which I have tried). I installed roon 64 bit onto WS2016 with no problems, logged in okay and selected all my drives to be imported including the USB but it shows 0 tracks in total and all 1943 (mostly WAV) tracks from the USB are in the skipped files section because of “I/O Failure”.

Hqplayer imports my music files from the USB (exFAT) in WS2016 perfectly fine. I was able to use the WS2016 install of roon on windows 10 fine so it’s definitely a problem with WS2016.

1 Like

I have the same problem as well with server 2016 core,roon finds my library on my hard drives but i get a i/o when i’m trying to import to roon.In gui mode it’s no problem!

1 Like

Good to know however, there’s no easy way to switch to GUI mode without reinstalling the whole OS again and the point of core mode is its minimal process management hence better performance. :cry:

This error sounds similar to what happens when Roon is installed on a basic Windows Server 2012 R2. That requires the Windows Server Essentials Media Pack to be downloaded and installed on WS2012. See the Roon FAQ

Hi Geoff,
I have the standard version of WS2016 which is supposed to have the essentials pack included, I even tried to install the media pack but it didn’t let me.
Perhaps it’s a hidden feature that was disabled, because I remember going through all my installed features.

Here the only role (in GUI) needed was “Files and storage services” which i’m sure I have.

Good morning gents.
Maybe you guyz can help me out here?Having a problem with that i’m getting i/o errors when roon trying to import my music library,all of my files are upsampled to dsd 128,in gui mode everything works just fine.I’m using the audiophileoptimizer but it’s a no go anyway ,any ideas??

Hey guys – sorry for the slow response here.

@Manish_Maharjan – I know we have a ticket open for this in our system, but feedback has taken longer than we’d like because unfortunately none of our developers are currently running Server 2016. I do want to make sure we resolve this for you, but I also wanted to be clear why this has taken longer than we’d like.

We discussed this just now, and I wanted to mention that this sounds like some kind of missing dependency in Server 2016, since it’s only come up a few times and we have a reasonably large number of people running Roon on WS2016 without experiencing this issue.

We can have our QA look into this, but for now my recommendation would be to confirm you have media packs and any other dependencies in place, and hopefully we’re able to come up with some more specific recommendation. My fear is that we’re going to test, not experience the same issue, and end up where we are now – unsure what distinguishes these two systems from all the other working WS 2016 installs.

We won’t know until we run the tests, so thanks for your patience guys – we’ll be in touch when we have some more news here.

Hello Manish

Please run the WASAPI Injector of AO 2.2.0 Beta 6, to do so follow the steps described in this article exactly and step by step. This should sort out the issue you er experiencing with Windows Server:

The “WASAPI Injector” will re-enable Kernel-Streaming & WASAPI in Server 2016 Core, add the Device Manager as well as the sound control panel back and last but not least will take care that RoonServer and RoonBridge can find all windows components they need to function properly in Core mode.

Very best,

Hello @Geoff_Coupe

If one own’s the AudiophileOptimizer it is not needed to install the Windows Server Essentials Media Pack or the Essentials Role at all. AO takes care of this without the need to install those two components. The system will have a much smaller footprint without all the totally unnecessary components which would otherwise be installed through the essentials role of windows server.

Please see detailed step by step guide over here: https://www.computeraudiophile.com/forums/topic/26766-how-to-roon-and-roonserver-on-windows-server-2012-r2/