iMac Not Scrolling Through Library Properly - SKIPS PAGES

GUI question: I am running Roon on an iMac 27 inch screen in the late 2013 iteration using the High SIerra OS. When I scroll through my library I use the scrollbar on my Logitech MX Master mouse and scroll horizontally (or laterally if that’s the word for it). But lately it has taking to jumpting ahead 3 pages leaving the two it jumped over unaccessible because if I reverse it, it jumps back to the first page. I actually had this problem before once but I cannot remember how I resolved it. Any help would be appreciated.

If I was to guess it’s related to some configuration setting of your Logitech mouse. There is no setting in Roon that would make this happen.

This has to do with the smart scrolling ‘feature’ of the Logitech driver. In Logitech Options, you can set per app settings. Just disable smart scrolling for Roon.

@support I thought it was my mouse. When i went to the Logitech Optkons app and reset everything fo factory settings, the wild scrolling effect stopped, so I thought, voila. However, the problem is back and restoring the mouse settings did not resolve it this time.

I have ROON core installed on an iMac (late 2013). The actual music files are on an external drive. The mouse I am using is the Logitech Wireless MX Master set to original factory settings. When I browse my Roon library, scrolling jumps two or three pages ever time i engage it, the ultimate effect being I am not able to get to much of my music. Moreover, the scrolling seems random. I can scroll at the end of ope page twice and get two different pages where the scrolling stops, I am stumped. My mouse works fine on other applications. I have another Logitech mouse, this one not so fancy and it does the same thing as the MX MASTER. So I don’t think the problem lies with the mouse. But I am open to correction.

Hello @Stephen_McLeod,

Could you post screenshots of your mouse settings in System Preferences, as well as in the Logitech control app?


Hello @Stephen_McLeod,

In the Logitech Options program, there should be a screen where you can set the mouse settings on a per application basis. Try setting the scroll speed for Roon to a low value and see if the behavior improves.

You can find out more about the Logitech Options settings here


1 Like

@Stephen_McLeod Here are my scroll setting. Notice that the top right corner says Roon, whereas yours says All Applications. Just click on it and add Roon as an application. Then disable smooth scrolling.

Okay thanks.

Thanks very much. It’s workin now.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.