Images Not Displaying - In Roon App - With Ipad Mini

My problem is that I recently changed internet providers in my home where the Nucleus is located. I did so to increase my internet speed to 50 MBS, up from 25 MBS. When the switch was made, the Roon App started to behave strangely on my iPad Mini. Specifically, all the images of the albums and bands not showing up on all screens. Before the change - everything worked perfectly in that regard. It is strange that I can ping my internet speed in the house now using an App, and it is significantly faster than when the Roon App was working perfectly. My concern is that with the images not being displayed like that, could I be losing some sound quality as well…?? Hoping you can give me some insight into this issue. Thanks for your help. JR

Hi @Jonathan_Richards,

So we can better assist you, please ]describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

If you use a different remote device do you see the same issue?


I am using a Bluesound Node 2i which communicates with the Roon Nucleus.

I use an iPad Mini as the remote. Not sure what else you might need from me
regarding the network I am using.

What is strange about the situation I am observing, is that all of the
images show up when I first load the App. As soon as I change screens in
the App, the images disappear, more disappear with each new screen I load,
until eventually there are no images shown at all.

Furthermore, if I kill the instance of the App, and re start it again, the
images are back, but only for the 1st screen as depicted above.

Would it be useful to uninstall and re install the Roon App?

I had the installation of Roon / Tidal done for me at the shop where I
purchased the Roon.

What steps do I need to take to make my Samsung Galaxy S9 the Roon remote?
To see if I can replicate the issue?

Looking forward to hearing back from you.


Hi @Jonathan_Richards,

You can install the Roon app from the Google Play store and you should be able to connect to the Core just as you would with the iPad. It would be good to know if it’s limited to the iPad or not.

Yes, let’s try an uninstall and reinstall of the app on the iPad and let us know if that helps.


O.K. - after learning that the Galaxy S9 worked perfectly as a remote, images and all, I went ahead and did the uninstall and re install with Roon App on my iPad Mini. It worked like a charm!

I am back in business once again - images flowing perfectly from all screens.

Thanks for your help!


Hi @Jonathan_Richards,.

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.