Import date lost after adding another drive? [Fixed - Bad Storage Migration]

Hello, I recently added another ssd drive to expand my storage capacity. I used Windows 10 OS to copy my folders to the new drive. How can I maintain my original the import date order before the upgrade? Right now, all the music that was moved has been “reimported” and showing up as “new”.



Hi, @Terrance_Wong, thanks for your report! Could you please describe step by step what you did exactly in this case? Because therea re case when it might be an expected behavior. Anyways, there is an option which might help you:

  1. Go to Settings->Library->Import Settings
  2. Scroll down to Track Import Dates Section.
  3. There are basically 4 options. If you have IMPORTDATE tags you can turn on option which uses them.

Unfortunately, there are no other options, that I can suggest you, without additional info.



I added a drive on my computer, copied over the directories from one drive to another. Added the path of the new drive under Storage. Deleted the files from the original drive. I let Roon scan and removed the missing files, and it reimported the moved files from the second drive.

I wa shoping that Roon would recognize the directories and music files, and automatically relink the database without affecting the import dates.

This is something that Jriver is able to handle easily.


It sounds like both sets of files where available to Roon at the same time… this will result with treating the copied files as “new” as they are in addition to the existing ones.

A workflow that avoids this i# required, some options are:

Don’t added a new Roon Watched folder, just edit the existing one and repoint it to the new location.

Remove the old files from the file system, so Roon knows they have gone … before creating a new Watched folder.

In both of these cases, Roon will know the files have moved and it will retain the existing DB information for them.

To recover from where you’re at … restore you latest Roon backup from before you started copying files to the new drive.

Once restored, force Roon to rescan… it should that the files in the old local have gone and report them as missing.

Then edit the existing Watched folder to point to the new location… Roon will see the files again and make them available to play once more … retaining the existing DB import dates, etc.

Hope this helps.

1 Like

It didn’t work.

I removed the new drive link.
Restored a backup prior to adding the new drive.
Roon restored properly and identified all the missing files, I did not clean it from the DB.
Relinked the new drive.
Roon started to reimport from the new drive.
All the music is showing up as new again.

Previously, I cleaned the missing files before linking to the new drive, and obviously that didn’twork either.

Yep, doing that would definitely wipe the album data from the Roon DB and thus it would import as new.

However, what you have just described (without cleaning the lib) should have worked … so I’m at a loss.

I think Roon @support should look at your Logs files to see what’s going on here.

Hello @Terrance_Wong,

Sorry to hear that you have been unable to move those files successfully yet. I just want to take a few steps back here and try the process again. Please follow these steps in this order:

  • Restore your Roon database from the backup with the old storage location listed
  • Open Roon Settings and disable the old watched folder location
  • Exit Roon (you must exit Roon after disabling the watched folder)
  • Move/Copy the files to the new location if you have not done so yet
  • Open Roon again
  • Navigate in Settings to your Storage -> Watched folder area
  • Add the new folder location while making sure that the original folder location is still listed as “Disabled”
  • See if the files are now showing the proper import date

More information on regarding moving files can be found in our Knowledge Base article

Please let me know if those steps above work for you or if not we can take a closer look at what could be going on here.


Just completed what you suggested, and its much better, only 6 of the albums are still showing as recently imported, I can live with that.

The only thing I added which I assumed you missed was after I let Room complete the import of the new folder location, I then enabled the location of my original folder.

1 Like

Glad to hear that it worked for you @Terrance_Wong! Please let us know if there is anything else regarding this issue, otherwise wish you a wonderful day!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.