Imported playlist track limit? and limits on Play all tracks in sequences


I’ve created an “All_in” playlist using Foobar2000 that includes all of my music collection - a total of 103051 tracks and saved the playlist as m3u8.

I use this list to keep track of my library while I’m cleaning it (deleting rogue duplicate tracks and re-saving the remaining tracks into this playlist).

I can load this playlist fine using Foobar2000 and many other players including Kodi, Squeezebox player on my phone, and even Windows media player classic (HT MPC) was able to load the entire playlist and play all tracks in random order, but Roon has loaded only a random subset of 17710 tracks from this playlist (see attached screenshots).

I have other large playlists that Roon only loads partially as if it is selecting a subset of tracks in arbitrary order (1442 tracks out of 6320 loaded from a Folk playlist). Is this a bug or a cap limit?


Hi Eli, fellow user here

Playing around with large playlists I have noticed that there are some tracks that act like a bug, all added until a “black” track found and roon stops. I haven’t found anything particular about those tracks. I did experiment with tidal not local files.
Hope others have better answers

Thanks. I don’t think it is the cause because the playlist m3u8 file is alphabetically sorted and Roon still loads about 25% of the track that begins with A up to Z, so the pick is random. Roon just skips many tracks for no reason. There isn’t even a way to create a playlist within Roon that has more than 5000 tracks. Roon can only load 5000 tracks to the queue and has no other way to create the playlist (cannot create a playlist of one genre for example). It’s unfortunate that I threw away $800 on Roon but ended up playing my music using the free Foobar2000…

Selected all track in library (66693) and hit play. Only 9k loaded. I’ll test some more tonight

How were you able to even load 9000 tracks at once? I’m on the latest Roon and it always caps out at 5000 tracks per queue. Makes no sense for free software like Foobar2000 to do something that an $800 software can’t. No matter which playlist I use, Roon only loads a random part of it… BTW, Jriver loads the entire playlist w/o an issue as well.

There’s a limit of 5,000 tracks per shuffle - is that what you’re seeing? The Playlist as a whole should be imported, but if you’ve got Shuffle enabled, then only 5,000 tracks will be randomly selected and added to the Queue. See this thread:


Maybe it is device dependant. What is your Roon Core computer?

Edit: No there is something else, but I do not know what

If I select My Tracks / Select all and hit play

Screenshot 2023-04-12 at 23.14.47

If I select My albums / Select all and hit play

Screenshot 2023-04-12 at 23.15.17

If I select My artists / Select all and hit Shuffle

My biggest playlist has 5078 tracks (maybe I should add that are added in the last 4 months)
Screenshot 2023-04-12 at 23.19.43
And roon plays that almost instantly (2 seconds versus the above mentioned that can take up to 10 seconds /I think)
Screenshot 2023-04-12 at 23.27.38

I’m on a Windows 11 machine (12-gen 15, 16GB RAM). I just used Foobar2000 to create a 4500-track playlist, but Roon thinks there are only 756 tracks in that playlist. The tracks were again picked in random order from A to Z. Not sure what could be causing this because no way it is a bug or a limitation otherwise, we’d see many more complaints. Perhaps it has to do with the location of my library (it’s on an external USB drive). I’ll try and relocate it to an internal drive…

For me all are tidal, I updated the last post with some tests. I’m on a m1 mini 16ram

Unfortunately I have only 20 tracks locally.

Edit: Does roon see any corrupted or unidentified tracks on the ones that you are trying to play?

Thanks. No, it is not the known shuffle limit. I have 100,000+ tracks (all FLAC) in my library. I now cleared the queue and hit home then track and then selected play now, ONLY 6406 tracks were loaded into the queue but not alphabetically. The queue starts with tracks that have symbols in their title and ends at tracks with the letter Z, but there are only 6406 tracks out of the 100K+. What could possibly cause such behavior?

Just a idea. Have you clean up your library?

Roon might not like some tracks

If I go to home/traks order by album name select all and hit play

Screenshot 2023-04-12 at 23.35.34

If I go to home/tracks order by length select all and hit play

Screenshot 2023-04-12 at 23.36.25

Yes, and there are no skipped tracks either. I’m currently running a full integrity scan using a tool called Audiotester that scans audio files to look for corrupted files. After that, I will make a Roon library backup and relocate my entire library to an internal HDD and then restore the Roon backup and see if this helps.

1 Like

Ok, keep on posting. A little late for me but I’m curious on results if changing the HDD. Tomorrow I’ve got a full work day but maybe after tomorrow I’ll keep on testing.

Is there any way to get support from a Roon rep on this topic because Roon is not working as expected for me. First, the playlist limit was partially resolved. Now Roon sees the correct number of tracks in the playlist but will only load a fraction of it to the queue.

Here is what I tried so far:

I ran a forced Roon backup. Then I uninstalled Roon and Roon server from the PC and rebooted.

I’ve moved my music folder to a new location (internal SSD).

I’ve used a free software called Audiotester to scan the entire music folder. After 6 hours, I got a report that out of 103339 files scanned, only 16 files had “loss sync” errors. I deleted those files from the library.

I reinstalled Roon and Roon server and pointed Roon to the new location and let it rescan everything.

Now, both Roon # of tracks and Foobar2000’s report the exact same number (103339).

Edit: this has fixed the missing tracks in the existing playlists. But, if I try to play a playlist which contains more than 5000 tracks, Roon will load about 5000 tracks to the queue.

Using Roon, I selected “Tracks” and hit “Play now”. Out of the 103845 tracks, Roon has loaded a total of 5053 tracks into the queue. So now what am I supposed to do? Give Roon up and stick to using Foobar2000 when I want to play all my tracks. Is Roon only good for playing one album at a time?

I want to play ALL of my tracks and be able to use focus within the queue to find a specific song, but no matter what I try, this is impossible because Roon only loads a fixed 5053 random tracks, some of which are duplicates (same song from different albums). Is this a bug only I’m experiencing? a design flaw? or done on purpose?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.