Importing to ROCK issues

Roon Core Machine

NUC i7 8650

Intel NUC 8th Gen i7

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hi all,

Having trouble importing files from HD to SSD I’ve loaded into my NUC. I’ve formatted the SSD and tried to copy and paste to it. It starts loading and my library in Roon is being updated but I get an error 43 or notification to say not enough space.

I have tried to drag and drop on the Roon app but that doesn’t seem to work at all. It’s a large transfer 6TB or so, the SSD has 8TB so space is there. Weirdly it says not enough space but I’m pulling the info from the same size drive as I want to load to or else I get error 43.

Is there another way I could do this. Internet connection is high speed fibre?


I connected the drive temporarily using a cable like below and did the copy.
iitrust USB 3.0 to SATA Adapter Cable for 2.5" SSD HDD Drives - SATA to USB 3.0 External Converter and Cable,USB 3.0 - SATA III converter

1 Like

I am sorry you’re having problems with file transfer. I assume that you’ve read Roon’s own documentation regarding importing files, so I apologize if you find what I offer too obvious.

  1. What platform are you on? If on Windows, then, typically error 43 indicates a hardware issue.
  2. Did you check if your HDD is not corrupted or defective in any way? There are tools available for scanning and testing a drive on every major desktop OS.
  3. Did you mount (map) the Roon InternalStorage share to your desktop OS? If so, how?
  4. Did you try checking (using your basic File Manager) to see how much space your OS “thinks” there is on that mapped Roon share?
  5. Did you try copying in smaller chunks?
1 Like

@Sean_Flynn What Operating system is are you using to copy the file the the NUC/ROCK? Is the SSD you are trying to copy the second SSD in the NUC? As you cannot store files on the main SSD. The main SSD can only have the OS on it in ROCK. The SSD can not be used for music content.
If you want music content in this device, use another disk either USB attached or internal.

How much Memory does the NUC have? If you indeed have two drives in the NUC as you would need, then I would look at @ged_hickman1 's suggestion. But if you do not want to take the drive out then I would try copying in smaller batches to the NUC. This is what I had to do when transferring my files over.

1 Like

I copied 3tb to a 4tb SSD , it just did it however slowly.

My source was a Windows 10 internal HHD in my desktop PC, destination a 4tb SSD newly formatted by ROCK in a new NUC installaption.

It could be doing some tricky hidden file copies hence the drive full error. I have seen this trying to copy to a nearly full drive where the copy happens before file delete.

Maybe try copying smaller say 1tb chunks

I have also set up SyncBack Pro to keep the new SSD synced with the original drive across the network

Maybe 6tb is just too big at one go

1 Like

Thanks for that , I’ll give that a good i actually have that cable at home. I was doing over the network.
Thanks for tip

Yes thanks for that I’ll give that a hi.


Memory should be sufficient , I’ll try not doing over the network.


Hi there

No this is internal storage , it should be sufficient.

I try not doing over the network instead.


Thanks I’ll try not doing over the network this time.

FWIW I did mine over the network

1 Like

I started doing it now over the network and first folder is nearly done , fingers crossed
Thanks for help.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.