Impossible to connect Roon to my QNAP NAS

Core Machine (Operating system/System info/Roon build number)

macOS Catalina v.10.15.4
Mac Pro (2019)
Processor 3,3 GHz 12-Core Intel Xeon W
Memory 32 GB
Roon Version 1.7 (build 528)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Firmware version:
CPU: AMD Embedded R-Series RX-421ND
Memory: 4 GB

Router: Technicolor TG788vn v2 (provided by my ISP)

All connections via a Cisco SG200-26 Switch (Ethernet)

In general, I don’t have issues connecting devices, computers, printers, hotspots etc to my network.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Benchmark DAC2 HGC connected to my Mac via USB. No issues here.

Description Of Issue

I’ve spent the past ten days trying to connect Roon to my NAS where I store my music as AIFF files, all imported through iTunes/Music over the years. My collection is about 15.000 tracks, organised in subfolders by artist and album respectively.
On the NAS I have completely disabled AFP connections and set the SMB from SMB 2 to SMB 3 (also tried with SMB 2 only).

My NAS has a static IP (
Server name: QNAP-873.
Shared Folder name: JDS_DATA
Tried to connect by using all suggested options:
with username and password and without, with a “.local” ending as some sites suggest and without.
Depending on the input I either get a “Error Loading Folder; UnexpectedError” or a “Could not connect to share; Host not found”.
I’ve tried it with my Mac connected to the NAS (Finder -> Connect to Server) and not connected…
[By the way, when my computer is connected to the NAS, why can’t Roon simply list the NAS in the relevant tab in Storage?]

TIDAL, Qobuz connects and plays without issues.

The only way to play my OWN music is when I go through /Volumes but then Roon will find only about of 85% my albums (approx. 13.000 tracks imported out of the approx. 15.000 tracks). As far as I can see, full albums are completely missing from Roon Library although I can perfectly see and play them in iTunes, Audirvana etc. Again, all files are AIFF.

The audio quality is amazing and I can’t wait to have a fully functioning library to enjoy my music!

Thanks in advance for your help.

Kind regards,


Hi, welcome!

Just a thought - that Cisco is a smart switch, there are some users who report issues with using Roon with such types of managed switch. Are you able to try connecting the NAS direct to the router, or test using another switch that is not managed?

Change tactics: Add some internal or USB storage that contains your library to your Mac Pro or run the Roon Core on your NAS?

I guess that the same holds true for internal storage vs NAS.

This is bad advice. The deficiency is not in the NAS holding the storage, it is that the storage is networked. It’s worse because the NAS is less powerful than the Mac in the above case.


Bad advice? No more networked storage and a powerful core!

I agree that is less powerful but if it’s sufficient (and again no more networked storage).

Hi @John_Saracakis,

As @Rockhound mentioned, managed switches are often trickier to get working properly with Roon.

We discuss a few common changes needed regarding managed switches in our Networking Best Practices guide, but I would suggest temporarily connecting both the Core and the NAS to the router or to an unmanaged switch as a test.

If the issue does not occur with the managed switch bypassed, then we will have a good idea on where to investigate next.

You should also be aware that this router is on our list of routers that may need special settings applied, as per Networking Best Practices Guide:

Technicolor Routers

We’ve seen that some technicolor routers cause Roon to have difficulties communicating to networked endpoints. This can be resolved by adding exceptions for Roon and RAATServer to the router’s IPv6 firewall settings.

Hi Rockhound,
Thanks for the tip! Actually bypassing the Cisco switch did allow Roon to connect. Strangely it would not connect by entering the IP (static) address but with the server name…

1 Like

HI @Noris,
Thanks for the quick reply. As mentioned, I was able to temporarily bypass the Cisco switch by using the spare ports on the router. I have to find out what it is in particular about the smart switch that conflicts with Roon. Any suggestions will be appreciated!

1 Like

Hi @John_Saracakis,

Glad to hear that bypassing the smart switch helped with the issue!

As per Networking Best Practices:

Managed Switches

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.