Impressive... Even through a VPN, roon is snappy!

I’ve come to use roon as a source of information when researching music. Since the app won’t run in a RDP session because of video driver issues I decided to try it through VPN.

The user interface is perfectly useable, I don’t think I would play any music back through the tunnel but at least I have access for research when I’m not home.

1 Like

Others have gotten it working, even 192khz audio!

1 Like

I’m in Canada we have 3rd world internet. :sob:


Great idea.

What hardware (computer, Tablet) and VPN settings did you use? (other than revealing your IPs)

Core is a windows 8.1 machine. Remote is my Macbook Pro OSX 10.10.3

VPN is PPTP supplied by my router. Couldn’t get OpenVPN working, something to do with compatibility with older OpenVPN implementation on my router.

1 Like

Now, I wonder if your Core could be accessed via an iOS or Android Tablet from Wifi hotspot outside your home. In theory it should work.

and if there a smaller Phone App of Roon coming then I will be set!

Finally got OpenVPN working and now everything functions including playback. Not sure why it was messed up with PPTP.

Seems like it’s about 187KB/S for a 16/44.1 flac file streaming or at least for the first few albums I tried.

I don’t have enough upload bandwidth to do 24/96. :pensive:

1 Like

I have 20MBS upload from my FL home and 15 MBS download in Montana so I am assuming I should be able to do it all. Of course the devil is always in the details and implementation.

How much bandwidth is your VPN using?

I only have 6mbps up and 24/96 was cutting in and out. So let’s assume 10mbps should be enough as long as you don’t have to share it with other devices. QOS might help. 24/192 would approximately require 20mbps so that might be pushing it in Montana.

You could always set a max of 24/96 for your Montana client DAC and let roon downsample your >96 stuff.

1 Like

FWIW 24/192 material requires ~9.2Mbps for the Stream itself…not the 20Mbps quoted

Protocol Overheads and other IT requirements will add to that…so the 20Mbps Upload and 15Mbps should be ok…as long as your ISP actually consistently delivers those speeds, which can be a serious question, especially at peak times

I didn’t quote the stream itself requiring 20mbps. I approximated to what would be needed to get stable streaming through openvpn.

And I still don’t think 15mbps would be stable enough to do 24/192.

1 Like

I appreciate the reply.

I will find out in two weeks. I will give it a shot, assuming I can get my VPN up and working properly.

I’m using an AC68U, i had to do some tweaking to get it working with tunnelblick. Apparently newer versions of tunnelblick require a tweaked DH parameters key. Found a reference to the problem and the right key value on the small network builder forum…

I can confirm Roon client on OSX or iPad works fine via openvpn to Linux Roon Core.
iPhone on 4G network was used as tethering device for OSX/iPad. :slight_smile:

However iPhone version of Roon does bot work via vpn. I can see Roon Core and iphone talking to each other on udp 9003 in tcpdump on “vpn concentrator” however iPhone never initiates tcp connection on 9101 to Core as it does when it is sitting on same LAN.

I know running via vpn not currently supported, just reporting more findings, maybe one day that glitch which is now isolated to iPhone (6 plus with iOS 9.3.5) would be fixed as part of other work on iPhone release :wink:

Just found all my VPN PPTP definitions gone into this air after Mac OS Sierra install…not happy Jan! :rage:

They removed it for security reasons. PPTP was known to be very insecure.

ive been using tunnelbrick + openvpn – still works on Sierra

Hmmm, tunnelblick + openvpn no longer works for me. I haven’t really used it for the last year, not sure what broke it.

The remote never finds the core. I can tell it what ip address and it still doesn’t find it.

Hi, I am trying to connect to Roon via VPN from my iPad. The vpn is working as I can connect to my network devices - eg RDP into Windows pc’s, access my NAS via web browser on address However, when I start The Roon app on my iPad, it does not finds my Roon Core/server. Roon core/server is running on a windows 10 machine with IP 192.168.1.yyy and I can also RDP into that machine.

Any advice on what I can do to fix?