Incompatible versions - Core is earlyaccess, remotes not, suddenly can’t connect anymore. Roon not accessible

And that window has now closed after the 6-week period - and stated in the Migration FAQ.

Again that was about migrating back from 2.0 Roon Core back to 1.8 Legacy release.

Or at least I hope, as the ability to use Roon Core 2.0 with a 1.8 based Roon Remote was a good step forward, I trust Roon is not taking a step back.

Well - I see you’ve posted about this in the EA category - we’ll see what Roon Labs have to say…

This is not a solution. It’s a kludge. It was working, somebody threw a switch at Roon and it’s now broken.

1 Like

With respect Geoff , those of use on early access were only using TestFlight for Arc.
I didn’t have TestFlight on my iPad but all of a sudden its required.

As I said before did Roon email early access users to say It would now be required also for Roon?

I guess not so a new test version of Roon has been released requiring testers to install TestFlight on all IOS,moble devises.

the problem is I already had TestFlight installed, because I was an ARC tester/user. opening TestFlight only gives an option to run ARC.

I solved this by finding the URL in step two in desktop safari, manually entering it in mobile safari, then clicking the “start testing link”, which took me to the App Store to download the test version of roon remote.

I installed it, overwriting the existing version, and all seems well.

the messaging about this is very poor, and IME, very un-roonlike.

1 Like

this is not the solution.

Steve, if you are still working through the problem, the links provided in multiple posts above (including mine) provide instructions for Windows/Android as well. Give it a shot. :slight_smile:


Well @Geoff_Coupe if you listen to the users here there seems to be a miscommunication has happened as ROON has changed workflow / dependencies which many were not aware of.

This is something that ROON can embrace and do better for things ahead. It would be the wrong sign to start blaming users who are willing to contribute and support ROON in the earlyaccess program.

1 Like

I guess the other possibility is that some people who were already on early access did not see the instructions about the new broader early access program. They were not aware of the need to install the Test Flight version of Roon Remote. Good communications are difficult especially with multiple groups of people in different situations.


I’m on the early program and I haven’t used it yet. I an having the same problem. I installed Testflight and when I opened it up I received a message “No Apps Available to Test”. How can I go forward?

Roon has been working fine up until yesterday.

Thanks, Rick…

What I’m looking for is how to install the current production release of Android 2.0 remote (in other words remove the Early Access flag from my phone).

I “left the beta program” in Google play, but the same EA version installs.

Thanks again,


From the article:

The process to leave an Android beta is similar to enrollment, but you will have to follow the added steps of removing and reinstalling the apps.

I assume you have an earlyaccess Roon Core running. Did you open this link on your iOS device? It will point you the earlyaccess Roon remote version.

I just had success and am back up and running.

I installed 1.8 Legacy, let it complain about my 2.0 core, then downloaded the current app again. That seemed to do the trick.


Thanks but I decided to get rid of the Early Access version and go to the current production version. I’m not doing any testing for ARC. It all seems to work now.


I’ve read the EA announcement and I don’t see anything that clearly states that EA is an all-or-nothing commitment across core and clients.

Can someone clarify what the long-term plan here is? I was looking forward to being able to move my core into and out of EA when I wanted to use or test an EA core feature or fix. I didn’t expect that I’d also have to onboard the many clients that my wife and I use across phones, tablets, laptops, and desktops. I can’t imagine doing that.

Roon already supports some degree of version interoperability for cases where one tier gets, even temporarily, ahead of another. I hope you folks consider applying that to EA. I’d use it selectively if I could.

You definitely want to be all in or all out. And being in has some “responsibilities”. I think the help explanation if you read it is pretty clear. My read is, if you want to minimize hassle, stay in production and wait for general release of new features. And if you want to see the new features before everyone else, be ready to maintain a slightly unique environment and have the occasional hiccough (as this one above has been). My opinion only, I’m not a mod or employee. But in all the early access programs I know, it’s always “be ready to act as a pro user & deal with the unexpected, you are catching some, hopefully but not necessarily minimal, amount of stuff/bugs/issues on behalf of all the general release users”. I know that’s not what Roon said exactly, but there are a lot of relatively less sophisticated users who are now in early access because they said it was just a costless choice, but this (even if we were warned, and we really truly were) is a perfect example. I’d say take your pick, but it’s not designed (nor is any early access program) to be perfect or easily permeable/simple to move between. If you want simple, stay in prod.

1 Like

Core is 1155
All Remotes 1148

Got the dreaded Incompatible Versions Problem.

Verified I’m Beta in Play Store. Where are the early access Remotes and why isn’t that a pinned post somewhere? This combo worked 2 days ago. Unsure why it stopped working this morning.

Obviously I missed a memo someone please point me in the right direction! I’m dead here. I’m listening on a Sonos speaker with bluetooth. The horror!

And, 1 of my Android tablets just stopped being dumb and connected (still using 1149).

Now Windows and Mac need to figure it out. What on earth am I doing wrong here?