Incompatible versions - Core is earlyaccess, remotes not, suddenly can’t connect anymore. Roon not accessible

Roon Core Machine

ROCK (PrimeMini 4 with Intel Core 8i7-8650U vPro (NUC7i7DN), 2x8 GB DDR4-2400MHz, 2 TB SSD internal storage)

Networking Gear & Setup Details

Router/Modem: Fritzbox 7590, Core connected via Ethernet to Router. No VPN.

Connected Audio Devices

Lumin U1 Mini, connected via Ethernet

Number of Tracks in Library

64k tracks

Description of Issue

Can’t connect iOS remotes (iPhone 14 Pro and iPad Pro) to Core, see screenshots.

Restarted the Core, no effect.

@support Please give advice on how to tackle this issue (e.g. opt out from earlyaccess). Thanks!

After „Go back“ it says „Update required“, but doesn’t do it. When tapping „Connect“ the next screen (1st screenshot) flickers and freezes with „Checking for an update…“


same here, it just happened like one hour ago…

1 Like

Same problem here! Happend just now!

1 Like

And again here, working fine until a few mins ago, same versions as original post

Same here!!

Same here too!!

Core is 1155
All other divices are 1148

Same here. Downloaded fresh MacOS roon from site, same symptoms. Funnily enough, my iPhone can control the zone that’s on the Mac that says it has an incompatible version - it’s playing right now!

This is absolutely crazy - just wanted to play for a big party and ROON no longer works :frowning:

Markus- though it’s a total hack, you could try what I did and control the core / zone that has incompatible versions with a remote that is compatible. For me, my phone was luckily compatible and could still control the zone on my Mac, even though it said it was incompatible with the core.

1 Like

@noris i saw you replied on a different “incompatible versions (1155/1148) thread, so I thought I’d copy you here. Thanks.

Maybe you need the Test Flight version Roon Remote build 1149.

Same here. My issue is for both my iPhone and iPad…both incompatible.

same here …

Yes, that might be the solution. Until today, the production builds of the remotes worked with an earlyaccess Core. I only have an earlyaccess Roon Core and ARC client. Is there a (public) link to the earylaccess remote via testflight?

Maybe here…


That solved it for me! I also had TestFlight of ARC but been using the production version of iOS.
There was no communication of ROON about that.

Well obviously many didn’t know. And in the last paragraph it says:

which so far didn’t work out as planned it seems.
But I hope users affected will find a fix here easily as described.

1 Like

I am running earlyaccess version of ROON as shown in the picture below.

The client is no longer working from Android, iPad, or Desktop (Win). Likely due to the version of the supported client published.


1 Like

Maybe install the Test Flight version of Roon Remote.

I’m wondering if some got pushed to build 1155 before the app stores released the remote??