Incompatible versions - Core is earlyaccess, remotes not, suddenly can’t connect anymore. Roon not accessible

Had the same issue today. I’m on the go and don’t have time to read it all, so apologies if this is bullsh … I simply installed the newer APK and everything works again.
Or, not early access, an earlier one?
I bookmark it every time, hope it helps.

1 Like

@Markus_Hubner is exactly right above. It’s all been laid out perfectly clearly, I just didn’t necessarily read and follow instructions. Thanks Markus!

1 Like

what is the fix exactly?!

how do I get my core off of “early access” and become a normal Roonie again?

1 Like

Read the article that Markus posted above. It’s easy to get the correct versions of Roon for you to have either all earlyaccess or all production / normal. Requires a little bit of work, but they keep that up to date.

To be fair, if you’re in earlyaccess you have to expect some amount more potential disruption than if you’re not. But this one was entirely of my own doing that I didn’t follow instructions.

I’m very annoyed since mine doesn’t work. Long day at work, just wanted to listen to some tunes and unwind. Guess not.

Preface this by stating that I’m not very technical and have been a happy user of my Roon Nucleus. Nucleus has worked flawlessly for months from the day I purchased and then today I get the incompatible error message. Reading up on this, it seems I have a Early Access version 2.0 build 155 on my Nucleus Core. How I have this instead of production I’m not sure since I never elected to have Early Access so my production ipad and iphone are no longer working since they are apparently production. How do I get back to production on the Nucleus? I followed the online help instructions of going back to production and clicked on the downloading the instruction file to put back into my /Data/Reinstall directory for the Nucleus but I get an error message of unable to expand “roon production bin” because unsupported format. What a nightmare. Not sure where to go from here.

1 Like

Update: Fixed. When going back to production, drag the .bin file to the Nucleus (Do NOT open to avoid the error). This did the trick. I clicked reinstalled and that fixed it. Wow. What a mess. I guess the real question here is why did my Roon Nucleus have early access installed…I didn’t install it originally.

Msg states choose your core sonictransporter version 2.0 build 1155 early access

When I push the connect button tells me I’m incompatible versions sonic transport 2.0 build 1155 this phone and also my iPad 2.0 build 1148 production I did reboot my server but still same issue
RoonArc is screaming music

Same here (see Incompatible versions - Core is earlyaccess, remotes not, suddenly can’t connect anymore. Roon not accessible).

Hope this gets resolved soon.

Thanks let’s me know not an isolated issue

1 Like

Yes, just booted up on my mac and get this, downloaded macos remote again and got the following response. For some reason my phone can boot and control the zone which is running on the mac.

same problem

Is the expectation that production client apps should work with early access cores? Or is it that early access is end to end with respect to clients and cores?

I can’t find any language in the docs or announcement that indicates one way or the other.


Same happened for me today.

Reposting instructions from above (it helped me navigate to the solution):

Apparently I had to move all my controllers to the Early access version (hasn’t changed in Arc for me yet though) - That is to say I needed to download the early access version of Roon on my laptop, and install Testflight and the early access for IOS on both phones. Deleted Testflight once complete. Worked a treat.


1 Like

I have the latest of each installed. can someone explain what’s happening here? started randomly this evening. Mobile app deleted and reinstalled, with the same error.

Folks, please make sure your Core, Remote, and ARC are all running Early Access.

If your remote says “Production” it’s not going to work with an Early Access Core, and vice versa.

For iOS users, note the two links here.

Any issues or questions, let us know.


Read the above posts, navigate to the early access instructions, and follow them. There is a link to the instructions posted several times above. Good luck. Let us know if you have any issues.

1 Like

arc is fine, and has been for months, as has been the mobile app.

I’ve had test flight installed for months.

I’m having issues; that’s the point of the thread.

Sure, but can you describe what exactly you did and where you got stuck? Do you have TestFlight installed? Did you get to the specific Roon Remote TestFlight link that Mike linked to above? Was there an issue installing the test flight link?

The members of the community likely can help if you tell us exactly what you did and what happened, but if you aren’t fairly precise it’s going to be very difficult to help you.