Incompatible versions - how do I update?

Roon Core Machine

Connected Audio Devices

Number of Tracks in Library

Not sure - can’t access it,

Description of Issue

I’m trying to get Roon working at all. I can’t connect to the Zen Mini as the error message says I have incompatible versions. I tried installing the Roon Remote legacy app on the iPad, as somebody in this community suggested, but still no luck.
Zenmini 1.8 build 886 beta You have the latest version installed
iPad 1.8 build 1126 production1x

I’m completely stuck. Can you help please?

Hi @Sandy_Mackenzie

It sounds like it’s just a matter of getting all of your remotes as well as your zenmini to the same version.

The legacy versions of Roon 1.8 as well as the current versions of Roon 2.0 can be found here.

Once all devices are on the same version, the issues should disappear.

Please let me know how things go. I will be monitoring for a response.


IOS version are listed on the Apple app store as Roon Remote (Legacy).

1 Like

Because my Core was on an old beta version of 1.8, and Remote on a newer version, I could not access my Innuos Zenmini at all. (See previous screenshot from 2 weeks ago)

Fortunately the wonderful support team at Innuos responded quickly and were able to force a reinstall of the correct Roon Core version, so my problem has been solved. I am remaining on 1.8 for now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.